Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Internet After Restart

12 Apr 2010   #1
Hajukh

Windows 7 Professional x64
 
 
No Internet After Restart

I have Windows 7 Pro x64, and the most recent driver for my mobo's LAN adapter. I can only connect to the internet after disabling and re-enabling the adapter itself.

I don't have Bonjour installed, so the ##Id.string service isn't causing the problem. I don't have a static IP or anything set up, and I'm at college so I plug directly into the wall. No router.

Is there any way to reset my adapter to default settings or something?

Thanks.

EDIT: I found that after disabling Link-Layer Topology Discovery Mapper I/O Driver and Link-Layer Topology Discovery Responder, the adapter works after a period of time. It's still quicker to disable then enable. Can I fix this?


My System SpecsSystem Spec
.
12 Apr 2010   #2
mattys domain

Windows 7 Ultimate
 
 

Have you tried going into Device Manager and uninstalling the LAN adapter. This should cause the OS to reinstall this device and maybe correct the issue.

Make sure you have any needed drivers available (the OS should have these anyway)
My System SpecsSystem Spec
12 Apr 2010   #3
Hajukh

Windows 7 Professional x64
 
 

How would it re-install the device without a connection to the internet to download the driver?
My System SpecsSystem Spec
.

12 Apr 2010   #4
electrotune1200

Windows 8 Pro
 
 

Are you using a wireless router?

If you are, try unplugging your router from it's power source. Leave it powered down for a minute or so. Boot down your PC. Plug the router back in and when all the appropriate lights are flashing, boot up your PC and see if the problem still exists.
My System SpecsSystem Spec
12 Apr 2010   #5
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by Hajukh View Post
How would it re-install the device without a connection to the internet to download the driver?
From system store on your hard disk....


Try this...

In your NIC settings...
Uncheck the boxes for Link Layer Topology Responder, Link Layer Topology Discovery and Internet Protocal V6.

Next... did your school assign you an IP address or does it let you obtain one automatically?

If assigned... highlight Internet Protocol TCPIP v4... and click properties enter the IP, netmask and gateway addresses they assigned you.

If auotmatic... in the TCPIPv4 dialog ensure that "Get Address Automatically" and "Get Gateway address automatically" are both enabled...

Ok your way out and when back at the desktop... restart your system...

Is it working now?
My System SpecsSystem Spec
13 Apr 2010   #6
Hajukh

Windows 7 Professional x64
 
 

It obtains the IP address automatically.

Unselecting TCPIP v6 doesn't make things any faster, and it looks like it takes most people in my school a minute or so to connect to the Internet after reboot. So, I think the issue's on the school's end.

Thanks for the effort.
My System SpecsSystem Spec
13 Apr 2010   #7
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by Hajukh View Post
It obtains the IP address automatically.

Unselecting TCPIP v6 doesn't make things any faster, and it looks like it takes most people in my school a minute or so to connect to the Internet after reboot. So, I think the issue's on the school's end.

Thanks for the effort.
DHCP, the software that automaticly issues IP addresses is a relatively low pirority on most servers, and I'm betting your school's server is a busy one....

So, fire up the box, go grab a jolt cola from the 'frigerator and by the time you get back all should be well.
My System SpecsSystem Spec
Reply

 No Internet After Restart




Thread Tools




Similar help and support threads
Thread Forum
A way to trigger the restart of a program if no internet activity
Good Day I was searching google and other websites for a solution. My problem is my vpn program stops sending and receiving data(Not Hanging) ramdomly. Then i need to manually stop and start the connection in the vpn program.The vpn program have the option of starting the connection on start up....
General Discussion
Internet Connection Lost on Restart
I posted the message below on another popular Windows 7 forum two weeks ago. So far the message has been viewed 267 times, yet not a single reply proposing a solution has been posted. I am hoping that there may be an expert on this forum who can shed some light on the problem and hopefully propose...
Network & Sharing
BSODs and loss of internet connection upon restart
Hi, My computer is relatively recent only being bought back around Feb/March. For the past month the machine has been crashing and when I log back in I need to restart my router in order to get my internet connection back. The strange thing is that other computers connected to the same router...
BSOD Help and Support
My connection to the internet died after a computer restart today
I am not good with computers, so that is out of the way. I have an HP Pavilion dm1 Notebook PC with Windows 7 Home Premium 64-bit. Earlier today I was downloading a patch to the game League of Legends, however, it was failing so I restarted the computer. The next thing I knew, the...
Network & Sharing
Disconnected from internet suddenly, re-connect only after restart!
Hi friends, I am facing this problem since last week. I have a dell inspiron 15 with wireless modem of ITI make supplied by my ISP (BSNL India) running windows 7. While browsing internet normally, suddenly the data transfer stops. Important thing is that ping to google goes through. But i...
Network & Sharing
Have to restart 3 times to get internet
It takes me at least 3 restarts to get connected. The first 2 times there is an X through the Network icon in the task manager. My mother board is a Gigabyte GA-EP35-DS3 and I'm using the intergrated Lan. Also tried to update the drivers from Gigabyte same prob. Also in the Device Manager I get...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App