Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet not found/won't connect at system bootup

27 Apr 2010   #1
Zathras

Win7 Home Premium x64
 
 
Internet not found/won't connect at system bootup

I've been using Win7 x64 for several months now, without significant problems when it comes it internet/networking. But lately, when I boot my PC, more often than not something goes wrong with the network/internet connectivity. When I boot, often Windows doesn't find the internet connection, or, takes a very long time to do so. In order to fix it I have to manually disable & re-enable the onboard Realtek NIC thru device manager, or power cycle the cable modem, and/or reboot the system again, to get connectivity. I can't tell if the problem is the Ambit cable modem or the NIC. My signal quality and strength are just fine.. S/N is 37 dB, and downstream power is -2 dB.

Any ideas why my PC won't connect to internet at boot? How can I diagnose & fix this?

Edit: also my internet speed seems very slow and erratic...sometimes it's testing at 7 mbps down, other times less than 1. for no apparent reason.


My System SpecsSystem Spec
.
27 Apr 2010   #2
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

I have had a lot of problems with these Realtek NIC's. Make sure you have the latest drivers for the NIC. Many times it fixes these issues.
My System SpecsSystem Spec
27 Apr 2010   #3
not so gray matter

W7 Ult. x64 | OS X
 
 

It sounds like your NIC isn't refreshing once it has lost a connection. This should be corrected by updating drivers as mentioned above and/or resetting all network card settings to default.
My System SpecsSystem Spec
.

27 Apr 2010   #4
Zathras

Win7 Home Premium x64
 
 

Thanks for the suggestions. But I can't really see how updating drivers would change the situation, as it was working fine for 4 months on the old driver. And I've heard many horror stories about onboard Realtek NICs getting bricked by driver updates that don't work.

I don't really know how to reset the NIC to default settings, as I haven't touched those from how they originally were. I suppose I could delete the thing in device manager and let Windows reinstall it.

Overall, I suspect my cable modem; when I had an old dying cable modem it had symptoms like this... intermittent loss of signal and terribly inconsistent download speeds.
My System SpecsSystem Spec
28 Apr 2010   #5
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

Try connecting to a friends network and see if the NIC works better, if it does you know your NIC is good. Simple test.
My System SpecsSystem Spec
Reply

 Internet not found/won't connect at system bootup




Thread Tools




Similar help and support threads
Thread Forum
Cannot get my system to connect to the internet DNS error
Hi all, Hope you can help with this annoying problem. I have read and tried everything on this forum. My system uses static IP and DNS. IP:192.168.99.240 Subnet: 255.255.255.0 Gateway: 192.168.99.1
Network & Sharing
operating system not found and no drivers were found eror
as usual I turned off my laptop and after a while a turned on again to use my laptop but it couldn't reach operating system and showed error : " OPERATING SYSTEM NOT FOUND" ! I tried all instructions to solve the problem and finally run by windows start up CD to re-install new windows. this...
Installation & Setup
System Won't Bootup
I just figured out one problem to run into another. After figuring out that the MB was bad and needed replaced all was well for a couple of weeks. Everything was working fine until one day I needed to reboot after updating my anti-virus when things went bad again. :( Here is the symptom: upon...
BSOD Help and Support
Network/internet issue after bootup
Hi, I'm having issues with my network / internet connection after bootup i.e. I have no internet connection after starting computer. There is exclamation mark in network connection icon in task bar indicating limited or no connection. If I unblug & replug network caple on computer issue is...
Network & Sharing
Win7 looses tick to auto-connect to wifi on bootup
Hi, I have a new windows 7 laptop (home premuim x86). I can connect to my wifi as normal and set the connection to Auto connect when network is in range. The problem is soon as i reboot the laptop it looses the setting so i have to go back into the settings for the wifi connection and...
Network & Sharing
System can't connect to internet?
I am using a dial-up connection, meaning the computer is not connected when immediately after powered on. I've noticed my copy of windows 7 can't connect to the net, but I can browse the internet through IE or firefox, weather gadgets and so on. It won't just download updates, send feedbacks nor...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App