Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network instability

02 May 2010   #11
sherisdoppel

Windows 7 Ultimate 64bit
 
 

I have no idea the detail, but all it says on the driver information is the following:
Ethernet: Broadcom NetXtreme Gigabit Ethernet
Wireless: Broadcom 802.11n Network Adapter

It's a laptop, 15" Macbook Pro i7. Driver is provided directly from Apple Bootcamp software. The weird thing is that the wireless works fine on Mac OS X.
I thought it was the Windows disc, so I installed with the same disc on other PC's and Macbook Air. They had no problem.


My System SpecsSystem Spec
.
02 May 2010   #12
Johnathan Lyman

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by sherisdoppel View Post
I have no idea the detail, but all it says on the driver information is the following:
Ethernet: Broadcom NetXtreme Gigabit Ethernet
Wireless: Broadcom 802.11n Network Adapter

It's a laptop, 15" Macbook Pro i7. Driver is provided directly from Apple Bootcamp software. The weird thing is that the wireless works fine on Mac OS X.
I thought it was the Windows disc, so I installed with the same disc on other PC's and Macbook Air. They had no problem.
If it works fine via OS X then I would take a gander that the driver is a bit sub-par.

I haven't tried this before so it may not work but see if you can't run Piriform's Speccy on your BootCamp'd Windows install

Speccy - System Information - Free Download

and post what you have in the "Network" category. If you can't, tell us what System Profiler says on the OS X side of the fence. I want to see if we can't get you a real driver.
My System SpecsSystem Spec
03 May 2010   #13
sherisdoppel

Windows 7 Ultimate 64bit
 
 

My Windows 7 says the same thing I told you so I went to Mac OS X and ran System Profiler and I got this under Ethernet card section on the left panel:

Card: Broadcom 5764
Type: Ethernet Controller
Bus: PCI

There is this card under AirPort section, but i just don't know what it is but I'm posting it hoping that it helps.
Card Type: AirPort Extreme (0x14E4, 0x93)
Firmware Version: Broadcom BCM43xx 1.0

I just want you to know that I really appreciate you trying to help.
My System SpecsSystem Spec
.

03 May 2010   #14
Johnathan Lyman

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by sherisdoppel View Post
My Windows 7 says the same thing I told you so I went to Mac OS X and ran System Profiler and I got this under Ethernet card section on the left panel:

Card: Broadcom 5764
Type: Ethernet Controller
Bus: PCI

There is this card under AirPort section, but i just don't know what it is but I'm posting it hoping that it helps.
Card Type: AirPort Extreme (0x14E4, 0x93)
Firmware Version: Broadcom BCM43xx 1.0

I just want you to know that I really appreciate you trying to help.
I'm glad I am able to help you, even if we haven't gotten very far, yet.

I was able to track down A driver for your BCM43xx for Windows. I cannot guarantee it'll work, though as it's labelled for Windows Vista. The BCM43 series wasn't used in any Windows-based machines.

Broadcom BCM-943xx/BCM43XX Driver 5.10.91.4 for Vista Driver for Windows Vista / Windows Vista64 Free Download - Softpedia

I'd set a restore point before treading these waters just in case.

Let me know how it turns out for you.
My System SpecsSystem Spec
03 May 2010   #15
zzz2496

Windows7 Ultimate 64bit
 
 

Oh, it was a driver issue from the beginning... No wonder your network acting very weird... Good luck finding the right driver...

zzz2496
My System SpecsSystem Spec
03 May 2010   #16
sherisdoppel

Windows 7 Ultimate 64bit
 
 

I just noticed the driver you gave me is mores stable, but when I ping a connection, I get 20% loss as to 0% loss on the other laptop beside me.
I believe this is a driver problem but is there any workaround with this?
My System SpecsSystem Spec
03 May 2010   #17
Johnathan Lyman

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by sherisdoppel View Post
I just noticed the driver you gave me is mores stable, but when I ping a connection, I get 20% loss as to 0% loss on the other laptop beside me.
I believe this is a driver problem but is there any workaround with this?
So now the OTHER computer is having packet loss? What is the make/model of this other laptop?
My System SpecsSystem Spec
03 May 2010   #18
sherisdoppel

Windows 7 Ultimate 64bit
 
 

Nope. The other laptop is having 0% issue.
My System SpecsSystem Spec
03 May 2010   #19
Johnathan Lyman

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by sherisdoppel View Post
I just noticed the driver you gave me is mores stable, but when I ping a connection, I get 20% loss as to 0% loss on the other laptop beside me.
I believe this is a driver problem but is there any workaround with this?
Ok I misread your statement. With the fact that you're not on Windows-ready hardware, it's going to be hard to really pin down the problem. I fear it really is a driver miscommunication, rather than it just being flat out bad and it may be something you will have to live with.

I'm sure there's someone here who may have two more cents to toss in for you, but at this point, I'm sorry, but I'm out of ideas.
My System SpecsSystem Spec
04 May 2010   #20
sherisdoppel

Windows 7 Ultimate 64bit
 
 

It turned out to be the driver. There were bunch of names on the driver so I tried every single one of them.
The first one worked well the most. I contacted Apple for the driver software update and they said they will be giving how it will go in the next few business days.

When I ping my router, I still sometimes get a hitch every 50 packets or so, but still better than not be able to watch Youtube or play some games.
I really appreciate your effort and it was very helpful. Thank you so much!

+REP !!
My System SpecsSystem Spec
Reply

 Network instability




Thread Tools




Similar help and support threads
Thread Forum
Sudden Wi-Fi instability
Hey everybody! Okay, so I got a new computer recently and it worked great on my campus' Wi-Fi network for about a week. Then all of a sudden the stability of my connection dropped down to nothing. For the past several days, I have barely been able to get on the Internet at all and my Wi-Fi...
Network & Sharing
System instability, with BSOD
Hi, I've had my system for just over a year, with no crash issues until this week. I am trying to narrow down what has changed to cause this. The problems: *********skip to the next break if you want the short version -starting Thursday, my machine would hard-freeze at random intervals...
BSOD Help and Support
Crashing Every Day...Had Instability for 11 months.
This thread is a follow up to a previous thread I posted awhile back. You can see it here: 5 BSOD's in one day with Windows 64 bit (Rebooted from bugcheck) - Windows 7 Forums Essentially I did a bit of driver updating and it got better for awhile...oh 5 days. I installed Call of Duty 4 and...
BSOD Help and Support
BSOD & System instability
Hi everyone, I bought a new computer and, since the first day, experiencing BSOD and application crashes. Here is the config : MoBo Asus P7P55 LX Proc Intel Core i5 750 RAM 2x2Go Corsair XMS3 1600 9-9-9-24
BSOD Help and Support
RAID 1+0 instability + BSODs
SO, i am up to my eyeballs here at school. i finally get some free time and think "PERFECT! Now i can set up my super cool raid 10 array giving me 1TB if storage accross 4 500 GB brand new Seagates which i sment a large portion of my savings on." Well i was quite wrong. Initial setup was easy...
BSOD Help and Support
Realtek Driver causing network instability
I was having great difficulty in getting a stable LAN connection, but this was due to the driver that was being installed by Windows update. Realtek's latest driver can be found here. Thanks. :geek:
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App