Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet very slow after Win 7 upgrade

09 May 2010   #21
Adrian

 

Quote   Quote: Originally Posted by cougarric View Post
I've attached the device manager screengrab.

Could you advise where to find my motherboard info?
I can see 3 devices in your NIC, are you getting any conflicts from any of them?
How are you connected to your IP?


My System SpecsSystem Spec
.
09 May 2010   #22
cougarric

Windows 7
 
 

i'll try the router thing next time i'm home which will be tues. i have a long cable that will allow me to do so.

And, yes, it is a desktop pc, on a wireless connection to the router upstairs.
My System SpecsSystem Spec
09 May 2010   #23
cougarric

Windows 7
 
 

Quote   Quote: Originally Posted by Adrian View Post
Quote   Quote: Originally Posted by cougarric View Post
I've attached the device manager screengrab.

Could you advise where to find my motherboard info?
I can see 3 devices in your NIC, are you getting any conflicts from any of them?
How are you connected to your IP?
no i dont get any conflicts
My System SpecsSystem Spec
.

09 May 2010   #24
cougarric

Windows 7
 
 

my connection has been pretty bad all night so far. feels like dial up at times.

I can't understand how sometimes it works perfectly, yet mostly it's really bad.

And can I just say guys, I really appreciate the assistance.
My System SpecsSystem Spec
10 May 2010   #25
Adrian

 

Quote   Quote: Originally Posted by cougarric View Post
my connection has been pretty bad all night so far. feels like dial up at times.

I can't understand how sometimes it works perfectly, yet mostly it's really bad.

And can I just say guys, I really appreciate the assistance.
Well, if we can eliminate the router then we may have an issue with your IP.
Depending if you are here in the US and you have comcast, Brighthouse or RR you may have a bad cable drop.
My System SpecsSystem Spec
11 May 2010   #26
cougarric

Windows 7
 
 

I'm using the same router for connection of my iPhone and xbox live. Both run fine even when the pc is slow. I have tried speedtest on my iPhone when the pc has been bad and it works fine with fast download speeds.
I'll be hone later to test the cable if you still think it's worthwhile considering the above?
My System SpecsSystem Spec
12 May 2010   #27
cougarric

Windows 7
 
 

I have connected via a cable rather than through my wireless router and everything worked perfectly.

Reverting back to the router and it's like being on dial up again!

With regards to it being a router problem - is this likely seeing as other accessories use the same connection without any problems? and I can connect to my neighbours wifi and I still encounter the same problems.
My System SpecsSystem Spec
12 May 2010   #28
cougarric

Windows 7
 
 

I think I've solved it!

Upgraded my router firmware, and immediately I get download speeds of 17mb.

I'll report again tomorrow if it's still ok, but it does look good.
My System SpecsSystem Spec
12 May 2010   #29
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

So far I've seen about 40 different systems fixed with a router firmware update but usually it won't connect at all. You never mentioned what model router you were using.
My System SpecsSystem Spec
13 May 2010   #30
Adrian

 

Quote   Quote: Originally Posted by cougarric View Post
I think I've solved it!

Upgraded my router firmware, and immediately I get download speeds of 17mb.

I'll report again tomorrow if it's still ok, but it does look good.
Allright then.
My System SpecsSystem Spec
Reply

 Internet very slow after Win 7 upgrade




Thread Tools




Similar help and support threads
Thread Forum
Desktop WIFI Internet Issue - Connected, but Slow/Dropped Internet
I've been battling this particular issue for a couple of weeks now without much success. I have a custom built desktop where my WIFI connection will deteriorate to the point where internet (and gaming over Steam, etc...) will be either painfully slow or unable to load pages at all. Windows claims...
Network & Sharing
Constantly slow and disconnecting from internet (no internet access)
Ok this has been happening for a few weeks now with the connection either being slow or just displaying a yellow triangle saying limited access and no internet access. Getting pretty desperate and running out of ideas now so need to ask here. Basically we switched ISPs after about a month of no...
Network & Sharing
Usb copy slow after ram upgrade
I have a dell dimension 9200 which copy very very slow from internal drives to usb after upgrading the ram from 1GB to 3GB. I have tried changing the rams, installing fresh windows 7, and all I could but the problem seems not be solved. the worse part of it is that as much as it copies slow, it's...
Performance & Maintenance
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security
Upgrade causing slow browsing, fine internet speed
Hi, Recently I upgraded from Windows Vista home basic 32 bit to Windows 7 professional 32 bit. Now however, my browsing speed is very slow and often doesnt work. It seems to especially have trouble with google related stuff (eg Gmail and google maps etc). However when I finally get a page up,...
Network & Sharing
Internet Explorer 8 Painfully Slow after Vista Upgrade
Hi Everyone- First post for me. A few days ago, I upgraded from Vista Home version on my Dell Inspiron laptop to Windows 7. Since doing the upgrade, Internet Explorer is painfully slow loading websites. I use a Linksys Wireless router with which my laptop previouslly ran well prior to the...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App