Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7x64 pro - Network slow or hangs

13 May 2010   #1
NLangela

Win / pro 64 bit
 
 
Win7x64 pro - Network slow or hangs

Hello.
I have been running the various testversions of Win7, finally the RC-build, on a number of PCs. The first installations were all 32 bit. All of them working fine on the different machines.
Then I bought Win 7 pro 64 bit, installing it on a newly formatted partition, on my home computer - the same machine as before, with no hardware-alterations.
I immediately began having problems. Windows Explorer (WE) would work fine for a while, but freeze up after a period, typically a few hours. Logging off was also impossible if WE had ceased functioning. Also, computers on the network were no longer visible in My Computer, and could not be pinged. Resetting the computer was the only way forward.
I spent a lot of quality time with GOOGLE trying to find a solution, and I found that many were having similar issues on their Win7 64 bit computers.
In the end I found a posting referring to mapping of network-folders and drives being the culprit.
I had mapped several network folders, and after un-mapping them I have had no more problems logging off, nor with Windows Explorer freezing.
BUT I still have problems!
I fire up my computer in the morning, and all is well for a while. I can access resources on all available computers on my network. They are all visible in My Computer. Then, sometimes only after a short time, typically within the hour, when I open My Computer and try to find a network resource, I only see “Myself” and very often only one other computer. The strange thing is that the other one can easily be at the “other” end of the network, through a switch, over a wireless network-bridge and through yet two more switches, whereas the NAS and Windows Home server which are copper-connected to the same network switch as my computer are are not visible nor accessible.
This is the situation just now. I have a network-scanner installed – Languard and I have just scanned my network with it, and all computers are detected. I can also ping all computers on the network with no lost packages and at <7ms.
But I can still not see them in Windows Explorer.
Windows Firewall is off, Zone alarm Firewall is on (Zone Alarm Extreme Security with the last updaqtes)
Windows Update is also activated and I have verified that it is doing its job.

Is there anyone out there that can help me?

Kind regards from Nils Langeland


My System SpecsSystem Spec
.
13 May 2010   #2
acurasd

Windows 7 Ultimate x64
 
 

Did you build this computer yourself or is it one off the market?
My System SpecsSystem Spec
13 May 2010   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by NLangela View Post
Hello.

Windows Firewall is off, Zone alarm Firewall is on (Zone Alarm Extreme Security with the last updaqtes)
Windows Update is also activated and I have verified that it is doing its job.

Is there anyone out there that can help me?

Kind regards from Nils Langeland
Did you say ....Zone Alarm? Gulp, the absolute worst culprit of all time for making machines invisible on your network. If you want things to work correctly start by uninstalling Zone Alarm and the ZA firewall then renable the Windows firewall which works perfectly well, then test again.

If you have a mixed Op system network then don't use Homegroups, set up a Workgroup instead.

If you have XP machines in your network try going to SP3 then install the LLTD hotfix which should make them show up on the network and in the network map more consistantly.
XP Computers in the Windows 7 Network Map
My System SpecsSystem Spec
.

18 May 2010   #4
NLangela

Win / pro 64 bit
 
 

Thanks, chev65, for tip on ZoneAlarm.
I uninstalled it, and all is well.
Shopping around for a good AV/firewall to substitute ZA.
Any suggestions?
Nils
My System SpecsSystem Spec
18 May 2010   #5
electrotune1200

Windows 8 Pro
 
 

Here's a useful thread for you
What's the Best Anti-virus?

I'm sure once the recommendations start, this thread could hit ten pages and you'll be nowhere closer to an answer. You could try a few trials (most offer 30 days free). Only you can truly decide what works best for you.
My System SpecsSystem Spec
18 May 2010   #6
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by NLangela View Post
Thanks, chev65, for tip on ZoneAlarm.
I uninstalled it, and all is well.
Shopping around for a good AV/firewall to substitute ZA.
Any suggestions?
Nils
Thanks for reporting back in NLangela. :)
My System SpecsSystem Spec
18 May 2010   #7
Hannibal001

windows 7 Ultimate 64 Bit
 
 

I have used ESET Smart Security for many years now and it has saved my bacon many times. Fairly easy GUI interface and not too big a footprint.
My System SpecsSystem Spec
Reply

 Win7x64 pro - Network slow or hangs




Thread Tools




Similar help and support threads
Thread Forum
Win7x64 UEFI-boot install hangs at "Starting Windows" on Skylake
Let me first address a few things: - I have read extensively on this topic, using guides such as this to determine whether or not I have bootable media for UEFI, which I do. - I have both an original, unused Windows 7 Pro w/ SP1 x64 install DVD, connected through the USB 2.0 external DVD...
Installation & Setup
Handling two Network Gateways in Win7x64
Hi - I am trying to find out how to configure Win7x64 to handle two network gateways efficiently and permanently. My configuration is this: I am running a Virtual Machine that creates a new public gateway on my network that routes all traffic to my VPN provider. The VM sets the public gateway...
Network & Sharing
Network slow to initalize?? PC hangs..
So its a fresh load on the machine, latest Intel 3945 wifi drivers. Hard drive is good without any bad sectors. When I boot into windows everything but the network comes up and after a minute or so the 2 network icons pop up at the bottom than the PC is usable. Anything I click on prior to...
Network & Sharing
Need help regarding slow boottime slow startup and hangs
I bought this Fujitsu laptop for less than a year. Its only for my school work. It takes forever to bootup, startup and it sometime hangs when I open up a program or typing. For the bootup, it takes very long time on the window logo, after that the black screen, followed by the welcome page with...
Performance & Maintenance
Network Speed Problems (Win7x64)
Been trying to track down some networking problems for a while now, and I'm starting to wonder if they are windows related. I have a gigabit network running through a cisco 3750. I have a windows 7x64 box that I can't get seem to get sustained throughput. I'm attempting transfers from this...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:34.
Twitter Facebook Google+