Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet access

01 Jun 2010   #1
Vesperian

Win7 Ultimate x64
 
 
No internet access

I have a wireless router..then i bought TP link WN422G wireless adapter and plugged it in my usb port..when Im connected through a wire it works fine..when I try to connect to a wireless network it connects me but is says that I have no internet access..

Ive been looking through the web for solution but nothing helps..


My System SpecsSystem Spec
.
01 Jun 2010   #2
OneSerious

MS Windows 7 Home Premium 64-bit
 
 

Don't want to hijack this thread but I'm having the exact same problem (Vista machine). Got Virgin Broadband today. Set up the router using the laptop via Ethernet as it was the only machine close to the modem and router. I have connected my Win7 and XP desktops to the wireless network fine, but the laptop (Vista) only connects to the network locally via wireless. Now it will only connect to the internet via the Ethernet cable which is not ideal.
My System SpecsSystem Spec
01 Jun 2010   #3
merkat106

Windows 7 Enterprise x64 SP1
 
 

Don't know if I'm understanding what either of you are saying. My experience has been on most computers (on xp through 7) that you can connect to the Internet with either wired or wireless, but not both at the same time.
Out of hundreds of computers I've worked on, only two have been able to do this and niether had anything in common.

If you want wireless, unplug the ethernet from the computer then try again.
My System SpecsSystem Spec
.

02 Jun 2010   #4
aem

Windows 7 Ultimate 64Bit
 
 

Can you provide ipconfig /all details when wirelessly connected.

I assume all settings are set to auto detect IP.
My System SpecsSystem Spec
02 Jun 2010   #5
kucing13

 

1. when you connect through wire,did you set the IP address manually or default auto?
2.And the same question when you connect wireless
My System SpecsSystem Spec
02 Jun 2010   #6
OneSerious

MS Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by merkat106 View Post
If you want wireless, unplug the ethernet from the computer then try again.
In my case, the vista machine would connect to the network via Ethernet locally and with internet access. When I unplug and try and connect wirelessly it connects to the network but only locally.

Quote   Quote: Originally Posted by aem View Post
Can you provide ipconfig /all details when wirelessly connected.

I assume all settings are set to auto detect IP.
I will do this when I get home later.

Quote   Quote: Originally Posted by kucing13 View Post
1. when you connect through wire,did you set the IP address manually or default auto?
2.And the same question when you connect wireless
Just followed the set up so I presume it was auto.

As stated earlier both the XP and 7 machines connect to the network wirelessly with full access no problem.

Another note, I inserted a Belkin wireless dongle (vista laptop) and installed the software and was able to connect to the network with full access just fine. Once I removed it and tried to connect with the onboard wireless I get the same problem of local connection only. I know the onboard unit isn't faulty because it worked that same day with the old Sky broadband router and has the most up to date drivers.

Thanks for the responses.
My System SpecsSystem Spec
02 Jun 2010   #7
aem

Windows 7 Ultimate 64Bit
 
 

If you have the SSID and password all good (and using the same wireless settings etc), you will always be able to get onto your wireless network.

Browsing the internet is one that requires correct dhcp setting ie IP, gateway, DNS etc, could even be a firewall preventing access.
My System SpecsSystem Spec
14 Jun 2010   #8
infomike

win 7
 
 

If you're getting these issues, you could try to follow the troubleshooting steps listed here: No internet access or Additional log on information may be required in Windows 7 x64 LAN and Wi-Fi It fixed my No internet access issue, perhaps it can help you too.
My System SpecsSystem Spec
Reply

 No internet access




Thread Tools




Similar help and support threads
Thread Forum
Dial Up ICS Error:Access Type No Internet Access With Yellow Triangle
Hi, i am a newbie when it comes to Windows networking particularly Internet Connection Sharing (ICS). A week ago i turned my Win 7 HP Laptop into wireless router which is on EVDO 3G dial up using the windows (ICS) to connect my second Win 7 Dell laptop which was successful. Unfortunately, i...
Network & Sharing
Frequent internet access dropping - "Limited Internet Access"
First things first, these are my computer specs. Operating system: Windows 7 Ultimate 64 bit System Manufacturer: Gigabyte Technology System model: GA-770TA-UD3 BIOS: Award Modular BIOS v6.00PG Processor: AMD Phenom II X4 955 Processor...
Network & Sharing
Frequent internet access dropping - "Limited Internet Access"
First things first, these are my computer specs. Operating system: Windows 7 Ultimate 64 bit System Manufacturer: Gigabyte Technology System model: GA-770TA-UD3 BIOS: Award Modular BIOS v6.00PG Processor: AMD Phenom II X4 955 Processor ~3.2GHz Memory: 4096MB RAM Display: ATI Radeon HD...
Network & Sharing
No access to Internet - Limited access for both wired and wireless
Hi i am new here My Original post is here - No access to Internet - Limited access for both wired and wireless - Microsoft Answers I have seen most of the threads going un-answered so i feel that i can get help from here! I just accessed wireless internet on another laptop! So i am sure we...
Network & Sharing
Internet Access = Can't browse / No Internet Access = Nice Browsing ??
When my computer says Internet Access, I am having trouble browsing. Most pages do not load. Right now, It says no internet access for over 15 minutes and I am able to brose so much better and still going on downloading around 400 kb/s. How can this be? Why would it be? (I am on a wired...
Network & Sharing
Win7 x64 Crashes on Internet Access or File Access
Hi all, So i'm writing this from Safe Mode with Networking as that seems to be the only way to keep the system stable. I was working on my computer last night with zero problems. I shut it down and then today I have the following symptoms. Once i boot, i can open folders on the desktop and...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App