Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange routing problem on VPN

15 Jul 2010   #1

Windows 7 Ultimate x64
Strange routing problem on VPN

Situation is as follows.
  • Home computer running Windows 7 Ultimate x64, sets up VPN connection (LT2P + IPSec, "use remote gateway" disabled) to office. Subnet is 192.168.64.x
  • Office has Draytek Vigor 2920 router, subnet is 192.168.32.x
The VPN connection is established, but Windows 7 says "no network access" and indeed, I cannot ping anything on the remote network or open a website hosted on a remote server.

On Windows XP however there is no problem like described above. I can ping remote hosts and open sites hosted on remote servers. So it seems like there is a difference in the routing between XP and Windows 7 (maybe only on x64?).

The output of "route print" on Windows XP (32 bit) looks like what you see in routing_xp.png. So here the gateway for the 192.168.32.x subnet is the IP address that the local computer has in the remote network.

The output of "route print" on Windows 7 looks like what you see in routing_win7.png. Now the gateway for the 192.168.32.x subnet is the IP address of the VPN router (32.1). I don't know if that causes this trouble, but it seems a bit strange.

Enabling "use default gateway on remote network" doesn't make a difference. Using the new option "Disable class based route addition" in Windows 7 only makes the route to the VPN router disappear.

I am really puzzled here. I assume the VPN routing can't be broken Windows 7, and this should just work without manually adding routes.

I also tried using the Draytek SmartVPN client, but that just adds a VPN connection in Windows and gets no further than "unknown error" when connecting .

I really hope someone has a solution for this problem .


Attached Images
Strange routing problem on VPN-routing_xp.png Strange routing problem on VPN-routing_win7.png 
My System SpecsSystem Spec
29 Jul 2010   #2

Windows 7 Ultimate 64bit EN
Exact same problem


After several weeks in which VPN's worked great between my Win7 Ultimate 64bit EN HP laptop and vigor 2920, it stopped working since this (or maybe last) week.
I'm having the exact same problem.
I noticed that the home or VPN gateway address (my home network is 192.168.1.x and the address range at my holiday network is 192.168.2.x) is not in the IP settings obtained by DHCP over the VPN. Also no route for is in my route list.
I manually added the home gateway ( but that did not help, though a route was added for through this gateway. A traceroute doesn't even get to the first hop.

I'll check if any Windows updates my be causing troubles. I haven't upgraded my Vigor in the meantime and I'm not aware of the exact firmware version. Help is appreciated.

Erik Dobbelsteijn
My System SpecsSystem Spec
29 Jul 2010   #3

Windows 7 Ult, Windows 8.1 Pro,

Did you open the port for the incoming connection?

Important: Configure your firewall to allow access to TCP port 1723 to allow incoming Point-to-Point Tunneling Protocol (PPTP) connection for VPN.

Router Configuration: Enable PPTP and Generic Route Encapsulation (GRE) on the Router. Depending on the type of router, you need to either enable PPTP or create a port forward to port 1723. If you’re router has an additional setting for PPTP or VPN, make sure it’s enabled. It’s usually called a “pass-through” setting (i.e. PPTP pass-through or VPN pass-through)

Virtual Private Network (VPN) - Enable Incoming VPN Connections
My System SpecsSystem Spec

30 Jul 2010   #4

Windows 7 Ultimate 64bit EN


Thanks for getting back to the issue. Yes, all ports are open and were open. Like I said: the VPN had been working allright.

Update: after a reboot yesterday, I was able to route traffic over the VPN. However, it seems that intermittently, TCP connections get lost. Haven't sniffed yet to see where the traffic goes and what happens to it.

My System SpecsSystem Spec

 Strange routing problem on VPN

Thread Tools

Similar help and support threads
Thread Forum
Slow routing
I have 2 routers.. The 1st, a Linksys EA9200, hardwired to my computer is getting the correct download speed of ~50mbps. The 2nd, a Linksys 54gl, when hardwired to the same computer only gets ~30mbps. I have no idea why.. Any help?
Network & Sharing
Routing problem with 2 network cards
Hello, I have some difficulties managing routes for my network cards. I have 2 network cards, one I use for internet, the other for multicast. Apparently, the current behaviour is that Windows chooses the first card he founds for multicast, and that will be the internet one. So, my cards are...
Network & Sharing
Routing Problem Win7 and XP
I am connecting several Windows 7 laptops via wireless to a wired network of XP machines. After several frustrating days trying to figure out why I couldn't see shares on the network I think I've finally caught the culprit: the netbios master browser. Can anyone shed some insight into what's going...
Network & Sharing
Cable Routing
I began this subject back some days ago, but can't find the thread for it, so I'm starting another. I just received an Audiovox TV Volume Controller that I ordered, which is supposed to be placed between the PC soundcard and the speakers, but there are only two and white, while the...
Hardware & Devices
Strange freezing problem and administrator problem
Hi all, I'm new on the forums. Best Windows 7 forums btw, have helped me a lot. So I'm having two different or same kind of problems. I really need help to solve these! Problem number one:I'm having a strange freezing problem. Sometimes randomly my desktop freezes. I can't right-click any...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:39.
Twitter Facebook Google+