Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Asus Z170-A Motherboard not showing external hard drives

31 Oct 2015   #1
matthewcroton

Windows 7 Home Premium 64bit
 
 
Asus Z170-A Motherboard not showing external hard drives

I have a new custom build which I have built and have installed Windows on. The issue I'm having is that when I plug in an external drive, they are not appearing on the PC.

They work on other laptops which I've tested and all the USB ports work on the new PC which I tested with the keyboard and mouse so I'm not sure what the issue is.

When I plug the drives in I get a light on them so it's being powered but not showing up.

I've read about having to use a switch to 'power' the drives but I'm not sure if such a switch is on this motherboard.

Any suggestions would be appreciated .


My System SpecsSystem Spec
.
31 Oct 2015   #2
Solarstarshines

Windows 10 Home Premium 64bit sp1
 
 

Hit start go to my computer Right click Manage and you should be able to manage the hard drives to appear on the system

By the way this is called Disc Management
My System SpecsSystem Spec
31 Oct 2015   #3
matthewcroton

Windows 7 Home Premium 64bit
 
 

I have tried this before but for some reason the drives do not show up in Disc Management despite being plugged in.
My System SpecsSystem Spec
.

31 Oct 2015   #4
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Matthew, I don't have a Z170 board, so I am not familiar with them. But, go into Bios and make sure Legacy USB is enabled, then try. If that does not work, try plugging the drives in and shutting down the computer then restarting it and see if the drives are detected.
My System SpecsSystem Spec
31 Oct 2015   #5
matthewcroton

Windows 7 Home Premium 64bit
 
 

Thanks for the reply, I will try this later today when I'm next at the PC.
My System SpecsSystem Spec
31 Oct 2015   #6
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Ok, have you also installed your Motherboard drivers? Go to Device Manager and see if you see any yellow triangles there too.
My System SpecsSystem Spec
31 Oct 2015   #7
matthewcroton

Windows 7 Home Premium 64bit
 
 

I haven't had chance to install any drivers yet so this could be why. I plan on installing them tonight/tomorrow.
My System SpecsSystem Spec
31 Oct 2015   #8
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

You have to install all your drivers, then it`s play time.

As suggested, open up device manager, it`ll show you all your problems.

All your drivers are on the motherboard cd.
My System SpecsSystem Spec
31 Oct 2015   #9
essenbe

Windows 10 Pro/ Windows 10 Pro Insider
 
 

Quote   Quote: Originally Posted by matthewcroton View Post
I haven't had chance to install any drivers yet so this could be why. I plan on installing them tonight/tomorrow.

You'll get more current drivers from your Motherboard's web site plus you can avoid installing most of the 'junk' included on the CD.
My System SpecsSystem Spec
31 Oct 2015   #10
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
According to the manual the mobo cd is second item after os install :/
Being it's z170 the drivers are probably fairly recent :)
Third is load all windows updates
Then your security
Then any third party software so it seems you skipped some steps.
My System SpecsSystem Spec
Reply

 Asus Z170-A Motherboard not showing external hard drives




Thread Tools




Similar help and support threads
Thread Forum
External hard drives recognized but not showing up in My Computer
I am having an issue with many external hard drives being recognized by Windows 7, it makes the hardware insert sound but the drives do not show up in My Computer. I have the same problem with some Android tablets as well, recognized, hardware insert sound, but not showing up in My Computer. It...
Hardware & Devices
Windows 7 UEFI install motherboard ASUS Sabertooth Z170 Mark 1
Hi all, I have new mobo Asus Sabertooth Z170 Mark 1. I want to install Windows 7 Home in UEFI mode, but I'm still not successful. Bios settings - SATA Mode Selection - Raid - 2 SSD disks set up in Intel RST as Raid 1 Newest Bios update from 7.1.2016 Boot settings: Launch CSM - Enabled ...
Installation & Setup
Asus Exhibits Glorious TUF Sabertooth Z170 Symbol 1 Motherboard
Together with its Z170 lineup, Asus unveiled its TUF Sabertooth Z170 Symbol 1 motherboard. Asus's TUF lineup of motherboards are built to be as tough as they can. "TUF" is a play to the word "tough, " but it surely actually stands for "The Quintessential Force, " with the plan behind the boards...
Hardware & Devices
External Hard Drives Not Showing Up
I haven't used my external hard drives for quite a while and I am now having trouble getting the computer to recognise both a Seagate and a Simpledrive. I got them to show up once on "computer" but now they have both vanished again. Any advice please?
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:11.
Twitter Facebook Google+