Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No display on own build PC

21 Apr 2017   #11
fireberd

Windows 10 64 bit
 
 

Sadly, you would never know which is the problem without a swap (e.g. another known good CPU).


My System SpecsSystem Spec
.
21 Apr 2017   #12
Mickyd

Windows 7 & Windows 8.1
 
 

Yeah thats true, i think i will just get another mobo bundle
My System SpecsSystem Spec
29 Apr 2017   #13
Mickyd

Windows 7 & Windows 8.1
 
 

I got another mobo - it worked i had screen - BUT would youbelieve the HD was DOA - so after a new hard drive put in - the PC is now bursting with life
My System SpecsSystem Spec
.

Reply

 No display on own build PC




Thread Tools




Similar help and support threads
Thread Forum
Laptop black when external display plugged in, #2 display also dark.
This happens as soon as the VGA adapter is plugged in. Unplugging it does not turn the laptop screen back on. Toggling with the function keys does nothing. Since I cannot see anything I cannot try to adjust/correct display settings (or do anything for that matter, other than turn the laptop off by...
Graphic Cards
Display screen black and blank- is mobile pc display the issue?
I started having issues yesterday, the day after I installed teamviewer a program that is on my iPad also to remotely control the laptop. At first the screen started freezing when I was in the middle of a Java game. So I restarted the laptop only to have it freeze at the main screen (after login). ...
General Discussion
Display issue over VGA with AMD A8-5600K APU new build!
This is a new system built yesterday with the following specs: asus fm2 mobo amd a8-5600k 8gb mushkin blackline 1tb caviar blue after install of win 7 with the default vga driver the output fills my monitor, after installing the amd drivers from my driver disk or straight from amd the...
Hardware & Devices
Display problem with W7 Build 7100.
Okay this is weird. I was using Windows 7 build 7068 or something before and I didn't have the following problem: Problem: I have 2 CRT monitors, one displays 1280x1024 default at 85 Hz, the other displays 1600x1200 (which I do not like) when W7 is installed. So I decided to switch to...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App