Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Administrator access

30 Sep 2010   #1
TaylerCFI

Windows Home Premium x64
 
 
Administrator access

After upgrading from Vista to Windows 7 on a Compaq desktop (about 2 years old) the printers stopped working. All of them. Lexmark and HP. I uninstalled and re-installed. But they still don't show up in the Printers list. When I try to add a printer, the errror message appears that the Spooler isn't working, and that I need to enable it.

In task manager the spooler shows as working. I went into the System menu and it shows it enabled and working.

I then looked at the spoolsv.exe files, and noticed that of the 3 copies of it on the drive, 2 of them are "new" (dated to the upgrade) and one is the original (pre-upgrade). I think the two new ones are corrupted, and all I want to do is copy the older one over the two new ones.

But they're located in System directories, and when I try to copy the older one into the directories of the others, I get the message telling me I need to do it as the Administrator. The problem is I'm already logged in as the Administrator. Typical Windows malfunction....

It was suggested to me that perhaps it was the permissions on the file itself that needs to be changed, but again, when I try to change the properties to allow that file to be copied/modified/changed, it tells me I need to be the Administrator. Round and round and round.....

So, how do I get REAL Administrator access, if it doesn't recognize the Administrator as the Administrator?

Or, if anyone has a suggestion of another way to fix the corrupted spoolsv.exe files, please don't keep it a secret.

Thanks


My System SpecsSystem Spec
.
30 Sep 2010   #2
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello TaylerCFI, welcome to Seven Forums!





Have a look at this tutorial at the link below to see if you can take ownership of the files in question; be sure to post back with any questions you may have and to keep us informed.


How to Create a Take Ownership Shortcut in Windows 7
My System SpecsSystem Spec
Reply

 Administrator access




Thread Tools




Similar help and support threads
Thread Forum
cant access my administrator
hi i have a school computer and two days ago i had full admin rights and could change all settings but yesterday my pc crashed and i restarted it and now when i am going to start a program as a admin it comes up that i need to write in username and password... i tried to write my username and...
System Security
Access Denied on Administrator
Hello! Many times I have seen the "Access Denied" error while using an administrator account. Especially in disk management utility when I tried to edit disk partitions but couldn't even with administrator privileges. This is not a specific case - I just want to know how, even with...
General Discussion
Restrictions to Administrator Access
I am the only user on my notebook and, thus, have Administrator status. I am using Win7 home premium OS. I had installed a program which did not have a comprehensive help guide but had a website with a very good guide. So, as I have done many times with WinXP, I tried to copy a shortcut to the...
General Discussion
No access for administrator
I am the only administrator for my computer. What happen was I loan my computer to my 10 year old cousin and now I can't open any files or programs that require administrator permission. Whenever I try to open a file/program that's only for an administrator, I get this message "Windows cannot...
General Discussion
No administrator access
Hi I'm new to Windows 7 and have a problem with the Built-in Administrator. More correctly, I have made changes to the Built-in Administrator and would appreciate assistance to correct the problem. I have followed the forums advice on enabling the Built-in Administrator, renaming it, and then...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App