Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 Is Slow!!! (my first post btw...)

29 Oct 2010   #41
gregrocker
Microsoft MVP

 

Quote   Quote: Originally Posted by t4akawolf View Post
OMG, I CANNOT BELIEVE THIS!!! ATI Catalyst was the problem!!! I uninstalled Catalyst, let Windows 7 handle the drivers related stuff, and now everything works like a charm!!! It took me TWO weeks to get a solution to this problem!
Two weeks was how long ago I suggested to uninstall Catalyst to try only the driver:

Quote   Quote: Originally Posted by gregrocker View Post
Sometimes Catalyst should go the other way: Uninstall and use only driver if you don't need advanced settings it offers. This will solve some problems with Catalyst conflicts, and those who don't need card settings don't need the package anyway except for driver.



My System SpecsSystem Spec
.
30 Oct 2010   #42
t4akawolf

Windows 7 Ultimate x32 (UPDATE: Now x64!)
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Quote   Quote: Originally Posted by t4akawolf View Post
OMG, I CANNOT BELIEVE THIS!!! ATI Catalyst was the problem!!! I uninstalled Catalyst, let Windows 7 handle the drivers related stuff, and now everything works like a charm!!! It took me TWO weeks to get a solution to this problem!
Two weeks was how long ago I suggested to uninstall Catalyst to try only the driver:

Quote   Quote: Originally Posted by gregrocker View Post
Sometimes Catalyst should go the other way: Uninstall and use only driver if you don't need advanced settings it offers. This will solve some problems with Catalyst conflicts, and those who don't need card settings don't need the package anyway except for driver.
*looks sheepish*

Heh heh heh , uhm, yeah, yeah it was...

Shuda listened
My System SpecsSystem Spec
30 Oct 2010   #43
t4akawolf

Windows 7 Ultimate x32 (UPDATE: Now x64!)
 
 

Oh btw, who marked this thread as 'Solved'? I mean it IS solved, but who did so? Isn't the Asker of a post the only one with the option to do that??? And where exactly is this 'Mark As Solved' button??
My System SpecsSystem Spec
.

30 Oct 2010   #44
gregrocker
Microsoft MVP

 

Your post sounded definitive, so I asked the mods to mark it Solved.

It's just housecleaning, that's all. Most don't know how or why to mark it Solved (use Report button).

Sorry if you're not quite ready to go.

Many threads stay active forever (regardless) thanks to Google.
My System SpecsSystem Spec
31 Oct 2010   #45
t4akawolf

Windows 7 Ultimate x32 (UPDATE: Now x64!)
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Your post sounded definitive, so I asked the mods to mark it Solved.

It's just housecleaning, that's all. Most don't know how or why to mark it Solved (use Report button).

Sorry if you're not quite ready to go.

Many threads stay active forever (regardless) thanks to Google.
No no, it's not that I'm not ready to go lol, I was just curious...
My System SpecsSystem Spec
31 Oct 2010   #46
gregrocker
Microsoft MVP

 

You can come back any time to visit, or hang around and share what you've learned.
My System SpecsSystem Spec
01 Nov 2010   #47
t4akawolf

Windows 7 Ultimate x32 (UPDATE: Now x64!)
 
 

Thanks! Well, I guess I'll see you around lol, bye!

Oh and btw, Catalyst itself wasn't the problem! You see, me being the most absent minded person ever, I installed WinXP's Catalyst in Win7 and THEN I updated it to the latest WinXP Catalyst -.- I just realized this when I saw '...winxp...' somewhere in the file name of the Catalyst installer. I downloaded the latest Catalyst for Win7x64 bit and everything works like a charm
My System SpecsSystem Spec
01 Nov 2010   #48
gregrocker
Microsoft MVP

 

Then it sounds like Catalyst was the problem.
My System SpecsSystem Spec
Reply

 Win7 Is Slow!!! (my first post btw...)




Thread Tools




Similar help and support threads
Thread Forum
How to recover Win7 Pro upgrade from Win7 Home Premium post HDD crash
Greetings - This is my first time here and am very thankful for this great collection of forums and this community. I am trying to recover from a VAIO laptop HDD crash to Win7 Professional upgrade. I had finished working, shutdown Win7 Pro. cleanly. Drove home, attempted to launch Windows...
General Discussion
Post-wmupdate virus issues: slow file copy, photoshop runtime errors
My computer contracted wmupdate virus the other day and wiped my computer. I system restored and had to run a couple disk checks and eventually managed to get the majority of my files back in order (albeit as hidden folders, which i manually changed back). However, a few of my programs now...
System Security
Win7 to Win7 slow network transfers
Hi I have tried searching the forums and tried all possible solutions but none of them seem to work. My setup is as follows: "Server": Windows 7 Professional x86 Connected to Draytek 2820n MIMO router with Gigabit Cat6 cable (Win reports 1Gbps)
Network & Sharing
Slow Network connection between Win7 and Win7
Hello This is my firt posting here. I hope, someone can help me. I connected two notebooks via a TP-Link router (Wlan 54g). The first computer is a brand new Samsung RF511 Win7 Home Premium 64bit with Intel I7, 8GB Ram. The second is a 5 year old HP Pavilion DV5000 device with Win7 Home...
Network & Sharing
Slow downs then Black Screen After Post
Hi, I had a strange issue with my computer today. It started yesterday when my wife and I noticed the computer hanging a bit more than normal - even when doing basic things, like clicking "login" to check our email. But, it would always come back and really wasn't all that frequent. This ...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App