Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird issue?

15 Oct 2010   #1
rosefox911

Windows 7
 
 
Weird issue?

Hey guys,

I just recently reformatted my computer. For some reason the load ups performance of it is ridiculously slow. And I mean SERIOUSLY slow.

My specs are:

i7 910 processor
6 gb ddr3 ram
2 500 7400 rpm hard drives.
gtx 460 graphic card
msi eclipse motherboard.


Any ideas? I'm trying to install the drivers but it's just going to take years at this pace.


My System SpecsSystem Spec
.
15 Oct 2010   #2
rosefox911

Windows 7
 
 

bump.
My System SpecsSystem Spec
16 Oct 2010   #3
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Sorry rosefox911, but "load ups performance". Can you clarify? Your PC is slow to load the internet? Slow to open folders or programs? Slow to install programs? Let us know as much as possible. A Guy
My System SpecsSystem Spec
.

16 Oct 2010   #4
gregrocker
Microsoft MVP

 

Run the Latency Checker to determine if a driver is responsible. There should be nothing in the red -if so follow the steps given in download sheet to disable drivers one-by-one to determined which is responsible:

DPC Latency Checker
My System SpecsSystem Spec
Reply

 Weird issue?




Thread Tools




Similar help and support threads
Thread Forum
I have a weird shortcut issue
Greetings my friends ! I have a weird issue-my shortcut looks very,VERY strange !! 1f59b3939153a0648165593140522b91.png I don't even know how I got that issue :(
Software
A very weird activation issue
i purchase Dell XPS L502X with Windows 7 Professional x64 pre-installed and fully genuine. but my bad luck on youtube i found a key to upgrade windwos 7 professional x64 to ultimate x64 and worked. but after some days message appeared that this copy of windows is not genuine. So, i tried 100 of...
Windows Updates & Activation
A weird connection issue.
Hello again and sorry for the trouble as well. So, I have been using this, Aztech broadband modem (Phone-line to modem then to PC) for a while now and I have decided to add another wireless router (Modem to router) along with it to make my connection wireless for my iDevices. So, at first,...
Network & Sharing
Having a weird issue when booting from CD.
Hello, you guys must feel exhausted of all the double work with the tons of windows 7 questions that keep flooding these forums. I however will (unfortunatly) be no difference. I have as well bumped into an issue. So, I recently bought the Windows 7 Home Edition Upgrade. It came nicely with...
Installation & Setup
Weird Issue
Not sure if this is right place to post this however all my icon associations for Microsoft Office have suddenly reverted to a generic icon (see pic) They still load in their various programs i.e. word, excel etc but it is really annoying that the icons are not what they should be. This appeared to...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App