Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I've lost my Run As Administrator command

17 Jun 2009   #1

Windows 7 RC Build 7100
I've lost my Run As Administrator command

In my context menu, I had lost my Run As Administrator command. I had installed a Take Ownership command for installing WMP11 but uninstalled it because I wanted RAA. But, it doesn't show up in my context menu anymore. Anyway to solve?

My System SpecsSystem Spec
17 Jun 2009   #2

Windows 7 Professional x64 (Build 7600)

What happens if you try to remove the Take Ownership from the menu? In my zip file you have what you need... if not try the reg key i also attached!

Attached Files
File Type: reg RunAsAdmin_add.reg (362 Bytes, 650 views)
File Type: zip (622 Bytes, 347 views)
My System SpecsSystem Spec
17 Jun 2009   #3

Windows 7 RC Build 7100

When I got rid of Take Ownership, it's gone too. Which was what I wanted. But I was expecting to see Run as Administrator replace Take Ownership.

Thank you, it worked.
My System SpecsSystem Spec

17 Jun 2009   #4

Windows 10 Pro x64 x3, Ubuntu

In addition to the solution above, one option which is not well known is the SHIFT-Right Click on an executable file - This will bring up the "Run as another user" option which may be used to run at higher user rights if you have another admin account available or Lower rights (which is useful for troubleshooting)
My System SpecsSystem Spec
30 Nov 2011   #5

Windows 7 Home Premium SP1

I have lost "Run as administrator" from my right-click context menu. I have searched and searched for an answer and found this. What I am most interested in is the registry key file bansh attached. Will that put the RunAs back into the registry? I don't know why it disappeared. I don't know what to check for in the Registry to make sure that is even where the problem is. I am searching for help. If you can help me please respond. OS is Vista Home Premium SP2
My System SpecsSystem Spec
02 Dec 2011   #6
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit

I wish you luck with the solutions presented.

I had much the same problem months ago and was only able to restore the Run as Admin capability by doing a Repair Install. There is a tutorial in the Installations section on how to do that -- but you will need Win7 installation media to do that.
My System SpecsSystem Spec
02 Dec 2011   #7

Windows 7 Professional SP1 32-bit

Try the following .reg file - I just exported it from my own registry. It'll only work for .exe files but I'm assuming that's where the problem lies to begin with.
Windows Registry Editor Version 5.00


@="\"%1\" %*"
"IsolatedCommand"="\"%1\" %*"

Attached Files
File Type: reg run_as_admin.reg (400 Bytes, 106 views)
My System SpecsSystem Spec
02 Dec 2011   #8

Windows 7 Home Premium SP1

Before I go ahead with this key, I want to make sure you are aware that I don't run Windows 7. I have Vista Home Premium SP2. Also, there is one thing I forgot to mention before. If I right-click anything which appears in my Start menu, or most things under All Programs there, the "Run as administrator command" still appears in the context menu. Example: I right clicked Jarte from Start/All Programs and the command was there. However, I went into C/Program Files and right clicked Jarte and the command is not there. If I click the shortcut on my desktop it is not there. In the past, I have used that command a lot with games from Shockwave. Sometimes a game will not open and play unless you "Run as administrator." I can still get to this command by going through Properties/Compatibility -- but it no longer appears in my right-click context menu.
My System SpecsSystem Spec
02 Dec 2011   #9

64-bit Windows 10 Pro

I whipped up this tutorial below to help make it easier to either remove or restore Run as administrator from the context menu of the default BAT, CMD, CPL, EXE, and MSC application files for all users in Windows 7.

Run as Administrator - Add or Remove from Context Menu in Windows 7

Hope this helps,
My System SpecsSystem Spec
02 Dec 2011   #10

Windows 7 Home Premium SP1

I need to hear from Corazon and Brink. Will this work on Vista?
My System SpecsSystem Spec

 I've lost my Run As Administrator command

Thread Tools

Similar help and support threads
Thread Forum
Run as Administrator command name
Is there a command to insert into a batch file so the file can ask for administrator approval before continuing?
System Security
Cannot Run command as Administrator
Hello, I have been buried by a cascade of issues that just drove me to a dead end. Everything started when one of the applications I use couldn't install properly. Now everytime I try to run this application it says that the folder d:\windows\assembly\gac_32\mscorlib\... is corrupted. Weirdly...
Performance & Maintenance
Run as administrator command has stopped working
Whenever I try to "run as administrator" a .exe file nothing happens aside from the window I was using to browse to the file freezing. Any ideas on what is wrong or how to fix it?
General Discussion
elevated command administrator password
I am writing a vba script for a standard user to run a program in elevated mode. Is there a way to program in the administrative password? ie..elevate "cmd /k mkdir "newfolder" The goal is to enable the standard user to create a new subfolder within a directory they don't have permission...
General Discussion
Run login command as Administrator
I used to have a network drive mapped to U:, but I have moved it to the local machine. Some programs (one in particular: iTunes) don't do well if you move their file paths around, plus it would be nice if all the machines on the network could have the same setup. So now I want to have a virtual...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:43.
Twitter Facebook Google+