Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Autoplay Registry key value

13 Feb 2011   #11
thesaint

Windows 7 Home Premium 64 bit
 
 

Hello "Jacket57"
Thanks for your suggestion to use value 177. As I mentioned, my value is 91. (which works - see below)
In my search for a solution I came upon a superb artical in "Wikipedia". It was very long and complex but I feel almost an expert on Registry matters now - until I forget tomorrow (well I am 73).
Anyway the problem was solved by going to key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer then left click "Explorer" to reveal "NoDriveTypeAutorun" I found that the value was set to 255. I changed it to 1 and did a re-set. I now have full autoplay on all inputs.
Of course there is a good security reason for not having Autoplay working. Any type of dodgy input device (CD/DVD/SD card/Flash Drive) could contain a virus which would automatically install with Autoplay working.


My System SpecsSystem Spec
.
13 Feb 2011   #12
jacket57

windows Professional 7-64bit upgarde from Home edition 64bit
 
 
Re: Option to enable Autoplay

Thank you very much for posting a reply to my working values in Regedit. Similarly I have gone to your posted references and also found my same value of 177 as the default. Autoplay has worked from day 1, with all types of media and drives inputed. Autoplay has also worked and continue to work when evr I install Pci Parallel Port cards. I am oblidged to you for your successfull repairs and calling upon me. Thank yo very much.

jacket57: I am 15 years younger.
My System SpecsSystem Spec
12 Oct 2013   #13
MadDad

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by thesaint View Post
Hello "Jacket57"
Thanks for your suggestion to use value 177. As I mentioned, my value is 91. (which works - see below)
In my search for a solution I came upon a superb artical in "Wikipedia". It was very long and complex but I feel almost an expert on Registry matters now - until I forget tomorrow (well I am 73).
Anyway the problem was solved by going to key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer then left click "Explorer" to reveal "NoDriveTypeAutorun" I found that the value was set to 255. I changed it to 1 and did a re-set. I now have full autoplay on all inputs.
Of course there is a good security reason for not having Autoplay working. Any type of dodgy input device (CD/DVD/SD card/Flash Drive) could contain a virus which would automatically install with Autoplay working.
I had installed a new MB using Paragon to save reinstalling Windows, suggested from here. Also ran several ad aware scanners, and cleaned up some junk. After all this I noticed I couldn't get autoplay to work. I don't know what broke it, but your suggestion fixed it. I know this string is a couple of years old, but it is still vary valid!!!
Thank you
My System SpecsSystem Spec
.

13 Oct 2013   #14
andrew129260

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by richnrockville View Post
Quote   Quote: Originally Posted by thesaint View Post
Hello "Richnrockville"
You may have the key I mentioned. You need to get to "explorer" then left-click that word. A new pane will open (on mine) and "NoDriveAutoRun" will be revealed. My value is 0x00000091.

I searched the registry for nodrive and everything else and it was not found.

One thing in the back of my memory is that microsoft had an update to security
that had something to do with autorun. Not sure when I saw it but it was
lately.

Rich
This is correct. Windows 7 due to security has disabled autorun for a reason. Malware infected usb drives are/were popping up everywhere so a security windows update was sent out to block this behavior.

See here:

AutoRun changes in Windows 7 - Security Research & Defense - Site Home - TechNet Blogs

AutoPlay Windows 7 behavior backported - Security Research & Defense - Site Home - TechNet Blogs

How to disable the Autorun functionality in Windows

Update to the AutoPlay functionality in Windows
My System SpecsSystem Spec
Reply

 Autoplay Registry key value




Thread Tools




Similar help and support threads
Thread Forum
Cannot delete certain Registry Key; Cannot change Owner of Registry Ke
In order to get rid of the *.zip folder view in WinExplorer on a64bit WIn7 system I tried to delete (according to some tutorials) the Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31} Unfortuantely this is NOT possible immediately....
General Discussion
Registry: can't control Desktop Background Slideshow in registry?
Just a rough test: 1. No slideshow on desktop; 2. Backup the registry file; 3. Turn on the slideshow (Desktop - Personalize - Desktop Background - Select All - Save Changes); 4. Run the backup registry file; The desktop starts with the original picture (the desktop wallpaper picture...
Customization
Registry problem after windows update and registry optimization tool
Hello sevenforum, I've already spend some time on this forum today but I can't find the solution to a particular registry problem I'm having. While windows was uploading some updates yesterday, I cleaned my registry using Iolo's system mechanic tool and that's where the problems started. (I...
Backup and Restore
Driver Sweeper can't delete all registry files in registry editor
http://i2.aijaa.com/b/00227/9175142.png So this is the situation: I've unistalled Amd Driver from Device Manager, Unistalled Catalyst software and ran Driver Sweeper. There is only 3 registeries that the Driver Sweeper CAN'T delete and these are under SYSTEM\ folder. I've tried to change user...
Drivers
Portable devices not listed in Autoplay option . Won't pop autoplay.
Hi I have protable device that won't autoplay when plugged , but it is shown in my computer and it's fully functional , it is not visible in the Autoplay option in the control panel , I tried reinstalling the device , but same thing , I followed Shawn's topic , how to set autoplay for...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App