Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: File that just won't delete

14 Feb 2011   #1

Windows 7 RC
File that just won't delete

Hi all

I've been lazy setting up my new computer, and I've installed Windows 7 Ultimate on an SSD, and just hooked up the HDD from my old one intact. I don't want to format my HDD, since it's got a lot of documents, pictures etc. on it. But I did want to delete the old Program Files, and the redundant Windows installation. Which has worked just fine using the takeown + icacls routine.

This has left me with one single file, D:\Windows\SysWOW64\Macromed\Flash\FlashUtil10b.exe which just won't delete. I've tried the takeown + icacls routine in safe mode, but it still won't go. Takeown returns "successful" and icacls returns "processed", but when I try to delete or attrib -r it still says "access denied"...

Any ideas?

My System SpecsSystem Spec
14 Feb 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

It does sound like a ownership issue.
You can use the recovery console which should ignore basically any file attributes.

Or you could try the old trick of killing the explorer process then attempting the delete (though that shouldn't matter in this scenario where the disc is no longer the system disc)
Last thing I can think of is to make sure the disc isn't still marked as a system/ boot disc in disc manager.
My System SpecsSystem Spec
14 Feb 2011   #3

Windows 7 RC

Hi again

I ended up deleting the file after removing the "Authenticated Users" group's special permissions on the HDD. Thanks for the recommendations anyway.

- Benjamin
My System SpecsSystem Spec


 File that just won't delete

Thread Tools

Similar help and support threads
Thread Forum
File permissions, can't delete file with 0 bytes size
I downloaded a file, didn't download correctly, size = 0 bytes. Reports owner unknown. I can't change ownership, remove file properties, any of that stuff. Can't rename or delete. I'm logged in as administrator but it keeps asking for administrator permission. ?? Another question about...
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
Help file wont delete win 7 says there is no file
I have a download that got interrupted and now have a file with extension .file that cant be deleted. Cleaning software wont catch it, restarting not working either. Havent tried a restore yet
General Discussion
Can't delete file due to invalid file name
Hey all! I have a .png file on my secondary hard drive, which I cannot seem to delete. When I try to delete or rename it, it tells me: "The selected file name is invalid or too long". I came across the programs Delinvfile and Unlocker, but they did not seem to work for me. Appreciate any...
General Discussion
Can't delete a jpg file
I can't delete a jpg file from our computer. The issue is that we can't even click on the file w/o it freezing the computer. I noticed the problem because I tried to run a defrag and virus check but both get stuck on this same file. I can't right click on it or even drag a box over it w/o the...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:26.
Twitter Facebook Google+