Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why runs slowly when i have 2GB RAM and P4 2.8 Ghz ?

27 Jun 2009   #1
extomas

WIndows 7
 
 
Why runs slowly when i have 2GB RAM and P4 2.8 Ghz ?

Hello everybody I have problem with Windows 7 on PC computer. IT runs slowly even i turn on clasic view and turned off all effects... My PC is:
Pentium 4 2.8 Ghz
RAM 2GB
Motheroard - AsRock
Video - Nvidia GeForce 7600 - 512Mb
WIndows installed on Sata HDD 40GB, in system there is more two HDD with 160GB and 250GB

IT runs more slowly than Windows XP before...

I thinks it could be few possibilities:

1. Previous widows xp were installed on drive D (in the same sata hdd) and when installed windows 7 on C (in the same hdd) it shows me (when boots) one more selection to choose one more OS, but when I select it nothing happens just black window and I need to reset pc and choose windows 7 to boot. Maybe this issue can be fault?

2. My Sata HDD is very old. Maybe there is problem?

3. Maybe there is old RAM's and old CPU with MB ?

Windows 7 is officiall beta release from microsoft...

In example on my HP laptop with Centrino and 1GB RAM runs perfectly with pre-beta release installed earlier. Runs default without any modifications like turning effects or smth...

Please help me find out problem.


My System SpecsSystem Spec
.
27 Jun 2009   #2
netRAT

Win7 7201 X64
 
 

Try installing on a different, clean formatted HDD.

Are you sure that 40 GB drive is SATA? Or is it IDE?

Make sure you have motherboard chipset drivers installed.

netRAT.
My System SpecsSystem Spec
27 Jun 2009   #3
sergiogarcia9

 

this is a long shot, but which build are you using? there's something about some builds is faster than other (on some machines).
My System SpecsSystem Spec
.

27 Jun 2009   #4
zigzag3143

Win 8 Release candidate 8400
 
 
slow pc

Quote   Quote: Originally Posted by extomas View Post
Hello everybody I have problem with Windows 7 on PC computer. IT runs slowly even i turn on clasic view and turned off all effects... My PC is:
Pentium 4 2.8 Ghz
RAM 2GB
Motheroard - AsRock
Video - Nvidia GeForce 7600 - 512Mb
WIndows installed on Sata HDD 40GB, in system there is more two HDD with 160GB and 250GB

IT runs more slowly than Windows XP before...

I thinks it could be few possibilities:

1. Previous widows xp were installed on drive D (in the same sata hdd) and when installed windows 7 on C (in the same hdd) it shows me (when boots) one more selection to choose one more OS, but when I select it nothing happens just black window and I need to reset pc and choose windows 7 to boot. Maybe this issue can be fault?

2. My Sata HDD is very old. Maybe there is problem?

3. Maybe there is old RAM's and old CPU with MB ?

Windows 7 is officiall beta release from microsoft...

In example on my HP laptop with Centrino and 1GB RAM runs perfectly with pre-beta release installed earlier. Runs default without any modifications like turning effects or smth...

Please help me find out problem.
Hi and welcome to SF
we will do our best to help you.
You Pentium is a few yrears old and doesn't have a ton of ram but it still meets the win 7 minimum requirements. If you could tell us all about it. who makes it what model video card, what apps are you running, how big is you page file etc. we can help you better.

Ken
My System SpecsSystem Spec
27 Jun 2009   #5
sup3rsprt

XP, Seven, 2008R2
 
 

Quote   Quote: Originally Posted by extomas View Post
IT runs more slowly than Windows XP
That is normal. Especially with older hardware.
My System SpecsSystem Spec
27 Jun 2009   #6
extomas

WIndows 7
 
 

I'll try to do what NetRat offered I have this in minds too, thanks.

To NetRat: yes it is Sata, because I myself connected all parts of pc...
To Sergiogarcia9: IT is official beta, build 7100
To sup3rsprt: Maybe, but on Hp laptop win 7 is much faster than WinXP (and no matter that it is "designed for xp" and capable for Windows Vista...) Here is why i thought that on my old PC windows 7 will be faster too

But know it is quite hard to work with him

Ok, I'll back than i have results

P.S. Maybe anyone knows why i see two options to boot OS ? In which file I can edit this? In Windows xp it was boot.ini, but here??? And if I delete that line, files still will be in hard.... So I think is better would be format hdd if Netrar offer succeed Answered in my own question
My System SpecsSystem Spec
27 Jun 2009   #7
elecg2

Windows XP x64/ Sev7en RC x64
 
 

Hunnn..im contacting Yoda for your question, because...
Win 7 works soo good on other computer here
P4 3.4 GHZ
1 GB DDR2 667 with 128 Mb Video Onboard.
All componentes onboard
IDE 66 HDS ( 20 and 40 GB )...
This works like XP, and, dont have any problems.
I have instaled the 7229 x64 on this system...yes, an x64 with 1 GB ( 8xx of RAM )
And 1 Gb Kingston Pendrive for Ready Boosst, Avira, Netlimiter, MSN, all om background...and,. with default drivers without any update to oficials from market.

Bye...

Quote   Quote: Originally Posted by extomas View Post
I'll try to do what NetRat offered I have this in minds too, thanks.

To NetRat: yes it is Sata, because I myself connected all parts of pc...
To Sergiogarcia9: IT is official beta, build 7100
To sup3rsprt: Maybe, but on Hp laptop win 7 is much faster than WinXP (and no matter that it is "designed for xp" and capable for Windows Vista...) Here is why i thought that on my old PC windows 7 will be faster too

But know it is quite hard to work with him

Ok, I'll back than i have results

P.S. Maybe anyone knows why i see two options to boot OS ? In which file I can edit this? In Windows xp it was boot.ini, but here??? And if I delete that line, files still will be in hard.... So I think is better would be format hdd if Netrar offer succeed Answered in my own question
My System SpecsSystem Spec
27 Jun 2009   #8
sup3rsprt

XP, Seven, 2008R2
 
 

Quote   Quote: Originally Posted by extomas View Post
To sup3rsprt: Maybe, but on Hp laptop win 7 is much faster than WinXP
Not on my HP laptop with dual core CPU. XP is faster.

But I like the power options of Windows 7, so I use it too.
My System SpecsSystem Spec
27 Jun 2009   #9
Mongo

XPSP3, Se7en RTM
 
 

Quote   Quote: Originally Posted by extomas View Post
Hello everybody I have problem with Windows 7 on PC computer. IT runs slowly even i turn on clasic view and turned off all effects... My PC is:
Pentium 4 2.8 Ghz
RAM 2GB
Motheroard - AsRock
Video - Nvidia GeForce 7600 - 512Mb
WIndows installed on Sata HDD 40GB, in system there is more two HDD with 160GB and 250GB

IT runs more slowly than Windows XP before...

I thinks it could be few possibilities:

1. Previous widows xp were installed on drive D (in the same sata hdd) and when installed windows 7 on C (in the same hdd) it shows me (when boots) one more selection to choose one more OS, but when I select it nothing happens just black window and I need to reset pc and choose windows 7 to boot. Maybe this issue can be fault?

2. My Sata HDD is very old. Maybe there is problem?
Age has nothing to do with it... Run a disk check (CHKDSK) to see if there are any bad sectors on the drive.

Quote   Quote: Originally Posted by extomas View Post
3. Maybe there is old RAM's and old CPU with MB ?
Your system specs are higher than mine. I'm currently using Windows 7 build 7229 and it's just as fast as XP. Windows 7 should run just fine with your current hardware.

You might want to check your BIOS settings or reset it to factory defaults. Also check the Asrock website for any BIOS and/or chipset driver updates.

If all else fails, reformat and start over...
My System SpecsSystem Spec
27 Jun 2009   #10
extomas

WIndows 7
 
 

Quote   Quote: Originally Posted by elecg2 View Post
Hunnn..im contacting Yoda for your question, because...
Win 7 works soo good on other computer here
P4 3.4 GHZ
1 GB DDR2 667 with 128 Mb Video Onboard.
All componentes onboard
IDE 66 HDS ( 20 and 40 GB )...
This works like XP, and, dont have any problems.
I have instaled the 7229 x64 on this system...yes, an x64 with 1 GB ( 8xx of RAM )
And 1 Gb Kingston Pendrive for Ready Boosst, Avira, Netlimiter, MSN, all om background...and,. with default drivers without any update to oficials from market.

Bye...
One diffrent there is which i forgot to mention, is my PC there is old RAM, DDR (not DDR2 or higher)... Here is main thing i think...
Another is that motherboard is ASrock... (it slowest motherboards in market as always it was..)
I tryed to format another partition in other hdd and installed win 7 and no changes for this, my pc is slower than hp laptop with lower ram, but hp has ddr2.

My conclusion is this:

motherboard asrock is slow/old (main thing)
ram is slow/old (no matter how much you have it)

So it means that most important things buying new pc will be these two parts...

Thank you all
My System SpecsSystem Spec
Reply

 Why runs slowly when i have 2GB RAM and P4 2.8 Ghz ?




Thread Tools




Similar help and support threads
Thread Forum
WDC Green: 750 GB runs Hot, 4 TB runs Cool ???
I have two external hard drives, both in Vantec NexStar3 USB enclosures. The older 750 GB WDC Green drive runs HOT to the touch, the 4 TB, and the 2 TB before that, run pretty warm but never hot. Why might this be, and would that much heat cause earlier than necessary drive failure?
Performance & Maintenance
age of Empire 2 EN LJ 65 laptop runs slowly
Hi, age of empire 2 runs very slowly on my EN LJ 65 laptop. It starts in the menu and it takes a long time to switch hotkeys. When im playing it runs rather smoothly in the beginning but when more units is on the map the game responds very slowly. None of my friends have the same issue so it...
Gaming
WIN7 x64 - Uses all available RAM, runs slowly
Hi all, pardon the newbie question. If this has been answered already please point me that way? I did do a search but found nothing to help. My system is a home built, Core I7, 8GB RAM, Radeon 560 TI with 2GB VRAM. Recently upgraded from 4GB RAM. I was having this same issue with 4GB of...
General Discussion
Windows 7 x64 installs and runs slowly
I am trying to upgrade my wife's computer to Windows 7 x64 from Windows Vista x32. It has run great for the past 3 years using Vista 32bit. The system shows it should run x64 bit no problems. I've already run the Windows 7 Upgrade adviser that also says I should have no problems. However...
Installation & Setup
replaced rj45 lan input with a new lan card but runs very slowly
My motherboard is an Asus M3A78-EM and I have been using the system with the built in lan rated at 10/100/1000 mbps. The socket seems to be going bad so I tried replacing it with another internal card. They only had two to choose from at Office Depot were rated at 10/100/ mbps. and the other which...
Network & Sharing
Virus? Computer runs extremely slowly!
Hi, I hope this is the right place to post. If not, I apologise, let me know and I'll move it to where it should be. Thanks! Basically, I'm having major problems with my computer of late, and the troubles all started a few weeks ago when I got a virus. I don't know much about getting rid of...
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App