Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CheckDisk fails in external RAID 5 device

02 Mar 2011   #1
uvazquez

Windows 7 Enterprise x64
 
 
CheckDisk fails in external RAID 5 device

* OS: Windows 7 Enterprise x64
* External Storage:
Mediasonic ProRAID HFR2-SU3S2 with 4 x WD 2TB SATA II (RAID 5) through USB 3.0
* Removal Policy: Quick Removal

I turned off the external storage without disconnected from the OS using the Safe Removal Hardware utility. Eventhough I almost always do it through the SRH utility, this exceptional case should not be a problem because of the Removal Policy for this disk. But next tiemes (all of them since thent) I connect the storage again (every single time), Windows displays a message saying:

"There might be a problem with some files on this device..." and asks for "Sacan and fix (recommended)" or "Continue without scanning".

1) If I click on "Scan and fix", the CheckDisk utility never do anything. In two hours the progress bar does not move nothing.

2) If I clck on "Continue withut scanning", it works properly. I have copied all the data to another disk and it reads all well. There is not a real problem in the disk. But I do not want to see all my life the same message everytime I connect the device!!!!! (I have seen at least 10 times since then).

What can I do about it?

Thank you in advance.


My System SpecsSystem Spec
.
02 Mar 2011   #2
barryware

Windows 7 Professional
 
 

I have a different device but pretty much the same (they all are about the same). Is there not a utility built into the devices firmware to allow you to scan the array and rebuild it if necessary?

Typically, there is a built in utility or a program utility you run that is device specific. Possibly that will solve your issue.

I am speculating as I do not have your exact device nor do I run enterprise addition of win7 but the devices I have hands on with, that is typically how they work.
My System SpecsSystem Spec
02 Mar 2011   #3
uvazquez

Windows 7 Enterprise x64
 
 

It should have, but the RAID is not corrupted. The storage works well. All the information can be read without any problem.

The only one real problem is the Win7 message about a "possible" problem (which does not exist). I can click in "continue without scanning", but it is a very bad idea to do that for the rest of my natural life every single time I connect the device. I want Win7 avoids to display that message.
My System SpecsSystem Spec
.

02 Mar 2011   #4
barryware

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by uvazquez View Post
It should have, but the RAID is not corrupted. The storage works well. All the information can be read without any problem.

The only one real problem is the Win7 message about a "possible" problem (which does not exist). I can click in "continue without scanning", but it is a very bad idea to do that for the rest of my natural life every single time I connect the device. I want Win7 avoids to display that message.
Well.. Raid 5 you can pull a drive out with no loss of data. Your raid box should throw an error but connected clients will see no loss of data. I'd run the utility anyway to rule it out.

I had a similar problem with a usb pen drive.. everytime I plugged it in, windows would want to do a scan disk or continue.. I could do nothing to correct it even though I would let the scan happen and no errors were reported.

I ended up formatting the drive and problem was solved.

soooo.. I would run the box's utility and see what it comes up with. You stated that you have already copied off the data so rebuild the array, reformat it and put the data back.

I personally wouldn't trust anything holding data without it being tip-top.

I know of no work around if windows thinks there is a storage error but I am sure I'm not the smartest around either.
My System SpecsSystem Spec
Reply

 CheckDisk fails in external RAID 5 device




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 installer not able to find SATA RAID device driver
I have XP running with a Samsung 840 EVO SSD: Motherboard: ASUS P5KPL-CM Processor: Intel Core 2 Duo CPU E7400 @ 2.80 GHz AMIBIOS: Version 0606 Build date 03/11/09 Bios IDE Config: ATA/IDE Configuration Enhanced Mode Support on
Drivers
External harddrive fails
I have a 500Gb external harddrive which is connected to my PC and pretty much on whenever the PC is on. Used it as back-up for all my work data. Today (half an hour ago) I see that it is not visible when I click on My Computer. Noticed that it was off so I turned it back on but got a message that...
Hardware & Devices
Checkdisk fails at Windows startup
I wanted to do the checkdisk action for my computer, it fails, and saying I have to use system restore to get rid of a recent software package installation. so what should i do right now?
General Discussion
Extremely Slow speeds using e-sata and usb 3 external raid box
Hi there guys, I have a hotway 4 bay usb 3.0/e-sata box that is currently in RAID and when connected to either e-sata or USB3.0 I am experiencing really slow speeds. On average 2.48MB/s. To describe what happens, the speed shows anywhere from 70-200MB/s when I first try to copy things over...
Hardware & Devices
Configured 8 TB external drive as a RAID 5 + 1, how can I verify?
Hello, Purchased a 8 TB LaCie 4 Big Quardra U device, decided to configure it as RAID 5 + 1. Followed instructions, but just want to verfiy that I did it correctly. Where would I look on my system to confirm that I did it correctly. Is this something that would be reflected in...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App