Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Very slow Win 7 Initialization - 2 to 3 min

13 Mar 2011   #1
fireberd

Windows 10 64 bit
 
 
Very slow Win 7 Initialization - 2 to 3 min

I'm having very slow startup times with my Win 7 64 bit system (it has been happening since before installing SP1). It takes 2 to 3 minutes to startup and I see the Ethernet link initialization taking up most of the this. The link icon will have the "circle" wait symbol on it for over 1 minute before the link comes active and while it's on "wait" nothing else appears to be initializing as Microsoft Security Essentials icon stays red and none (two) of the sidebar comes up (I have a weather and the "All CPU" meter).

I have a separate hard drive on this PC with Vista 32 bit and it does not have the excessing startup time with Vista - the Ethernet link activates almost immediately.

I'm using a Linksys router but it's not the router as I've connected the RJ45 directly to the cable modem and it acts the same.

Whether it's the link activation that is causing the delay or some other process?? I have a relatively vanilla system and not much is in the startup. I've disabled some start up items in msconfig and that didn't help anything. I've reinstalled the Intel NIC drivers and also let Windows install drivers for the NIC and that didn't help.

In the notification area, I have Volume Control, Network Connection, Microsoft Security Essentials, Win Patrol, Epson Event Manager, Malwarebytes and "safely remove hardware" icon (because of an iLock key). I've disabled Win Patrol, Epson Event Manager, Malwarebytes and MIcrosoft Security Essentials in startup and it didn't make any difference. Actually all of these items have been installed for quite a while - before I noticed the slow startup.

I don't want to do a complete reinstall unless absolutely needed. Too much of a hassle.

If I start in Safe Mode with networking, the network link takes the same amount of time to become active.


My System SpecsSystem Spec
.
13 Mar 2011   #2
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Hi Fireberd,

Install and Run free Soluto.

Once you reboot after installation, it presents a very easily understood graphic showing all the components that load during boot, as well as how long each one takes (example shown in image below).

This might help find out what is causing your long startup time.

See this video to see how it works - its pretty neat:



Regards,
Golden


Attached Images
Very slow Win 7 Initialization - 2 to 3 min-capture.png 
My System SpecsSystem Spec
13 Mar 2011   #3
fireberd

Windows 10 64 bit
 
 

Thanks, I'll give it a try.
My System SpecsSystem Spec
.

13 Mar 2011   #4
gregrocker

 

If Soluto doesn't make the problem apparent then use the tool which the Pro's use to trace boot hangs: Trace Windows 7 boot/shutdown/hibernate/standby/resume issues - MSFN Forum

Our own Cluberti who also runs MSFN can help you interpret the charts if the tutorial isn't enough. In one recent case I learned, for example, that a Dell laptop was hanging for 2 minutes due to heavy fragmentation of System Files, after which it remained a full minute startup due to old slow HD.
My System SpecsSystem Spec
13 Mar 2011   #5
fireberd

Windows 10 64 bit
 
 

Thanks I'll give this a shot. Soluto didn't show me anything I didn't already know. I'm still seeing the long network connection time, that is on a separate PC with Vista 32 bit that is wire connected to the router and with this same PC hardware when booted with Vista 32 bit.
My System SpecsSystem Spec
13 Mar 2011   #6
sbrads

Windows 7
 
 

Try giving your network adapter a fixed network address, e.g. 192.168.0.2 via Device Manager>Network Adapters> Properties for your adapter. You can find out what your PC is currently automatically setting itself up as (perhaps slowly) by typing ipconfig into a DOS prompt - use that number.
My System SpecsSystem Spec
13 Mar 2011   #7
fireberd

Windows 10 64 bit
 
 

I installed the SDK and ran a boot trace. Funny thing with the boot trace active the startup looked "normal". But, I rebooted and without the boot trace it was back to an extended boot time with the network on the 64 bit system, but not the Vista 32 bit systems.

I'll try the fixed address but I don't think that is the problem, since this same hardware works OK (normal startup and no real delay on network) on Vista 32 bit.
My System SpecsSystem Spec
13 Mar 2011   #8
fireberd

Windows 10 64 bit
 
 

The fixed address made no difference. It has to be something related to the startup sequence and what is loaded when. As I noted when running the boot trace it started "normal" including the sidebar CPU Usuage monitor before the network. A "normal" startup it has to wait for the network before other items startup.

Fortunately I normally startup in the morning, at a set time before I get up, and it's left on all day
My System SpecsSystem Spec
13 Mar 2011   #9
gregrocker

 

I'd next run through these troubleshooting tips to see if anything becomes apparent.

In particular see if any issues are cued at the top of the Advanced Tools page referenced in the list, and check the logs listed for clues.
My System SpecsSystem Spec
13 Mar 2011   #10
fireberd

Windows 10 64 bit
 
 

I didn't see anything in the thread you referenced. Many of the items have either been previously checked or do not apply.
My System SpecsSystem Spec
Reply

 Very slow Win 7 Initialization - 2 to 3 min




Thread Tools




Similar help and support threads
Thread Forum
Slow Internet connection Initialization on Startup
Hello i am having an unusual problem with windows 7 64 Bit. I am using a belkin wireless adapter with windows 7 64 bit drivers. When i startup the computer the blue circle just keeps turning on my internet connection icon in the taskbar. The internet connection takes 2-3 mins to startup and it...
Network & Sharing
CSM initialization Error with RAM
OK, when I am overclocking my ram I am able to reach DDR3 2296 however when I go pass DDR3 2300+ I get the following error code 79 which is CSM initialization. Question 1 Does anyone know what CSM initialization is? Question 2 What bios setting do I need to do to push past this to...
Hardware & Devices
Slow initialization in Windows 7
hello; i am using windows7 ultimate 32-bit and when i start to boot my computer, after all the four points have joined to make windows logo, it takes about 5 mins to show the welcome screen..., and the welcome screen also makes late to show desktop.. Can anybody help me>>>:cry:
General Discussion
HDD initialization
Hello, i'm trying to connect an external HDD via eSATA to my notebook. It shows up uninitialized, but when i try to initialize it i get the message "The system cannot find the file specified" under the tab "Virtual Disk Manager". Yfrog - erri Disk 1 is the external drive. Any tips on how...
Hardware & Devices
HDD Initialization Problem
A few threads on this but nothing seems to cover my problem. Briefly: 1. I'm using a so far trouble free home build, quad core, 8GB DDR2, desktop running W7 Pro 64 whos main function is editing photgraphic images. I have 4 WD internal HDDs (2x 150 GB, 1x25GB and 1x 1TB) and an external USB3...
Hardware & Devices
DirectX Initialization
I have one game (Kyodai Mah Jongg) that normally runs fine, but on occassion, it will freeze not only itself but the OS, and when this happens, it is always at the same point...intializing DirectX. The only alternative is a forced restart of the OS, which is something that I would like to avoid. ...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App