Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CoreFoundation 11 x64.dll MISSING?

14 Mar 2011   #1
Ev Barney

Windows 7 Home Premium x64-based PC
 
 
CoreFoundation 11 x64.dll MISSING?

I am getting this message when i try to boot Photoshop cs4 64 bit. The 32 bit version is fine. BUT if I open a document with photoshop as the default ap, I get the message. I have uninstalled adn reinstalled the entire Adobe CS4 suite - no joy.

Fragmentation is not an issue, as my OS drive is solid state.

I use Microsoft Security essentials as my anti-virus ap. And, I've run Spybot S&D, as well as Iobit Advanced Care pro to try and locate/fix the problem.

I've also followed advice I've seen on the net to uninstall adn reinstall Apple software (Quicktime, iTunes, etc . . .) but that hasn't helped. I've also uninstalled and reinstalled the entire Adobe CS4. It didn't help.

LOTS of sites like this one want to sell me their magic fixes. I'm dubious. Particulalry sinc enone of them tell you the price untill you have DLed and scanned.

I've also searched the registry using the RUN command - and can't find any reference to CoreFoundation (well GOSH - the error DID say it was missing) and even (I think) reputable site sites that offer a CoreFoundation .dll for download don't offer ones with this string: 11 x64 - but that may be irrelevant.

My PC has did hang on me a couple of times since this started, so I'm afraid of things getting worse.

Any thoughts?


My System SpecsSystem Spec
.
14 Mar 2011   #2
cluberti

Windows 10 Pro x64
 
 

Given that file is installed and in use by iTunes and/or Quicktime (seems that the Apple "helper" apps install this), reinstaling Photoshop isn't likely to help:
http://forums.adobe.com/thread/819736
MobileMe: "CoreFoundation.dll was not found" or " Apple Application Support is missing" alert

What you could do, however, is run process monitor from sysinternals, configure it to only watch files (ignore registry / process events / etc by unclicking those buttons in the top toolbar in procmon), and then start the app until you get the error. Stop procmon logging (F12), and then search for that .dll name and see exactly where it's looking. You will need to put that .dll in whatever location seems most appropriate, and/or figure out what installed that .dll in the first place (again, it seems to be a Quicktime/iTunes .dll, so perhaps reinstallation of those packages will fix it?).
My System SpecsSystem Spec
14 Mar 2011   #3
Ev Barney

Windows 7 Home Premium x64-based PC
 
 

Quote   Quote: Originally Posted by cluberti View Post
Given that file is installed and in use by iTunes and/or Quicktime (seems that the Apple "helper" apps install this), reinstaling Photoshop isn't likely to help:
Adobe Forums: Missing file: CoreFoundation_v11x64.dll
MobileMe: "CoreFoundation.dll was not found" or " Apple Application Support is missing" alert

What you could do, however, is run process monitor from sysinternals, configure it to only watch files (ignore registry / process events / etc by unclicking those buttons in the top toolbar in procmon), and then start the app until you get the error. Stop procmon logging (F12), and then search for that .dll name and see exactly where it's looking. You will need to put that .dll in whatever location seems most appropriate, and/or figure out what installed that .dll in the first place (again, it seems to be a Quicktime/iTunes .dll, so perhaps reinstallation of those packages will fix it?).
okay - thanks will try that - BUT - does it matter that my error message has thouse numbers (11 x 64 - and keep in mnd this only comes up with the 64 bit version of Photoshop) or can i just use the corefoundation.dll?

Also - I've done the "take out all apple aps and reinstall" thing and it's not fixed. siiiiiiiiiiiiiiiigh
My System SpecsSystem Spec
.

14 Mar 2011   #4
cluberti

Windows 10 Pro x64
 
 

Quote   Quote: Originally Posted by Ev Barney View Post
okay - thanks will try that - BUT - does it matter that my error message has thouse numbers (11 x 64 - and keep in mnd this only comes up with the 64 bit version of Photoshop) or can i just use the corefoundation.dll?

Also - I've done the "take out all apple aps and reinstall" thing and it's not fixed. siiiiiiiiiiiiiiiigh
#1 - Yes, it matters. #2, use procmon at this point to figure out where it thinks the file should be, but isn't .
My System SpecsSystem Spec
14 Mar 2011   #5
Ev Barney

Windows 7 Home Premium x64-based PC
 
 

okay - tried a number of things (first the ones you suggested) and here is what worked - (Keep in mind that uninstalling and reinstalling the suite DID NOT work so go figure):

Removed the plug-in folder (nope - hadn't added any to PS - just what it come with) then reinstalled just PS x64 without any other deletions.


got joy.

what can i say?

all is well



thanks for the support!

A number of sites (inclduing Adobe) talk aobut various causes for this error. The "remove plug-in folder" fix that worked came from an Adobe forum post - i just don't recall which one!
My System SpecsSystem Spec
Reply

 CoreFoundation 11 x64.dll MISSING?




Thread Tools




Similar help and support threads
Thread Forum
Missing files, missing "user" folder, can't access local drive
Hello to all! I'm new to this forum and obviously i'm not sure if this is the right place for starting and posting this thread. Since i'm pritty desperate i'm going to explain the best i can what is really happening and how it all started: since a few days ago i was noticing that a few...
General Discussion
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing MBR and missing OS after sleep problem
My setup had an MBR issue a few days ago after installing Skyrim. I was unable to repair it using the windows 7 instal disc. I tried the automatic fix as well as bootrec.exe. After giving up and reinstalling a fresh windows 7, my rig has not been starting up properly. It insists on waking up from...
BSOD Help and Support
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App