Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow system

08 Apr 2011   #11
LarryE1946

Window 7
 
 

Quote   Quote: Originally Posted by Shootist View Post
You are welcome. Hope it all works out for you.

I have to add that many will say there is no reason to stop services. Win 7 is as lean and mean as any OS MS has ever released. And that it will take care of itself.
I think differently. In fact I posted this on another thread.
I just installed another 8GBs of RAM in my system. Bringing the total to 16GBs.
When I had only 8GBs my page files usage at startup was under 1GB in size. With this other 8GBs of RAM installed you would think the page file usage size would go down as the system has more RAM to use. NO the page file is now 1.4+GBs at startup with the exact same services running. Seems kind of ASS BACKWARDS to me.
Yes, that does sound rather backwards to me also. Wonder if anyone can explain why?


My System SpecsSystem Spec
.
08 Apr 2011   #12
gregrocker

 

Uncheck everything in msconfig>Startup except AV and gadgets - all others are freeloaders on your RAM/CPU, Startup and can spy on you. Startup Programs - Change

After several restarts, find out what is writing itself back into Startup list, then turn it off in its Preferences.

Next hide all MS Services in msconfig>Services to see what else is starting without your knowledge. Uncheck the items and restart to check performance. If they write themselves back in, turn them off in Preferences or uninstall them.

Other Win7 troubleshooting tips: Computer lags every couple seconds
My System SpecsSystem Spec
08 Apr 2011   #13
LarryE1946

Window 7
 
 

Thanks for the advice. I appreciate it. Only thing running in msconfig is my anti-virus software and Intellipoint because I have the mouse buttons configured and if I turn that off, my buttons don't work the way I want them to. Other than that, nothing else is loading. As far as the services, I've gone through the list of services that was prepared by Black Viper and have followed his advice. The changes I made this morning seem to have helped and I honestly think it was the Corel software I recently installed that was messing up.

Again, thanks for the advice.
My System SpecsSystem Spec
.

08 Apr 2011   #14
gregrocker

 

I was not referring to Black Viper service edits which are outmoded with Win7, which is as lean as it can be and requires no tweaking.

If you read the steps I gave you carefully you'll see I was referring to how program sneak into the msconfig>Services tab and how to keep them out - just as with the Startup tab.

Try uninstalling the Corel software long enough to see what happens.
My System SpecsSystem Spec
08 Apr 2011   #15
LarryE1946

Window 7
 
 

I know what you were talking about and if you read my message I said that I had already taken care of MSCONFIG. The first thing I do when I get a new computer is get rid of all the "bloatware" and make sure only one or two things I really need are running in the background. And the Black Viper list has been updated for Windows 7, which is not quite as lean as you say it is. There are still processess running that are not necessary and need to be either disabled or set to manual.
My System SpecsSystem Spec
08 Apr 2011   #16
Shootist

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by LarryE1946 View Post
I know what you were talking about and if you read my message I said that I had already taken care of MSCONFIG. The first thing I do when I get a new computer is get rid of all the "bloatware" and make sure only one or two things I really need are running in the background. And the Black Viper list has been updated for Windows 7, which is not quite as lean as you say it is. There are still processess running that are not necessary and need to be either disabled or set to manual.
I agree with you on turning off some services that I do not need. One is the WLan service. I don't have a Wireless card in my desktop PC, no need to have that service running. I also don't use the windows firewall, that is set to manual. Home group services are set to manual. I don't use the home group I have it setup as a work network PC.

In any event many say Win 7 is lean. Not in my opinion.
My System SpecsSystem Spec
08 Apr 2011   #17
gregrocker

 

More advanced users may find services they personally don't use to turn off, but when average users try to use service edits they can run into unintended consequences.

Many of us who lived by Black Viper's service Edits in XP and early Vista watched over a year's time as Windows 7 developed to where service edits and tweaks outside of normal System Settings are not needed and counterproductive.

The way to go with Win7 if you need additinoal performance is hardware upgrading.

Those who insist on tweaking and editing WIn7 services should bookmark our Crashes forum as this is where they will end up if they don't know exactly what they're doing.

Tips for cleaning up factory bloatware based on hundreds done here: Clean Reinstall steps
My System SpecsSystem Spec
Reply

 Slow system




Thread Tools




Similar help and support threads
Thread Forum
Network slow to initialize on startup, slow system
Specs: Win7 64bit, 4GB ram. For the past little while now, whenever I would turn on my computer, things would start up but it would hang, in the sense that nothing *would* start up until the network was found and connected to. The network indicator icon in the taskbar would just have a frozen...
Network & Sharing
System is slow, what to look for
Hello My PC (I5 with 8 gig) is running slow this morning. I have win7 64 Antivirus as found no treat. What do I look for - I have install Process Explorer: Other test to do?
Performance & Maintenance
System gone really slow.
My computer has suddenly gone really slow, for some reason, it can't handle more than one task at once or is very slow and choppy. For example, I can't transfer files without it being slow. I have 8GB of Ram, but can only use 4GB as for some reason I can't get 64 Bit. - ATI Radeon 6770...
Performance & Maintenance
Unknown icon in system tray - slow system - pic attached
Hi, I've been having some very slow system issues today and have checked that system resources seem to be at normal levels - CPU usage at around 20% and Memory usage at around 50% during normal operating. However I have noticed a new icon in my system tray which I can't identify, can't click...
Performance & Maintenance
system slow down
HI.. i jus bought new sony vaio-E series with 2 GB ram,,, it was fine working for 3 weeks,, i installed sql server n visual studio,,, my lap gettin slow in booting,,,and in performance,,, i m using windows 7 os 64 bit,, is dre any way to increase its speed and performance,,, any one ....plz...
Performance & Maintenance
System slow
my system is slow on start up and about 2 days and then everything to be good to go does any body know why and my hard drive seems to run constantly could it just be a bad drive and causing all my problem i am running with all the default setting
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App