Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: problem: 3.2GB RAM usable out of 8GB!!

28 May 2011   #1

Windows 7 Professional x64
problem: 3.2GB RAM usable out of 8GB!!

Well, this seems to be a common problem. Before answering please read well this thread.

I Have Windows 7 Professional x64 with 8GB installed (2x4GB DDR3 Kingston). I installed the windows with the 8GB from the start. Windows recognizes 8GB installed but only 3.2GB usable.

In the Resource Monitor 4.9GB are "Hardware Reserved". I have a nVidia GTS450 graphic card, but the nvidia control Panel "System Information" shows that it uses 1GB from the card framebuffer and 1.4 GB shared system memory.

The M/B supports 8GB

I didn't find any memory remap option on the BIOS, but it clearly detects 8GB (the BIOS).

I tried checking (and unchecking) the "Maximum memory" option in the msconfig > Advanced Options. When i chek it it automatically appears "8192" (8GB?), but when i reboot and check again it appears "0" (which means auto??). Nothing happens at all.

Further PC specifications:

MSI H55M-E21 M/B (socket 1156)
Intel i5-760
nVidia GTS450
2x4GB DDR3 Kingston (PC3 - 10600 CL9 240 - Pin DIMM)

See the images below

Any Ideas?

P.S: please dont tell me to check if my OS is 64 bit. It is

Attached Thumbnails
problem: 3.2GB RAM usable out of 8GB!!-propiedades.jpg   problem: 3.2GB RAM usable out of 8GB!!-resource-monitor.jpg   problem: 3.2GB RAM usable out of 8GB!!-system-information.jpg  
Attached Images
problem: 3.2GB RAM usable out of 8GB!!-tgrafica.jpg 
My System SpecsSystem Spec
28 May 2011   #2

Win 8 Release candidate 8400

UN-check Max memory so itr will auto sense.
My System SpecsSystem Spec
28 May 2011   #3

Windows 7 Professional x64

i did uncheck it... nothing happened
My System SpecsSystem Spec

28 May 2011   #4

Debian Squeeze Stable 64-bit

Why use that motherboard with the CPU? The H55 is a cheapo chipset where you'd use the onboard graphics of a supported CPU . . . . try taking out one RAM module and see what happens.
My System SpecsSystem Spec
28 May 2011   #5
Microsoft MVP

Win 7 Ultimate x64

This is primarily dealing with the x58 chipset but can apply to pretty much any Intel chipset,

Asus X58 + 6/12GB memory overclocking - detecting less memory than installed - - different look at memory

Is this a recent build? If not has the full 8 GB ever been fully available? If not #8 from that link might be the cause. If you check would be a good idea to pull the heatsink and CPU and check the pins in the socket and see if any of them are bent, seen quite a few reports elsewhere where a bent pin or two can cause the memory to act like yours is (if the bent pins don't render the whole issue inoperative).
My System SpecsSystem Spec
28 May 2011   #6

Windows 7 Professional x64

it is a recent build... i don't think #8 is the cause... i reinstalled the heatsink... but no changes

i removed the ram from slot 2.... result: 3.2GB usable out of 4

changed the memory stick..... result: the same

put then the second stick on the second slot.... result: back to "normal": 3.2GB usable out of 8...

conclussion: the memory sticks seems to be OK.

i also checked the socket pins... it looks like they're ok too...

nothing changed
My System SpecsSystem Spec
28 May 2011   #7

Debian Squeeze Stable 64-bit

Try an Ubuntu live CD. Does it still happen? Or is all RAM usable?
My System SpecsSystem Spec
28 May 2011   #8

W7 Professional x64

As you can see, 5 GB of memory is "hardware reserved" which is usually due to the motherboard allotting it for graphics. Your motherboard might simply be confused or have it allotted still. I will check on some ways to fix this.
My System SpecsSystem Spec
28 May 2011   #9

Windows 8 Pro

I have mine unchecked and its showing 2MB H/R
My System SpecsSystem Spec
29 May 2011   #10

W7 Professional x64

So far my research is putting the blame on a BIOS setting or update. Memory remapping in BIOS (or something similar) could fix the problem by unchecking that option. The other option is to look into BIOS updates and see if this issue is mentioned in any updates after your BIOS release.
My System SpecsSystem Spec

 problem: 3.2GB RAM usable out of 8GB!!

Thread Tools

Similar help and support threads
Thread Forum
Very strange memory problem 8gb installed 3.74gb usable
I recently swapped in a new motherboard to upgrade my graphics. the board came from a model in the same Pavilion dv6 3xxx series. Everything booted fine, the bios recognizes the processor and windows installed all the missing drivers right away. However I can only get half of my installed...
Hardware & Devices
Problem RAM (4GB RAM 2GB Usable) Windows 8.1 Pro
Hello, I will try to put there my problem, sorry for my english tho. So the problem I have is the RAM one, I mean I have 4 GB RAM installed, but only 2 GB 'usable'. I've done all things, like update BIOS, type msconfig, Boot, uncheck Maximum memory thing but nothing works,I tried to swap RAM...
Hardware & Devices
win 7 x86 4GB RAM only 2.6 usable
Hello, I recently bought an Acer Aspire one laptop with 4GB RAM memory installed. I 've installed windows 7 x86. It says that there are ony 2.6 GB usable. Can anyone tell me what to do. Because, as far as I know win 7 should recognize more than 2.6GB even in 32 bit version. I wouldn't want...
Performance & Maintenance
Problem with RAM sticks. Not usable? Gateway Laptop.
Heh.. Kinda new to this forum so yeah. Kinda getting a bit desperate about this. I've had a Gateway NV53A Laptop for about a year and a few months. No problems with it. Only problem I've found so far? It's REALLY slow. I mean on everything. Opening something, closing, shutting down,...
General Discussion
Problem after merging partitions Windows 7: Only 380GB/931.41 usable
Hi, a few months ago I created a partition on my C drive: Z:\ using "Partition Magic" because my C drive would only let me shrink to ~3GB. The Z: drive was ~500GB, while the C: drive was left with 380GB. I decided to merge the partitions, seeing as it made no difference in performance, using...
Hardware & Devices
usable memory problem
I have 4 gigs 2x2 on windows 7 x86 it shows 4 GB (3.25 GB usable) I have gone through msconfig and made sure the maximum memory was unchecked, and I've also tried setting a max memory amount, but it wont give me that last 750mb. Also my video card has 512mb of ram itself so it shouldn't be...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App