Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: High CPU usage, low fps, high latency.

08 Jun 2011   #1
NeoArod

Windows 7 Home Premiun x64
 
 
High CPU usage, low fps, high latency.

Since Jan-Feb of this year I have encountered the following issue while trying to play games on my laptop.

Abnormally High CPU Usage
Extremely low FPS - After 5-20 Mins of play.
Extremely High latency to servers - from 300 - 900 after 5 - 20 mins of play.

The thing is all of these started 1 year after I been using this laptop, after a full year of everything running flawlessly all these issues kicked in after I performed a clean install in Jan., I even performed one in Feb. and one 3 weeks ago, since someone suggested this could fix my issue and I still face the same problem.

I would kindly take any suggestions since I am so desperate that I am considering trowing this device out the window.

Here are my specs:

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600
System Manufacturer Dell Inc.
System Model Studio 1558
Processor Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz, 2400 Mhz, 2 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM) 4.00 GB
Name ATI Mobility Radeon HD 5400 Series
Adapter Description ATI Mobility Radeon HD 5400 Series
Adapter RAM 1.00 GB (1,073,741,824 bytes)


My System SpecsSystem Spec
.
09 Jun 2011   #2
zigzag3143

Win 8 Release candidate 8400
 
 

All of your symptoms could be a driver issue. Please download this free latency checker and run it to see if it is.

DPC Latency Checker
My System SpecsSystem Spec
09 Jun 2011   #3
NeoArod

Windows 7 Home Premiun x64
 
 

I'll try it immediately
My System SpecsSystem Spec
.

12 Jun 2011   #4
NeoArod

Windows 7 Home Premiun x64
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
All of your symptoms could be a driver issue. Please download this free latency checker and run it to see if it is.

DPC Latency Checker
Alright so I gave this a try and played arou disabling different devices in the computer, at times it does seem that it has helped a little bit with ts but I cant be 100% onn it since issues still persist.

Any other suggestions?
My System SpecsSystem Spec
13 Jun 2011   #5
Fumz

7 Ultimate x64
 
 

Give this a thorough read: "lag" in online games with Windows 7
My System SpecsSystem Spec
19 Jun 2011   #6
NeoArod

Windows 7 Home Premiun x64
 
 

Quote   Quote: Originally Posted by Fumz View Post
Give this a thorough read: "lag" in online games with Windows 7
Alright so I've known of this, but still gave it a try and searched a lot around the net this week, and did further testing on it, see if could get somewhere.

In a moment of frustration i started killing off services, and I got to one that did eliminate any issue, the only problem is that the laptop shut it self down after a few minutes and now cant remember what service or process I killed. Any other suggestions?
My System SpecsSystem Spec
19 Jun 2011   #7
Fumz

7 Ultimate x64
 
 

System restore... or you could go to someplace like Black Viper's and look at his list to see what the defaults should be. Black Viper’s Windows 7 Service Configurations | Black Viper's Website | www.blackviper.com
My System SpecsSystem Spec
20 Jun 2011   #8
NeoArod

Windows 7 Home Premiun x64
 
 

Quote   Quote: Originally Posted by Fumz View Post
System restore... or you could go to someplace like Black Viper's and look at his list to see what the defaults should be. Black Viperís Windows 7 Service Configurations | Black Viper's Website | www.blackviper.com
System Restore is not a working option since a clean install of windows doesnt fix the issue.

I checked the list for the W7 services, and still nothing, I've gathered some info from different sources that it could be a Audio Issue but I've tried available fixes and ideas and still nothing.
My System SpecsSystem Spec
23 Jun 2011   #9
NeoArod

Windows 7 Home Premiun x64
 
 

Anyone else got any other suggestions for this issue?
My System SpecsSystem Spec
23 Jun 2011   #10
SlackerITGuy

Windows 8.1 Pro
 
 

Have you tried disabling your Antivirus and/or Firewall when gaming?

Worth a shot IMO.
My System SpecsSystem Spec
Reply

 High CPU usage, low fps, high latency.




Thread Tools




Similar help and support threads
Thread Forum
Network usage causes high DPC Latency
Hey everyone, Happy New Year :) After about 24 hours of booting my computer, I have seen my DPC Latency spike tremendously. At first, I thought this was an issue with my network card (since disabling it would drop DPC Latency), so I bought a new card. The problem didn't go away, so I realized...
Network & Sharing
Svchost.exe Crazy High CPU Usage and Crazy High Memory Usage
There is a serious issue with svchost.exe on my windows 7 computer. My HP Touchsmart 300-1025 has windows 7 64bit installed and svchost is slowing down the computer and using very high cpu and memory usage. It is not a virus or malware. I know the computer is not infected because one the computer...
Performance & Maintenance
Very high physical memory usage, no high usage programs running
Hello everyone, I've been having a very weird problem recently, in which I BELIEVE is involving high physical memory usage. Sometimes I will be doing things such as playing a game, or watching a stream, and my computer will run fine for a little while. But at random times, my computer will majorly...
Performance & Maintenance
Stuttering and high CPU usage while downloading at high speeds
I've been having this problem now for an year or so now. It started when I upgraded my connection from 8/1 ADSL to 100/10 cable (so the problem wasn't noticeable even if it was there before) and when I download at high speeds (in steam, for example) my CPU usage jumps to 80% and higher, and my pc...
Network & Sharing
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App