Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: imageres.dll unfixable

12 Jul 2011   #1

Windows 7 Ultimate 64 bit Service Pack 1
imageres.dll unfixable

When I run sfc /scannow, I get the following in my log file:

2011-07-12 06:20:08, Info CSI 000000e4 [SR] Cannot repair member file [l:24{12}]"imageres.dll" of Microsoft-Windows-imageres, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file cannot be checked

I do not pretend to understand all these diagnostic messages, but to someone in the know they might indicate why sfc is not completing.

I have already replaced the "imageres.dll" with the one from the installation disk, but the problem is not going away. I do not understand why. However, since everything seems to be working OK, I don't really need to fix anything. I would like sfc to work correctly though.

If anyone knows why this is happening, I'd appreciate some tips. Thanks!

My System SpecsSystem Spec
12 Jul 2011   #2
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate

Quote   Quote: Originally Posted by Bare Foot Kid View Post
Hello mackerzz, welcome to Seven Forums!

Perhaps running the sfc /scan several times from boot will help where a 'regular' scan won't, because the files in question won't be 'in-use' during the process, have a look at this tutorial at the link below and be sure to post back with any further questions you may have and to keep us informed.

SFC /SCANNOW : Run in Command Prompt at Boot
Quote   Quote: Originally Posted by donensley707 View Post

... I'd appreciate some tips. Thanks!
Here's a tip, did you run this a couple times as suggested?
My System SpecsSystem Spec
12 Jul 2011   #3

Windows 7 Ultimate 64 bit Service Pack 1
Imageres.dll unfixable after boot CD sfc /scannow

I ran

sfc /scannow /offbootdir=f:\ /offwindir=f:\windows

five times following the suggestions, and replacing the drive with the actual one where the system being repaired was located (E: in my case).

The result each time was:

"Windows Resource Protection could not perform the requested operation."

Since there does not appear to be anything wrong with my system, other than a bit of a delay between the "Welcome" screen, to a black screen, before the desktop is displayed. However, this is not anything major.

I have already tried restoring the original "imageres.dll" file from the Windows CD, so I am thinking of trying some other type of repair, such as a system restore operation that retains my installed 3rd party software, but reinstalls the operating system. Of course, I do not want to make things worse by attempting a system repair at another level! Also, I am at service pack 1 of Windows 7 Ultimate, 64-bit.

Thanks for the assistance.
My System SpecsSystem Spec

12 Jul 2011   #4

MS Windows 7 Ultimate SP1 64-bit


Just stick to the garden variety sfc, that is,
sfc /scannow.

After all you've attempted, I'd like to ask you to run sfc /scannow once again.

This time, afterwards, create sfcdetails.txt file described in the tutorial SFC /SCANNOW Command - System File Checker

Attach sfcdetails.txt to your next post.
My System SpecsSystem Spec
12 Jul 2011   #5

Windows 7 Ultimate 64 bit Service Pack 1
sfc /scannow text output

I've attached file sfcdetails.txt according to the prescribed action of running the garden variety sfc at the elevated administrative command prompt. Thanks for the assistance.

Attached Files
File Type: txt sfcdetails.txt (9.6 KB, 35 views)
My System SpecsSystem Spec
12 Jul 2011   #6

MS Windows 7 Ultimate SP1 64-bit

go to \windows\system32 | right-click on imageres.dll | Properties | Security tab | Advanced button | Owner tab

Who is shown as the current owner?

do the same for:
the imageres.dll in \windows\syswow64
My System SpecsSystem Spec
12 Jul 2011   #7

Windows 7 Ultimate 64 bit Service Pack 1
owners of imageres.dll files

C:\Windows/system32/imageres.dll owner is:


This is me.

C:\Windows\SysWOW64\imageres.dll owner is:


This is not me.

My System SpecsSystem Spec
12 Jul 2011   #8

MS Windows 7 Ultimate SP1 64-bit

Is that an administrator account or a standard user account?

How to determine if you are an administrator:

1. Click on the Start button.
2. Select Control Panel.
3. Select User Accounts and Family Safety.
4. Select User Accounts.
5. On the right of the User Accounts window, you should see your account name, account icon and a description listed.
6. If the word "Administrator" is in your account’s description, then you are an administrator. If you see "Standard user," then you are not an administrator.
My System SpecsSystem Spec
13 Jul 2011   #9

Windows 7 Ultimate 64 bit Service Pack 1

I am an Administrator.

I have also changed the ownership on my C:\Windows\System32\imageres.dll back to TrustedInstaller, but nothing changed in the sfc /scannow. It still does not complete.
My System SpecsSystem Spec
14 Jul 2011   #10

Windows 7 Ultimate 64 bit Service Pack 1
Resolution of imageres.dll sfc /scannow problem

I have solved the problem! It was the security settings on the files in the system directory and the restore location in the winsxs folder that caused the problem.

I set both of these to include SYSTEM, Users, Administrators, and TrustedInstaller as seen in the two attached PNG screen-shots.

The owner in both cases if TrustedInstaller, and the auditing is by Everyone (All).

After setting these up, the sfc no longer reports any problems.

In my case with SP1, this was far better than trying to reinstall Windows 7!

Thanks again for everyone's contributions!

Attached Images
imageres.dll unfixable-imageres.dll-system32-folder-permissions.png imageres.dll unfixable-winsxs-imageres.dll-permissions.png 
My System SpecsSystem Spec

 imageres.dll unfixable

Thread Tools

Similar help and support threads
Thread Forum
BSOD Error unfixable
Here is what i get everytime i try to install a game called aion, It stops on about 75-90% when it tries to update the game dump file: 052214-6630-01.dmp Crash Time: 5/22/2014 11:49:52 AM Bug Check String: PFN_LIST_CORRUPT Bug Check Code: 0x0000004e Parameter1:00000000`00000002...
BSOD Help and Support
Unfixable Unmountable Boot Volume
I've made my brother's laptop worse, and I need some guidance. He has a Dell Inspiron 1750 running Windows 7 Home Premium. I see no indication anywhere as to whether it is a 32 or 64 bit system, and he doesn't know. He asked me to look at it because it'd been extremely sluggish, and it had...
General Discussion
When I right click on the file and select properites I do not see an Icon Tab to view the icons. Is there something that has to be done to view the available icons? Thanks.
imageres.dll ?
In the System 32 folder is a imageres.dll file. If I remember correctly, and I reserve the right to be 100% wrong here, there are .bmps in the file for desktops during the boot/shutdown procedures. I also think there is/was a program that be used to open and edit these files. Does anybody know...
Hello guys. I changed my imageres.dll file, some folders are blue as i want, but some of them are still default, yellow. When i create a new folder, it should appear blue, but is yellow. How do i have to clear the thumbnail cache ? I did the disk cleanup, form System Tools. Is there anything...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App