Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Low Processor Subscore in Windows Experience Index

28 Aug 2011   #1
Munir

Windows 7 Ultimate 32bit
 
 
Low Processor Subscore in Windows Experience Index

I own Dell Vostro 1400, C2D 1.6Ghz, 4 GB DDR2 Ram (2x2GB), Windows 7 Ultimate 32 Bits.

I was very happy with the performance but suddenly it has become extremely slow to use. It becomes quite unresponsive even for simple tasks like watching youtube in browser. I check Windows Experience Index and found out that Processor and Memory subscores are very low.

It shows 2.1 for Processor and 2.8 Memory. I would appreciate if anyone can tell me the reason of this sudden change.

Thanks.


My System SpecsSystem Spec
.
28 Aug 2011   #2
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Hello Munir. Welcome to the forum.

What were the scores before?
What changes have you made to your system around the time of the perceived change in performance?

Normally you would see an issue like this if the current chipset driver was not installed on the PC yet - a new install. But you do not normally see these things change for no reason.

If you made any changes - updated a BIOS, added new hardware, or had an event - crash, hardware failure, power outage, it would make it easier to diagnose the issue.
Tell us what you know.
My System SpecsSystem Spec
28 Aug 2011   #3
Munir

Windows 7 Ultimate 32bit
 
 

Quote   Quote: Originally Posted by TVeblen View Post
Hello Munir. Welcome to the forum.

What were the scores before?
What changes have you made to your system around the time of the perceived change in performance?

Normally you would see an issue like this if the current chipset driver was not installed on the PC yet - a new install. But you do not normally see these things change for no reason.

If you made any changes - updated a BIOS, added new hardware, or had an event - crash, hardware failure, power outage, it would make it easier to diagnose the issue.
Tell us what you know.
Hi TVeblen,

Thanks for your response. I didn't make any changes in hardware. One thing I can remember is installing fresh Win 7 SP1 copy. Previously I was running Windows 7 without SP.

Drivers for Windows 7 are not available on Dell site for "Dell Vostro 1400". I remember installing Vista drivers. Do you think this could be the reason?
My System SpecsSystem Spec
.

28 Aug 2011   #4
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Yes I think so.
You need to find the most current drivers for that laptop(?). If there are no W7 drivers offered then the Vista drivers are your best option.

The Vista drivers will normally work OK in W7, but you might need to install them in "Compatibility Mode" to get them to install correctly.
Drivers - Install Vista Drivers on Windows 7

Also check to see if Windows Update is offering you and drivers that may be newer then the ones you have now.
My System SpecsSystem Spec
29 Aug 2011   #5
Munir

Windows 7 Ultimate 32bit
 
 

I think I will try to install Vista just to see if its drives issue or not.

Thanks again.
My System SpecsSystem Spec
29 Aug 2011   #6
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

Did you install the Intel chipset drivers?
My System SpecsSystem Spec
Reply

 Low Processor Subscore in Windows Experience Index




Thread Tools




Similar help and support threads
Thread Forum
Processor Windows experience-index Drops after system recovery.
Hey, I got my pc for a while now and i have played many games with it. And everything was fine. I installed the drivers and had an solid 7,9 for all the parts of the Windows index. But after i torrented a old game called Medieval Total War II so i could play with some friends online, who did the...
Performance & Maintenance
Windows Experience Index
My Index is 5.5, can I get any better? If yes, what next??? Alvin
Performance & Maintenance
Low Windows Experience Index Processor score
I have sony Vaio VPCEC290X before Windows Experience Index was 5.1 but now it reduced to 3.5 i have update to latest bios a i have check power settings cleaned laptop dust also but the score is still 3.5 what might be the problem i have contact sony care also they checked and told nothing problem...
Performance & Maintenance
Windows Experience Index and E5200 processor
I am wondering why this kind of processor gives me only 3.8 score. I've seen somewhere that this processor can do a score between 5.10 and 5.70 WITHOUT overclock. So, whats wrong with my processor? It can be because I have SpeedStep feature enabled? Source: Computer CPUs sorted by their...
Performance & Maintenance
Low Experience Index processor score...
Hi folks! I'm new to the forums and I tried searching around a bit for this with no luck. Right now I have a Phenom II X4 945 Deneb 3.0GHz 4 x 512KB L2 Cache 6MB L3 Cache Socket AM3 125W Quad-Core Processor. Win7 is giving me an Experience Index rating of 3.7. Everything else, besides my hdd...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App