Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System restore fails after Avast Antivirus messes up the system

26 Sep 2011   #1

Windows 7 Home Premium 64-bit
System restore fails after Avast Antivirus messes up the system

I ran a full scan on Avast yesterday, it found 3 infections in my windows folder, can't remember the specific paths anymore.. I think one was in Sys64 or something.
It managed to quarantine 2 of them but it couldn't find the specified file path (or something) of the infection in Sys64 (or something).
So, Avast suggests that I restart and run a scan. I click yes, computer restarts, starts running a scan before Windows starts. After an hour it is done, I log on my account...

The startup is a bit faster than usually, but I notice that the programs that should start on startup won't (MSN Messenger, Skype, etc. including Avast itself. Comodo firewall starts as it should though).

I try to open some programs, including Firefox, Avast, Messenger... nothing happens when I click the shortcuts.
I can use explorer to browse my folders, but if I try to open an application nothing happens (usually, CCleaner worked however).

I tried system restore to an earlier state, but once the restore was "done" and I logged back in, it said that system restore failed because an antivirus program was running a virus scan.

I tried to clean registry and remove some files with CCleaner, but no effect.
I also tried to system restore to a different point multiple times: same effect. Fail.

So I tried to uninstall Avast, nothing happens when I click it at the control panel "uninstall or change programs" thing.

Next I go on rampage and try to delete the folder of Avast Antivirus, it says I need admin rights for that.. I have.

... what should I do?

My System SpecsSystem Spec
26 Sep 2011   #2

Windows 7 Ultimate x64 SP1

Seems Avast definitions are flagging important system files as infected. Many are saying sfc/scannow corrects the problem.

Just check the Avast forum and you'll see how many current threads there are on it.
My System SpecsSystem Spec
26 Sep 2011   #3
Ted Myers


Might be time for a new AV App. MSE is a very good alternative.
My System SpecsSystem Spec

26 Sep 2011   #4

Windows 7 Home Premium 64-bit

Thanks a lot, Airbot! It worked!
Also, Ted: indeed. It's gonna be either AVG or MSE.
My System SpecsSystem Spec

 System restore fails after Avast Antivirus messes up the system

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 System Restore Setting resets to 100% - never used Avast
Yes, System Restore habitually changes its allotment of my C: drive to 100%. Two or three times a day I have to crunch it back down to minimum. Not only have I never used Avast on this build, I'm mildly paranoid about cloud applications; I use Steam and OneDrive, but other cloud apps are closed...
Performance & Maintenance
system restore fails saying possible corrupted restore point
twice I've run system restore, and it always says failed. System restore started,goes threw loading registry and then reboots, after desktop loads the failed dialog box comes up. I've read previous posts, and checked services running and made sure System Restore is on with available space. At one...
Backup and Restore
System Restore Fails
Hi, guys My system is Windows 7 Home Premium SP1 64-bit, newly bought on a new computer. I tried a system restore to undo an installation of an incompatible program that wouldn't uninstall – I had anticipated trouble, so I had prepared a specific restore point for that. The operation...
Backup and Restore
System Restore fails
I have tried several system restores. Each time, I get the following error (from event viewer): The restore point selected was damaged or deleted during the restore (Windows Update). I have been searching my system for sr.inf but cannot find it. Where can it be hiding? (And, yes, my folder...
Backup and Restore
System Restore fails
I can create restore points, but cannot perform system restores from them. Windows reports that the restore failed, and that no files or settings were changed. I have attempted to reinstall system restore by right clicking sr.inf in the windows/inf folder, but the sr.inf file is not there...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App