Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Triple core CPU showing ONE in task manager

31 Jul 2009   #1
nate42nd

Windows 7 Professional x64
 
 
Triple core CPU showing ONE in task manager

My AMD triple core 8400 has been struggling lately. Performance is WAY down. I just tried to play an HD video and it just maxed out and kept buffering. It's NOT heat. That's the first thing I checked. In the device manager it still shows 3 CPUs.In the task manager, it has always shown all 3 cores. Now it only shows one. Has anyone seen this? What can I do to fix it.....or is my "cheap" CPU going downhill fast? Thanks for any help.

Also, I have Vista and Windows 7 on this box and they are both showing the same thing and acting sluggish. That's would point to a hardware problem. I have never heard of this before...Is this what a CPU would do if it "broke"

This has always shown 3 cores too...now just one. It's from SIW. I think my CPU is dying...... How about you.....any fix I can do?
Triple core CPU showing ONE in task manager-cpu.png




My System SpecsSystem Spec
.
31 Jul 2009   #2
Brink

64-bit Windows 10 Pro
 
 

Hi Nate,

You might see if this is the issue with a lower amount of cores selected.

Boot Advanced Options - Number of Processors - Vista Forums

Hope this helps,
Shawn
My System SpecsSystem Spec
31 Jul 2009   #3
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Another thing you might want to try (that has worked for me) in Msconfig is try selecting Detect HAL, reboot and see if it finds them, if it does then go back and disable detect HAL and it should be fine after that.
My System SpecsSystem Spec
.

31 Jul 2009   #4
nate42nd

Windows 7 Professional x64
 
 

Thanks Brink. This was the second thing I checked after the heat issue. There is just one option now. I have always had the option to choose 1-2-3 in msconfig. Now there is just one option....1. I ran SIW to see if it still said I had 3 cores and it does not. I can't find anything searching the internet but I'm sure it's there. I hope it's not dead.....
My System SpecsSystem Spec
31 Jul 2009   #5
nate42nd

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Mr GRiM View Post
Another thing you might want to try (that has worked for me) in Msconfig is try selecting Detect HAL, reboot and see if it finds them, if it does then go back and disable detect HAL and it should be fine after that.
Thanks for the info Mr GRiM. I cannot find this in the msconfig utility. Where is it? (detect HAL)

Do you mean to "uncheck" the option to use the # of processors? I think that's what you're saying.....
My System SpecsSystem Spec
31 Jul 2009   #6
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

That is a good question, it was there in earlier builds but the option seems to have gone, it used to be here like in Vista.

My System SpecsSystem Spec
31 Jul 2009   #7
nate42nd

Windows 7 Professional x64
 
 

Okay, I see. I only have two options:

PCI lock and Debug

I'm getting scared now....glad I just built a new computer.....

Anything else? CPUZ should also be showing X3 on all these numbers too...
Triple core CPU showing ONE in task manager-boot.pngTriple core CPU showing ONE in task manager-cpuprob.png


My System SpecsSystem Spec
31 Jul 2009   #8
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Is your build info still correct, build 7229 x64, maybe try a newer build, When I had this problem I was using x86 but it's never happened when using x64, anyway I hope you find a solution.
My System SpecsSystem Spec
31 Jul 2009   #9
Brink

64-bit Windows 10 Pro
 
 

Yep. Detect Hal is gone in Windows 7 RTM builds.

Triple core CPU showing ONE in task manager-no_detect_hal.jpg


Nate,

You might also check to see if there is a newer BIOS and chipset version available that may address this issue.


My System SpecsSystem Spec
31 Jul 2009   #10
nate42nd

Windows 7 Professional x64
 
 

Well, thanks guys. I am running the official RC on this machine. I am also running Vista Ultimate. Same situation in both OSs. There is no BIOS update (and it has been fine for a year) so it sounds like my CPU is dead. I only had a 90 day warranty. I guess it's new CPU time or junk it.

If you guys think of anything, please let me know. Thanks for the suggestions.
My System SpecsSystem Spec
Reply

 Triple core CPU showing ONE in task manager




Thread Tools




Similar help and support threads
Thread Forum
Task Manager not showing applications
I have a Lenovo ThinkCentre running Window 7 Professional. If I bring up the Task Manager, no applications show in the window, no matter how many I have open. Processes, Services, etc. all look fine, just no apps. Of course this makes it impossible to kill a 'not responding' app. This is not...
General Discussion
Task manager showing 20-30% cpu usage...
Hi there, .. I dont know why my task manager is show that my cou usage is that high.. Even tough I have nothing runnung, .. I check the processes and I don't see anything running there, . and the System Idle process is in 93% (for example) while the task manager is showing CPU usage: 30%... ...
Performance & Maintenance
Core temp showing CPU at 30 - 50% but Task Manager Shows 8%
I a couple of odd behaviors from my core i5 750 on ASUS P7P55D Pro. Core 2 is often running about 10 - 20% higher than all the others according to Core Temp even at idle. According to Windows Task Manager the CPU is only running at minimal % and no programs are showing as dominate (all under 1%...
Performance & Maintenance
Task Manager is showing weird.!
so whenever i open my task manager its open in some differently.i have running eset smart 5 antivirus.i have scanned my pc but no virus found.here is snapshot
General Discussion
task manager is showing only one core vs two
I really hope someone has a good idea what is going on with my SSD partition of W7 Professional X64 using a Core2Duo processor. I think I may have confused HAL with my old HDD that I currently have in my DVD/CD bay via an Ultrabay Adapter on my laptop. I had the platter drive with W7 installed...
Hardware & Devices
Task Manager showing just 1 Processor
I have upgraded to Intel core 2 Duo processer ans my task manager is displaying only one processer. i have attached some pics for reference . if anybody can help it would be really appreciated. Thanks in advance
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App