Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Disk defragment not responding in safe mode

21 Oct 2011   #1

Disk defragment not responding in safe mode

Hello, when I try to run disk defrager in safe mode my mouse just does the quick loading animation then stops and nothing happens, the window doesn't pop up, doesn't appear in task manager or anything.
Everything else in safe mode seems to work fine except that.

Any ideas?

My System SpecsSystem Spec
21 Oct 2011   #2

64-bit Windows 10 Pro

Hello Beauski,

Are you able to run Disk Defragementer while in Windows 7?

If not, then you could use step 3 in OPTION THREE in the tutorial below to defrag the HDD in a commmand prompt at boot.

Disk Defragmenter - Open and Use

Hope this helps,
My System SpecsSystem Spec
21 Oct 2011   #3


Yes it can run in windows 7 it has completed it once before.

But recently when I tried to run it again it got upto Pass 2: 0% Defrag and will not continue at all, so a friend recommended to run it in safe mode but now it won't open.

So any ideas?
My System SpecsSystem Spec

22 Oct 2011   #4

64-bit Windows 10 Pro

It wouldn't hurt to run a dskchk to check for bad sectors.

How about trying to run defrag in a command prompt at boot instead to see if it will finish?

In addition, Auslogics Disk Defrag is good free 3rd party program alternative that runs much faster.
My System SpecsSystem Spec

 Disk defragment not responding in safe mode

Thread Tools

Similar help and support threads
Thread Forum
urgent; Can't boot in safe mode and msconfig stops responding
I opened msconfig and after clicking on the Services tab --> hide all Micorsoft services --> disable all and then clicked on 'apply' System Configuration Stopped responding . I did so manually. I tried again this time instead of selecting 'Disable all'' I just disabled one of them (Adobe update...
General Discussion
My laptop Asus Eee PC is not responding to clics even in Safe Mode
Hi, My Asus Eee PC laptop stopped working; the cursor arrow is still visible and movable, but nothing is clickable, ctrl-alt-delete appears but nothing can be clicked. I have removed battery and tried the safe mode but noting changes. I suspect it is a virus but I am unable start a...
Performance & Maintenance
Nothing responding unless in safe mode
Hello all, I've ran into an issue that I've never had before and I was wondering if anyone has any advice or experience dealing with a similar issue. Here goes: I was quietly reading an espn article while chatting on gmail when suddenly my computer froze. It wasn't one of those freezes where...
BSOD Help and Support
Windows 7 Home Premium - not responding -can't get into safe mode etc
Hi, I'm having many problems on my HP p6-2100 desktop running Windows 7 Home Premium now, the programs like Internet Explorer 9.0.8112.16421, Excel, is more and more often become not responding, tried System Restore but failed, showing "The restore point was damaged or was deleted during the...
General Discussion
Windows 7 not responding, works in safe mode
Yesterday I was playing a game on my HP Laptop when the computer froze. I couldn't move the mouse, open task manager, ctl+alt+delete, nothing. I had to hold the power button down for 10 seconds and do a hard reset. I let it sit for a few minutes and then booted it back up. Ever since, my...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App