Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Memory usage maxes out 100% during file transfer, computer freezes

02 Nov 2011   #11

Windows 7 Professional 64bit

Great. Thanks cluberti. I emailed you the info.

Looking forward to hearing from you.

My System SpecsSystem Spec
02 Nov 2011   #12

Windows 10 Pro x64

You have a few issues here I see already, some major:
  1. You aren't using Win7 SP1 on a lot of binaries (like usbport.sys, videoprt.sys, etc, which should have been updated - yours in this trace appear to be 6.0.7600.16385, rather than 6.0.7601.17514!!!), which could very easily mean you have a botched SP1 install.
  2. You have the old Intel Matrix drivers installed, rather than the new Intel RST drivers for your controller - given the DPC behavior with iastor and usbport, this is an issue.
  3. You're hitting a usbport bug that is fixed (only) in Windows 7 SP1, and you're not running SP1 binaries for a lot of things (going back to #1), so this might be a problem simply with a botched SP1 install over an RTM box.
  4. You need to update to later Intel storage drivers (you have the old Matrix package installed, and not the newer RST package with proper support for AF drives): ng

I really need you to test on a working Win7 SP1 install (and subsequent security updates, of course, if missing) with the right Intel storage drivers loaded. Hopefully after doing the above, so you're actually using the OS version *and Intel driver package* that is designed to work properly with Advanced Format drives, will resolve the issues.
My System SpecsSystem Spec
03 Nov 2011   #13

Windows 7 Professional 64bit

cluberti, thanks for the feedback. The link you posted took me to Intel Rapid Storage Technology F6 Driver Diskettes. I downloaded them, but in looking at the readme, it appears that these need to be installed when first installing the OS.

Is there a way I can update all that needs to be updated without reinstalling Windows?

I looked at Windows Update, which says that my system is up to date, except for some C++ and MS Office updates needed.

But maybe Windows thinks I've got SP1 installed, even if it's botched.

Is there a way to uninstall SP1 and reinstall?

Sorry for all the questions, but I'm not quite sure what to do.

Thanks again.
My System SpecsSystem Spec

03 Nov 2011   #14

Windows 10 Pro x64

If you haven't run disk cleanup or the dism command line to clean up your SP1 installation, then yes, you can use Add/Remove programs to remove Windows 7 SP1, and then try a reinstall. Otherwise, if that doesn't work (or you did indeed cleanup your disk and remove the SP1 uninstall information), then you'll be left with only the option to reinstall to fix (and you should use SP1 integrated media to do so).

For the Intel driver, there should be an "All OS" package here:
My System SpecsSystem Spec
04 Nov 2011   #15

Windows 7 Professional 64bit

Hi cluberti,

OK, here's what I did. I uninstalled SP1 by doing this:
  1. Click the Start button, click Control Panel, click Programs, and then click Programs and Features.
  2. Click View installed updates.
  3. Click Service Pack for Microsoft Windows (KB 976932), and then click Uninstall.

Next, I launched Windows Update. It gave me a list of 6 important updates to install, one of which was the SP1 update. I check marked them all and clicked Update All.

At the end of the update, I received this message:

Succeeded: 5 updates
Failed: 1 update
Error(s) found: Code 80070005 Windows Update encountered an unknown error.

The update that didn't install was SP1. After googling the error, I did this:

Click Start, All Programs, Right click on Windows Update, Run as Administrator, Click Yes/Confirm

The SP1 downloaded, but then I had another error: 0x80240016

I googled that error and got the following cause and did the following steps:

Cause: This issue occurs if a Windows Update client or a Microsoft Update client cannot access the user token.

Follow these steps:
  1. Close any Windows Update or Microsoft Update browser windows.
  2. Click Start, type Command Prompt, in the list of results, right-click Command
    Prompt, and then click Run as Administrator.
    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  3. Type the following commands. Press ENTER after each command:
    net stop wuauserv
    net start wuauserv
  4. Close the Command prompt window.
  5. Try to install updates again.

Next, I ran Windows update again as an Administrator. This time, I got the message that SP1 had successfully installed.

Next I installed the Intel drive (RAID: Intel® Rapid Storage Technology Driver for Intel Desktop Boards) that you gave me at this link:

The installation completed successfully.

Finally, I ran the xperf trace again that you outlined in post #7. Unfortunatley, the problem hasn't been resolved. I'm still getting the same result -> I transferred a 2GB file to the 3TB drive and the memory usage jumped up to 3.8 and in resmon, the orange "Modified" memory filled to 2230MB and has not come down.

Cluberti, I updloaded the new file that the trace produced. I named it filecopy-2.rar. It's at the same link that I emailed you previously (www...../cluberti/ filecopy-2.rar) if it would be helpful to you to examine it, I would be greatly appreciative.

I'm still hoping to resolve this. Thanks for so much for all your help.
My System SpecsSystem Spec
04 Nov 2011   #16

Windows 10 Pro x64

You'll need to fix that link, but good work so far :).
My System SpecsSystem Spec
04 Nov 2011   #17

Windows 7 Professional 64bit

Hi cluberti,

I sent you the link to the latest xperf trace results file to cluberti [at] cluberti [dot] com.

Thank you!
My System SpecsSystem Spec
11 Nov 2011   #18

Windows 7 Professional 64bit

Any further input on this mystery?
My System SpecsSystem Spec
11 Nov 2011   #19

Windows 10 Pro (x64)

Do you have a pagefile?
My System SpecsSystem Spec
11 Nov 2011   #20

Windows 10 Pro x64

Sorry, no. Traveling all week.
My System SpecsSystem Spec

 Memory usage maxes out 100% during file transfer, computer freezes

Thread Tools

Similar help and support threads
Thread Forum
90% memory usage at idle - computer freezes
I have an EEEPC netbook model 1025c which has 1Gb memory and came installed with Windows 7 starter. From the start it ran poorly until I disabled Aero and basic themes - it is now on "classic" I believe and looks ugly but is now actually functional! One remaining problem is that it consumes 90%...
Performance & Maintenance
Netflix CPU usage maxes out and causes video to lag
I've been having some serious problems playing netflix on my computer using any browser (Firefox, IE9, or Chrome). At first the video will play fine and my cpu usage remains below 20%. Then within about 1 or 2 minutes my cpu usage will jump up around 70% to 100%. The task manager shows the...
Music, Pictures & Video
Strange RAM usage on File transfer.
My "Windows 7 Ultimate x64" is acting strange. My normal RAM usage is ~3.12GB When I connect my "Nexus 7 3G 32GB" tablet to my pc, the RAM stays the same, but when I start to copy files from/to it, my RAM usage jumps to ~96%, about ~8GB. And when it's done copying the files, the RAM usage doesn't...
General Discussion
Windows 7 64bit, Memory usage rises/computer freezes over time.
I've noticed over maybe the last few computer would randomly freeze/slow down, yet cpu usage and memory in use is low. It says all of it is cached right now..i don't know if that's normal for Windows 7 or what. It's not freezing right now but it eventually will, yesterday i got the low...
Performance & Maintenance
Maximum memory usage freezes my PC - Why ?
My memory usage is up to 95+% when I am running a backing on another PC (using that PC). My main PC is almost useless as it is using 95% or so memory...BUT...this/my PC is NOT doing the backup...only connection is that it is on my 5 PC home network using the same external USB backup drive that does...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App