Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Choose default program button (in Right-Click) not working!?

25 Mar 2012   #1

Windows 8 Pro with WMC 64-bit
Choose default program button (in Right-Click) not working!?

Hey Guys!
When I right click, open with, choose default program button, it gives me an error says: "This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel."
I fixed Windows 7 fix association files, but error still there!

Only Open with and Choose default program button NOT WORKING, but everything like .txt, .exe, .mp3, etc is WORKING, just the BUTTON NOT WORKING!

I run a Registry Cleaner before this error, and I don't have BACKUPS!


My System SpecsSystem Spec
25 Mar 2012   #2

Windows 8.1 Pro x64


Would it be possible to provide some step-by-step screen shots so we can see visually what you are doing and also see the error message on screen?

My System SpecsSystem Spec
26 Mar 2012   #3

Windows 8 Pro with WMC 64-bit

My problem is the same problem for this person: Choose Default Program does not work (is broken) on Windows - Super User

ِAnyway I uploaded my problem


Attached Thumbnails
Choose default program button (in Right-Click) not working!?-sevenforums.jpg   Choose default program button (in Right-Click) not working!?-sevenforums2.jpg  
My System SpecsSystem Spec

26 Mar 2012   #4

Windows 8 Pro with WMC 64-bit

Any HELP!!!!!?!?!
My System SpecsSystem Spec
26 Mar 2012   #5

Windows 8.1 Pro x64

Having seen the error message I'm not sure, this isn't something i have seen before sorry.

Maybe someone else around here has seen this error before?
My System SpecsSystem Spec
27 Mar 2012   #6

Windows 8 Pro

See if running SFC /SCANNOW Command - System File Checker solves the problem.

Also DO NOT use registry cleaners as windows 7 is good at taking care of registry needs itself.These so called registry cleaners do more harm than good as seen from your case.
My System SpecsSystem Spec
29 Mar 2012   #7

Windows 8 Pro with WMC 64-bit
Problem solved!

Hey all! :) :) :)
SFC \SCANNOW command didn't solve... BUT it solved by a member from Vista Forums name yankz23
Thread link: Solved Open with...choose default program error on Vista. - Page 2 - Vista Forums

As he said that some registry entries are deleted

That what he said in Vista Forums:
First I stumbled upon this article on Microsoft's website by changing my google search to fix the problem. I started searching google with the following:

"open with" context menu missing

That brought up the results with the first being a microsoft link:

"Open With" Command Missing from the Context Menu

Now the article didnt tell me exactly how to fix it but it gave me an idea.
It said to examine the following reg key:


And it said to look at the following default value:

C:\%windir%\rundll32.exe shell32.dll,OpenAs_RunDLL %1

After looking at this I noticed the value was different but then I noticed the article said this applies to Windows 95 and 98.
I then looked at the same key on my laptop which is also running Vista Ultimate 32bit and I noticed there were subfolders on my laptop that my desktop did not have.
It should look like the following:


My desktop only had the DefaultIcon folder.
Well I just copied the key from my laptop and worked.
I exported the registry keys that are missing, I don't know if uploading it legal or not, I will ask Brink (Shawn)

By the way, Brink helped yankz23 in that thread in Vista Forums!

This is Brink's profile in Seven Forums: Windows 7 Forums - View Profile: Brink
And this is his profile in Vista Forums: Vista Forums


My System SpecsSystem Spec

 Choose default program button (in Right-Click) not working!?

Thread Tools

Similar help and support threads
Thread Forum
Open With - Choose Default Program Error
I am using Windows 7 Ultimate and when I try to open files using Right Click > Open With and I select Choose Default Program I keep getting an error message like the one below, I copied the picture link from another thread when searching for an answer so disregard the C:\Program Data etc in the...
General Discussion
Help, left click button isn't working
Hi there, I just got a new gaming mouse, an Anker 4000 DPI one from Amazon and i've been having this problem for the week i've had this and it's that the left mouse button doesn't like to work. I've tried doing most things like checking if Click Lock has been turned on, re-installing drivers and...
Hardware & Devices
Choose default program button (in Right-Click) not working
I get the same error, when I right click on a file and hover the mouse on Open With option, then in the Open With context Menu, I want to choose default program for that file, it shows me an error saying: This file does not have a program associated with it for performing this action, please...
General Discussion
Ordering the elements when Right-Click on the Desktop and choose New
Hi All, I have been investigating how to order the elements shown in the "New" Menu after right-clicking in the desktop... have found barely nothing about this... I would like to give it try here about this. Problem comes from Win95 to the present days of Win7... How to order the elements in...
How do i choose default app for scanner
Oh come on, what's up with this? will i have to go digging in the registry? I'd llike the standard windows fax and scan program when i click the hardware button on my scanner not photoshop, that feels like overkill for regular documents.
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:37.
Twitter Facebook Google+