Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Explorer.exe showing 50% CPU usage

15 Aug 2012   #1
sourav24

Windows 7 Ultimate 32 bit
 
 
Explorer.exe showing 50% CPU usage

Explorer.exe is showing 50% cpu usage in task manager and machine is getting slowed up..Can any1 plz help..


My System SpecsSystem Spec
.
15 Aug 2012   #2
OldMX

Microsoft Windows 10 Professional / Windows 7 Professional
 
 

Process Explorer

Post a screenshot of that utility, se we can see whats going on...
My System SpecsSystem Spec
16 Aug 2012   #3
sourav24

Windows 7 Ultimate 32 bit
 
 

Explorer.exe showing 50% CPU usage-untitled.png

These are the processes..


My System SpecsSystem Spec
.

Reply

 Explorer.exe showing 50% CPU usage




Thread Tools




Similar help and support threads
Thread Forum
HDD showing 112 GB incorrect disk space usage
Hi! My system specs: Windows 7 Home Premium 64-bit SP1 Intel Core i5-3317U CPU @ 1.70 Ghz, 8,0GB RAM Intel HD Graphics 400 My Computer Management shows 112 GB of used space more than I have for my C: drive. It shows 233 GB (capacity), 208 (used space) and 24,7 (free space).
Hardware & Devices
Task manager showing 20-30% cpu usage...
Hi there, .. I dont know why my task manager is show that my cou usage is that high.. Even tough I have nothing runnung, .. I check the processes and I don't see anything running there, . and the System Idle process is in 93% (for example) while the task manager is showing CPU usage: 30%... ...
Performance & Maintenance
Physical Memory/CPU Usage showing high
I am using Windows 7, with 4GB ram. My physical memory usage goes high upto 3.5Gig even when i use very less applications. I have monitored using both Performance Monitor (Perfmon.exe) and Process Explorer. All applications shows the same including my Task Manager/Wdws Gadgets. My system is...
Performance & Maintenance
Explorer is showing incorrect disk usage
Hi Everyone, I am using Windows 7 (x64) and I am getting incorrect disk usage reporting through Explorer. I am looking at a 1TB disk, which with partitioning considered is showing as a 931GB disk - however even though I am using only 421GB of the disk space Windows 7 (Explorer) is showing ...
General Discussion
Shockwave plug-in showing 92% CPU Usage in all browsers
Can't figure out what to do in all browsers this plug-in is running at extremely high percentages and slowing down my whole computer. Videos are all playing very slow and choppy as well. What the heck is going on?
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App