Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: keep failing to solve 'insufficient resources' problem in windows 7

25 Oct 2012   #1

Ubuntu, Windoze8pro64
keep failing to solve 'insufficient resources' problem in windows 7

This problem is getting pretty old, and I've gone through a lot of searches and potential solutions already. Please read 'solutions tried' before answering...

Details about my systems.

1) The older computer: Samsung HDD, 6GB RAM, Core 2 Duo, running on Asus P5K mainboard. Four times as much software installed as on the new one,. Easily reaches one or two months of uptime without rebooting windows. Never runs out of resources.

2) The new computer: OCZ Vertex 4, i7-3770 CPU, GTX 670, 8GB CL8 RAM, Asus P8Z77i-Deluxe (not overclocked). This system has only a small subset of the software installed that resides on the old system.

Windows 7 Professional 64bit SP1 with updates and drivers current on both machines.

The Problem: After running the new machine for 30 minutes to an hour, it will fail even small tasks like copying a file with an "Error 1450: insufficient resources exist to complete..."

Causes pretty much ruled out so far:
- Installed Software other than drivers, since none of my software produces any such problem on my old machine
- Registry size - this Registry is half the size of the one on the old computer
- Virus - Kaspersky has a pretty good reputation and should find pretty much everything when run from outside windows. Windows Security Essentials, Windows Defender and Sphinx Software firewall are always active.
- Available hard drive space - 256GB windows drive is less than half full.
- RAM, Swapfile and CPU utilization: all 3 show well below 50% usage at any given time.
- Temperatures - the system runs perfectly cool, using Asus Fan Control, everything stays around 85-95F.

Solutions tried:
- 3 different Microsoft KB's regarding max handles (set to max)
- 1 Microsoft KB regarding max registry size (set to max)
- Tracking Handles with ProcessExplorer.exe
- Trackign Handles with handles.exe
- scouring system logs for errors (found nothing that gave me any clue)
- Uninstalling or disabling autorun for all non-essential software.
- Uninstalling nonessential mainboard drivers, Asus Utilities etc
- Tried different Nvidia drivers
- used Registry cleaner
- used System File Checker (SFC /scannow)
- ran Windows Security Essentials full system scan
- used Kaspersky Antivirus from its own boot disk with newest definitions
- Sysinternals Rootkit Revealer (I'm not really pro at evaluating the results on that)
- CC Cleaner
- Malwarebytes
- tested RAM with memtest
- manually underclocked RAM
- asked all my programmer friends...

They just told me the same Microsoft KB's that I had already found when googling my error.

Possibly interesting fact:
Using ProcessExplorer.exe or Handles.exe, once the problem becomes acute, will both fail with the message "Insufficient system resources to get handle information."

So, the very trouble shooting tools I try to use quit working.

I just tested it again: Since cold boot on this sytem, I have run nothing except internet explorer, opened this forum and have been typing this for ~15 minutes. I have 6 tabs open from my search. That's all! Still, as soon as I start up Process Explorer, it pops the error message. If I start it as the first thing, it will track handles ok until the system runs out of resources. But I don't really know what I'm looking for, I don't see any one process have way more handles than any of the other processes. Nothing looks conspicuously out of order.

If I ignore the fact that some programs start refusing to run (can't load DirectX after it runs out of resources, can't copy etc) and keep running the browser, maybe use word and excel (which oddly always start fine), it'll continue chugging along for some time still. It does not BSOD, it'll just hard freeze, so I have to hit reset.

Any of my 'bigger' Software including games will run fine, as long as I start it right after a reboot - even for hours on end. But once I close and try to start it again, no cigar, until reboot.

. .
Could this be a hardware problem of some sort? Or could one of Asus' or Intel's drivers be bad and leak resources like no tomorrow? Is there a better way for me to trouble shoot?

Any advice would be much appreciated, hope this is the right section of the forum...

My System SpecsSystem Spec
25 Oct 2012   #2

Windows 7 Ultimate 64 bit

Sounds like to me it's a corrupted file or registry. How long has the new system been up and running? If it were me, since you've done some extensive trouble shooting all ready, I would just re-do a clean install of the OS.
My System SpecsSystem Spec
25 Oct 2012   #3

Ubuntu, Windoze8pro64

It did it from when it was a brand new install..

Now its a month old, still the same... doing my hardest to avoid having to do a new install... that robs me of a week of my time to get everything back in place... I need to work

What good is an OS that can't be repaired but only be trashed.
SFC should have found any corrupt files.
I guess the registry is so hard to fix, programs like registry cleaner and its ilk can't be relied upon?

looking at the resource manager, I'm finding that my SSD is being continuously thrashed by writing wfpdiag.etl at 10kb/s...

Since 10 minutes, even more ceaseless thrashing is going on with MSStmp.log (250kb/s to 1000+kb/s and Windows.edb (~250kb/s) even while I'm just here writing this, and nothing much should be happening on the system.
My System SpecsSystem Spec

25 Oct 2012   #4
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

The most likely cause is a bad install of Windows. I ran into that back when adding a WD Green Power model 500gb drive in for the extra drive for RC testing on 7. Nothing would run right on that install where I finally decided to leave that one in for storage only until building the present case.

Any and all Windows installs whether XP,, Vista, or 7 beta to RC back then would run normally on the WD Caviar SE 500gb drives while that one particular drive removed from an external enclosure was problematic from the start. Since you are running an SSD the board's bios setting as far as the drive mode could also be other thing to be looking at. AHCI or ide?
My System SpecsSystem Spec
26 Oct 2012   #5

Ubuntu, Windoze8pro64

Thanks for the info... Your question reminds me of a couple of things that might be relevant to the issue:

The BIOS is set to AHCI, the SSD is hooked up to the first SATA-3 port on the mainboard. The drive has been NTFS formatted with a single partition prior to installing windows.

The UEFI BIOS is set to legacy mode, due to the fact that I had to manually select the drive to boot in UEFI mode every time, while it boots without intervention in legacy mode.

The computer has also been unable to hibernate or enter sleep mode from the day of installation.

Just remembered that I also have an unknown device in device manager, listed with hardware ID ACPI\INT\33A0. Windows can't find a driver for it and neither can Google, it seems. Some posts seem to think its a virtual Intel driver of some sort...
My System SpecsSystem Spec
26 Oct 2012   #6
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

You may be right about the need for an Intel driver. That seems to surround an Intel Z77 chipset if the search on that is correct. The search results ended up on a vendor's product/information page for an Asrock board which could be part of the problem while it is usually the drive mode or need for Sata/Raid type controller drivers that can stall the works.

When first getting into this build the board came set default for AHCI and Windows ran like crap at first until switching modes to the Native ide option and suddenly all ran well. Recently during the summer when looking into the AHCI guide here and switching the modes all drivers were already on and all went smooth as silk with both OS drive mounted as SCSI devices.

It sounds like the soluttion for you may be similar in fashion where you run things in one mode until everything is on and then switch over to see a normal running OS. That would be switching to ide and watching to see if performance suddenly presents itself and then going to the Intel support site to look things up there as well as at Asus.
My System SpecsSystem Spec
27 Oct 2012   #7

Ubuntu, Windoze8pro64

Ok, I changed the SATA settings in the BIOS from AHCI to IDE mode.

Rebooted, got BSOD right after the boot menu (couldn't read, cause the system immediately rebooted).
After trying it several times without change, I went back into the BIOS and set SATA back to AHCI mode.

System booted up again, I went to Device Manager to follow a suggestion I found to look for "PCI VEN & DEV numbers" for the Unknown Device, only to find that now, there was no unknown device anymore!

Still, the problem remains...

PS: I wrote this up twice, cause when the forum's token expires, it fails to post, and after clicking "back" as advised in the error message, you find that the forum has discarded all your text in the process.
My System SpecsSystem Spec
27 Oct 2012   #8

Microsoft Windows 10 Professional / Windows 7 Professional

You screwed your system with those registry cleaners, get a fresh install to sort those problems, if possible run a couple of memtest loops to discard memory errors, and load bios defaults.
My System SpecsSystem Spec
27 Oct 2012   #9

Ubuntu, Windoze8pro64

I did run memtest, because some people suggested this issue could have to do with RAM problems. However, it came up with no problems. I've also tried under clocking the RAM, with no apparent change.

Further, this issue was certainly not caused by a registry cleaner.

I used a registry cleaner only after about every other strategy of fixing this failed. After its use, the issue didn't go away, but it didn't get any worse either.

This mainboard also came with VIRTU drivers/software. I removed that early on and didn't put it back, even though that removal didn't alleviate the problem either.
My System SpecsSystem Spec
27 Oct 2012   #10
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Upon looking up the error message you are seeing I ran across one thread you may be interested in loooking over at the MS TechNet site. This is regards to the same error seen when someone was trying to install the Enterprise edition where the advice was to set a registry value to unlimited. Windows Modules Installer - Error 1450 Insufficient System Resources

The error message itself can also be seen with several other versions like XP or Exchange Server 2007 as another example and not pointing directly at anything wrong with the new build so far. "Insufficient system resources exist to complete the requested service" error message when you try to extend database files in an Exchange Server 2007 environment
My System SpecsSystem Spec

 keep failing to solve 'insufficient resources' problem in windows 7

Thread Tools

Similar help and support threads
Thread Forum
Memory Leak: Insufficient System Resources
My practice is to turn off the machine at bedtime and reboot it every morning, so that it gets a fresh start every day. I upgraded to Windows-7 from -XP about a month ago, applied all available updates and thought it the right move until recently. Now after the machine runs several hours, when I...
Performance & Maintenance
0x800705AA Insufficient System Resources
Need a little help. I have three W7 Home Premium Systems running on a gigabit network. When I copy a huge Acronis backup files (20+GB) from system B (using Windows Explorer on System B) to system A it runs at 40+ MB/Sec and quickly fails with the 0x800705AA error code. When I copy the same file...
Network & Sharing
Halo 2 Insufficient Resources
I FINALLY got Halo 2 to do something by running it in compatibility mode for Windows XP. But now it says I have insufficient resources. Now I know I have sufficient resources because I can run Metro 2033 with DX10 on high. The problem is that my switchable graphics don't actually switch to the...
XP Mode insufficient resources
HP ProBook 4510s Windows 7 Pro 32 Intel Core Duo T6570 2.1GHz 4G RAM Memory allocated to XP Mode is 2048M I followed the instructions on this site to install and set-up XP Mode. The first time I launch the XP mode after a reboot, it will work correctly. From that point forward, the...
Insufficient System Resources Error Message
I have three systems on a gigabit network all running Windows 7 Home Premium 64-bit. All three were upgraded from Vista Home Premium within a few weeks of each other. Two of the systems will not move/copy a 20 GB file over the home network. They give me the 0x800705AA error "Insufficient System...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:26.
Twitter Facebook Google+