Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: sfc /scannow stops at 69% ...could not perform the requested operation

20 Nov 2012   #1
Kratos Aurion

Windows 7 Home Premium x64
sfc /scannow stops at 69% ...could not perform the requested operation

Again, sorry if I posted this on the wrong section...

Anyway, in the beggining of the year I got the infamous malware that infected many PC's worldwide (can't remember the name) and got my action center completely destroyed. I eventually fixed it, by adding the Security Center service that was gone, but one issue still remains: the action center system tray icon is greyed out, and impossible to turn back on!

I searched online, and the most common solution i've found was to run the sfc /scannow command. So I did, and for some reason it stops at 69% and after about a minute stuck at that number it says: "Windows Resource Protection could not perform the requested operation" I tried multiple times, but the same error happens every time. So I searched for this error, and not a single solution i've found worked (and i've only found like 2 solutions).

How can I fix this error, without re-installing the OS? Or is this only solved that way?

Thank you for your time.

My System SpecsSystem Spec
20 Nov 2012   #2

64-bit Windows 10 Pro

Hello Kratos,

Since malware/virus was involved, you might consider doing a clean reinstall of Windows 7 to help make sure you are fully clean. You just never know what may still be lingering around.

Usually when you get the Windows Resource Protection Could Not Start the Repair Service error, check to make sure that the Windows Modules Installer service is enabled and set to Manual.
Services - Start or Disable

You might see if using the tutorial below may be able to help enable the Action Center system icon.
System Icons - Enable or Disable
Hope this helps for now, :)
My System SpecsSystem Spec
21 Nov 2012   #3
Kratos Aurion

Windows 7 Home Premium x64

Thank you for the reply, and sorry for putting this on the wrong section...

Well yeah I know a clean reinstall will solve everything, but I really wanted to avoid that and explore other possibilities :S

Yes, the Windows Modules Installer is enabled and manual. I tried the option two in that tutorial a long time ago, but didn't solve my problem...

I guess the only solution then is a clean reinstall...damn. Thank you for the help anyway :)
My System SpecsSystem Spec

21 Nov 2012   #4

Microsoft Community Contributor Award Recipient


I agree with a clean install. Especially after a malware problem. But one other thing that can contribute to sfc stalling is hardware. It's possible that a memory module isn't seated correctly or that it failed. (Happened to me on a Sony Vaio. One of my memory sticks went bad. SFC kept stalling at 52%.) Also a possibility that the hard drive is going bad. Just a thought.
My System SpecsSystem Spec

 sfc /scannow stops at 69% ...could not perform the requested operation

Thread Tools

Similar help and support threads
Thread Forum
Windows Resource Protection could not perform the requested operation.
I get this error when I run sfc /scannow and I tried safe mode, kb947821 Surt and other solutions, none worked. Also I removed and reinstalled .NET 4 all versions. No good. I saw that I'm missing PendingDeletes in C:\Windows\winsxs\Temp i would appreciate it if someone could upload his folder...
Performance & Maintenance
you do not have sufficient rights to perform this operation
I can't format my local drive
Hardware & Devices
Windows Resource Protection could not perform the requested operation
I also have some similar problem. My windows Help center has gone bad with multiple _elbasuer_ instances. But there is no BCRM_Bluetooth_Help strng in the registry. So an sfc scan could help, was my thought. But sfc /scannow stops at 9% with a message "Windows Resource Protection could not perform...
Performance & Maintenance
SFC "Could not perform the requested operation"
Hello everyone, In my computer, I try to run SFC /scannow /offbootdir=C:\ /offwindir=C:\Windows from the recovery console. However, after "Beginning system scan. This process will take some time.", it almost immediately returns "Windows Resource Protection could not perform the...
Performance & Maintenance
Could not perform this operation because
I just purchased and installed Windows 7 Home Premium on my Toshiba 64 bit computor. It had Vista on it and did not like it from the get go but Circuit City installed it. The problem I am having is when I click on the mail icon on the toolbar I get the following message: could not perform this...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:48.
Twitter Facebook Google+