Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PC very slow after installing windows 7?

25 Nov 2012   #11
TheCyberMan

Windows 7 Ultimate x64
 
 

Quote:
my antivirus and another one (a driver checking software)
Using driver checking programs are usually more trouble than they are worth you should always use the computer or vendor manufacturer's websites for downloading and installing your hardware drivers.

You should gather the drivers needed before installation of new operating system so you are ready to install the all the hardware drivers even before installation of anti-virus and any firewall software and connecting to the internet.


My System SpecsSystem Spec
.
25 Nov 2012   #12
indianacarnie

Windows 10x64 Build 1709
 
 

And at some point it would be nice if you added your system spec.'s. System Info - See Your System Specs
Hard to give pertinent advice playing in the dark.
My System SpecsSystem Spec
25 Nov 2012   #13
gregrocker

 

Make sure your install came close to following the Best Practices for Win7 install as written in Clean Reinstall - Factory OEM Windows 7.

These include using the drivers provided by the installer, then quickly updated by optional Windows Updates, waiting until all Updates are finished before importing any drivers missing in Device manager from the Downloads webpage for the PC or device. This is not XP and drivers are handled differently in Win7 which is the first driver-complete OS.

If you're still experiencing slowness or hangs make sure you have the minimum hardware requirements met, then work through these Troubleshooting Steps for Windows 7
My System SpecsSystem Spec
.

26 Nov 2012   #14
emiliobob15

Windows 7
 
 

I installed the driver checking software so i can check which drivers i am missing.
I installed the nvidia and foxconn drivers from the website. There are still updates to be done. I'll do all these things and tell you if it improves.
My System SpecsSystem Spec
26 Nov 2012   #15
gregrocker

 

Check drivers in Device Manager, not using a driver-finder program.
My System SpecsSystem Spec
30 Nov 2012   #16
whyareallthe

windows 7 32 bit
 
 

3GB thats unsual number for installed Ram. You have not said what version im assuming 32 Bit otherwise you would mention it.

The official figure from MS is GB Minimum but there figures are always on the tad conservative, its best to run it on the maximum it will utilize (32 Bit) so you probably have two slots replace the GB stick with a 2 GB its best to take the battery out first if its a Laptop. Before that try a def rag with defraggler including the option for def-ragging the page (swap) . Check all the drivers are there, and there are no conflicts in device manager.

It may be the graphics which are causing the overhead try switching the desktop to "classic view" it then looks much like a /windows XP desktop

Last but not least go Run/msconfig check all the non ms services and programs that are starting with windows disable any Google services.

If you go into "processes" in task manager you can see if there are any particular programs or services that are hogging your resources.

Iv'e installed 7 3 times now and it can be a bit unstable to begin with but for some reason settles down once its been configured correctly. any major changes be sure to restart rather than go in "sleep Mode" if the Defrag takes a long time leave it when you go out and set it to shut down when finished . You will need to temporarily change your power scheme to always on (except for the monitor display) Dont forget to put it back again.
My System SpecsSystem Spec
01 Dec 2012   #17
emiliobob15

Windows 7
 
 

I have 6 gb of ram and it is a 64-bit windows 7. I unchecked everything apart from my nod32 from the startup programs. I defragged disc C. I installed all the windows updates and drivers. My pc is still slow as hell. I am really desperate, don't know what more to do. I'll try to switch to classical view as you said.
My pc never gave problem with my old 32bit win xp. It was really fast. I hope it is the hardware so I can change something.
My System SpecsSystem Spec
01 Dec 2012   #18
gregrocker

 

Have you done the hardware tests in Troubleshooting Steps for Windows 7?

If you'd report back results of the steps then we may have other ideas.
My System SpecsSystem Spec
01 Dec 2012   #19
TheCyberMan

Windows 7 Ultimate x64
 
 

As gregrocker has said have you done all the steps including installing all hardware drivers but not using the driver checker software but from the computer and vendor websites.

Please update us so we can help you further.
My System SpecsSystem Spec
Reply

 PC very slow after installing windows 7?




Thread Tools




Similar help and support threads
Thread Forum
Computer slow 100% CPU usage after installing Windows 7 please help
Hi my problem in a nutshell is as follows My computer was running slow for ages it is a very old computer so I assumed it needed a fresh install of Windows 7 to de- clutter things upon completion I could tell immediately that things had not improved if anything they had gotten worse. Internet...
Performance & Maintenance
Windows 7 Slow after installing Adobe reader
Hi I have just done a fresh installation of Windows 7. As soon as I installed Adobe Reader it has slowed my laptop down alot Take around 15 seconds to load up a page at time and generally opening apps has slowed down I have even uninstalled it but still Windows 7 is running slow
General Discussion
trouble installing windows 7, extremly slow
Hi, i've just built a second computer from an old computer and some parts. It's been a few years since i last built a computer but i'm fairly certain they are compatable. I tried to install windows 7 on it 2 days ago and i've still not managed to complete an install. The first attempt took 8...
Installation & Setup
Windows slow down after installing AV !
my windows slow down after installing kaspersky or norton ?i have 2.4 dual core and 3 gb of ram !!
System Security
Slow Internet connectivity after installing Windows 7
hi there , I had windows Xp 32bit OS and now recently I installed Windows 7 Ulitmate 64 bit OS I have a configured PC . Have pasted the MSinfo32 OS Name Microsoft Windows 7 Ultimate Version 6.1.7600 Build 7600 Other OS Description Not Available OS Manufacturer Microsoft Corporation...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App