Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't get scf /scannow to work

17 Dec 2012   #1

Win7 64
Can't get scf /scannow to work

My PC has been getting very slow lately. Have tried all the usual fixes but effect only marginal. Came across scf /scannow thinking that I may have a corrupted system file. Followed instructions to the letter but cannot get scannow to even start. Making sure I am the administrator I key in sfc /scannow from the Start command box and just for a split second the normal black command box comes up on screen and then disappears again. Any ideas? I've looked everywhere online and tried every tip but to no avail. Virus checks all ok.

Am using a Dell Inspiron Win 7 x 64 Running Microsoft Essentials as security.

Thanks folks in anticipation

My System SpecsSystem Spec
17 Dec 2012   #2

Microsoft Community Contributor Award Recipient


Hello plav and welcome to Seven Forums.

I think the problem is you're not using an elevated command prompt.

In the Start Menu search box area type cmd, then right click on cmd.exe (at top), and click on Run as administrator. This should open up a black screen with white letters and you should see this:


The cursor will be flashing so just type in sfc / scannow and click Enter. (Note the space between sfc and /scannow.) The scan could take quite a while. See this tutorial starting at Step 6.

Elevated Command Prompt
My System SpecsSystem Spec
17 Dec 2012   #3

Win7 64

Muchas gracias! Didn't find anything wrong but worked fine.

Adios! (I'm English but I guess you Texans know a bit of Spanish!)
My System SpecsSystem Spec

17 Dec 2012   #4

Microsoft Community Contributor Award Recipient


Si! I do know a bit of Spanish. I can order almost anything on the menu at a Mexican restaurant.

Glad to hear you got the SFC to work and there were no problems. Thanks for posting back!
My System SpecsSystem Spec

 Can't get scf /scannow to work

Thread Tools

Similar help and support threads
Thread Forum
Can't get sfc /scannow to work
hi, when using elevated command prompt within windows, i get the message "windows resource protection could not perform the requested operation" when opening the command prompt from windows7 boot cd, i get the message "there is a system repair pending which requires reboot to complete" ...
Performance & Maintenance
Can't run Sfc /scannow
Strangest thing. On my windows 7 Pro (32-bit) desktop I am getting a c0000001 error at boot with no indication of which file is causing the problem. I boot to the OS disc and try to run Sfc /scannow and it tells me there is a repair pending. I looked in the winsxs folder but there isn't a...
Performance & Maintenance
stuck on "welcome" screen cant get "sfc /scannow" to work
Hi everyone. All my experience is with XP, but my partners windows 7 laptop has this problem and I am stuck. it is a Dell laptop latitude E4300 about 4G ram, no external devices fitted. Laptop starts to boot, I log in, "welcome" screen comes up but never finishes processing. Harddrive light...
BSOD Help and Support
Can't run sfc /scannow
This is odd. Suddenly I can't run sfc /scannow. I right click, choose run as admin. The window opens "UAC" click Yes and window flashes but does not open. Any ideas please?
General Discussion
SFC /SCANNOW does not work Plz help me to solve this problem! Before it work,I'm alone Administrator!:sarc: Thank you.
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App