Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How do I Fix the Windows Services - Many in services.msc won't start

17 Feb 2013   #1

Windows 7 home premium 64 bit
How do I Fix the Windows Services - Many in services.msc won't start

64 bit emachines desktop PC running Home Premium, direct wire connection to a modem.

It boots normally, it just doesn't connect to the internet. Many of the services are disabled.

I have done a startup repair with and without a disk (the CD we have is NOT from emachines - it's a standard Windows 7 Home Premium 64 bit disk. The repairs never find a problem. I have done an sfc /scannow. No intefgrity violations were detected.

When I run services.msc I see that DHCP Client is not running. When I attempt to start it, I get that it could not start because the dependency service or group failed to start. If I go to properties and click on Dependencies I get a Win32 error - the service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

I get the exact behavior when I try to start DNS Client.

There are no restore points available. There are no viruses or malware according to TDSSKiller, Malwarebytes and ComboFix. When I try to use Internet Explorer I get the 'page cannot be displayed' . When I then click on 'Diagnose Connection Problems', I get 'Troubleshooting Couldn't Identify the Problem.'

There's about 50GB worht of music and videos on this PC and the idea of saving all that externally, plus the drivers, reinstalling and putting everything back is a lot of time and work.

I was looking for something that used to be available in Windows XP, where you'd pop in the CD, boot from it, hit enter to do an install, then after your OS was displayed you'd hit R do do a repair install.

Have they removed that feature in Windows 7? Any other suggestions?
My System SpecsSystem Spec
17 Feb 2013   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 10 Home x64

You might be at the point where a Repair Install is in order:

Repair Install

A Guy
My System SpecsSystem Spec
17 Feb 2013   #3

Windows 7 home premium 64 bit

I booted the PC, put in the Windows 7 64 bit CD, clicked on 'Install Now', got setup is copying temporary files, and then got Windows could not retrieve information about the disks on this computer.

Now what?
My System SpecsSystem Spec

17 Feb 2013   #4

Windows 7 home premium 64 bit

Fixed the problem by enabling and starting Virtual Disk Service. It had been dusabled. When I click on Upgrade, I get the Your current version of Windows is more recent than the version you are trying to upgrade to. Windows cannot complete the upgrade.

Perhaps my Win7 Home Premiun 64 bit disk is not SP1? The PC definitely is SP1. Using the Dell link to download W7 64 SP1
My System SpecsSystem Spec
18 Feb 2013   #5

Windows 7 home premium 64 bit

Wonderful! (sarcasm). I downloaded W7 SP1 64 bit, burnt the ISO image and ran the in-place upgrade. Now the (expletive deleted)'s want a product key, 2 characters of which I cannot read. I guessed twice (wrongly) and now the services work again and I can connect, but I also went from a PC that was validated to one that is not.

GoshI hate Microsoft. Why don't they just have a simple utility that'll reset your service registry entries back to default level for the OS?
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Services - Restore Default Services in Windows 7
How to Restore Default Services in Windows 7 This tutorial provides you with registry downloads that will completely restore any of the default services and their settings you want in Windows 7. This can be handy if a service was deleted by mistake, is missing, or had it's properties set...
Cannot start Windows Security Center Services. Error 5 access denied
I had trouble updating the MSE definitions a couple of days ago and I tried everything to get it to update, something about no connection. I gave up and uninstalled MSE completely using Revo. From Microsoft's web site, I downloaded and installed the newest version of MSE and the definitions updated...
System Security
Some Windows Services won't start
(Running Windows 7 Home Premium SP1 x64 on a Toshiba Satellite laptop, up-to-date) I was browsing the internet a few days ago, on and (which I'm pretty sure are legitimate sites), no other programs open, when Windows froze, and I had to hold the power button to shut...
General Discussion
Services utility to toggle and restore/enable disable services
Hi, I'm trying to sort out issues with my Win7 machine and want to disable/set to manual services that I know are not needed, but every time I have done this in the past (a while ago now) I invariably run into an issue where I've inadvertently disabled a service that was needed by something,...
3 important Windows-Services don┤t start
Hey there Due to to my last problem, there are three Services which just can┤t start. It always says they get started but they don┤t, they seem to stuck. Well, I only have the german names of them so I will give you the short names: SENS, Dhcp and Imhosts. They┤re all started in the svchost.exe in...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

┬ę Designer Media Ltd

All times are GMT -5. The time now is 12:06.
Twitter Facebook