Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Explorer.exe seems to be running high on usage

13 May 2013   #1
Brandon138

Windows 7 Home Premium 64bit.
 
 
Explorer.exe seems to be running high on usage

I hope this is the correct area to post this.

My explorer.exe I noticed has been running at a higher usage rate than normal that last few days. I had recently installed Daemon tools lite, and it was suggested that it could be the problem, so I uninstalled that and ran the SPTDinst.exe and removed the drive, restarted the computer and I am still having the problem. Explorer.exe seems to go from about 25,000kbs to 45,000kbs when I am not running anything major. The only other thing I installed recently was the Rosetta Stone software, not sure if that could be the problem. A

Any ideas on what to do about this? Or is the normal? I run windows 7 64 home premium. I have norton 360 installed and ran a full scan, nothing, and did the same with Malwarebytes and nothing came up.


My System SpecsSystem Spec
.
13 May 2013   #2
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Maybe normal, Mine is currently 34,120K, that's how much RAM it is using, not Kbs. Getting rid of Daemon was a good idea.
My System SpecsSystem Spec
13 May 2013   #3
Brandon138

Windows 7 Home Premium 64bit.
 
 

Really, well that makes me feel a bit better, I googled it and people seemed to think that was high, which is why I posted this thread. I was also told that Norton 360 tended to bump things up a lot and it was suggested that perhaps I should switch to either Avast or MSE.

The only other thing of note is I got a BSOD the other day, which is rare for me these days and it happened when I plugged in an external hard drive. I was told I should update my AMD usb filter driver, but I could not find the correct one for my toshiba satellite online at their website, so I did nothing and the problem has yet to resurface. Not sure if that could have anything to do with it.

So in your opinion, would you say not to worry about it at this time?
My System SpecsSystem Spec
.

13 May 2013   #4
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

I don't see anything wrong. I am a Norton user but I don't like the 360 product, it doubles up on a lot of things w7 already does. I'd disable all of its "optimizing" features. I just use their Internet Security. MSE is kind of weak on detections but many here use and like Avast security.
My System SpecsSystem Spec
13 May 2013   #5
Brandon138

Windows 7 Home Premium 64bit.
 
 

Thanks I will configure Norton better, appreciate the advice and attention paid.
My System SpecsSystem Spec
13 May 2013   #6
carwiz

Windows 7 Pro-x64
 
 

Open Task Manager, click on the Performance Tab. At the bottom of that window is a button labeled Performance Monitor. Click on it then select the Disk Tab on that new window. It will show all disk drive activity by file. Windows 7 does a lot of background housekeeping but if you watch the activity, it will drop off and you can see what files are in use. The other tabs show similar activity for CPU, Memory and Network. It's a nice tool for checking your system.

The Overview Tab will show all processes and services. You can change the order of the list by clicking on a column header. If you click on Average CPU, you can see who the hogs are.
My System SpecsSystem Spec
Reply

 Explorer.exe seems to be running high on usage




Thread Tools




Similar help and support threads
Thread Forum
Very high CPU Usage without running anything
Hi! I booted my laptop tonight and I notice that it is really slow. Start up is good (I only had 4 start up entries). But when I try to refresh the desktop, it will take a long time before the menu will pop up.Whenever I click refresh, it will almost take 10 seconds before it will refresh. I...
Performance & Maintenance
Very high physical memory usage, no high usage programs running
Hello everyone, I've been having a very weird problem recently, in which I BELIEVE is involving high physical memory usage. Sometimes I will be doing things such as playing a game, or watching a stream, and my computer will run fine for a little while. But at random times, my computer will majorly...
Performance & Maintenance
High RAM Usage & Nothing Is Running
Recently, I noticed that my RAM usage is high. It jumps up to 35 & 40, while it used to be 15% or less. This affects my gameplay and I can't play any game smoothly. CS:GO for example was perfect, now I have a lot of FPS drops and FPS spikes. Performance SS: http://i.hizliresim.com/mPl13Z.png...
Performance & Maintenance
High CPU usage when the computation program is running
Dear all This is my first post. I need your help from you. I am doing computational analysis for my project work. The computational analysis will finish approximately 7 hours. When I run the program for computational analysis, the computation process running fast . During this time, I...
Performance & Maintenance
High CPU usage with only a program running
hi everyone^^ again i need your help:cry: almost 2 weeks ago i reinstalled my windows duo to my nvidia..and i had to buy a new nvidia now on the fresh instaled windows. i had windows 7 profesional and nvidia geforce 8400gs and now i have windows 7 ultimate and nvidia geforce 210. it was a...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App