Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: svchost using high cpu often like clockwork

08 Oct 2013   #1
Berkey

Microsoft Windows 7 Professional 64-bit SP1
 
 
svchost using high cpu often like clockwork

When I wake my laptop and start the internet (right after waking), generally after 3-4 minutes this svchost kicks up which involves;

(task scheduler, themes, windows updates, windows profiler services, application information, background intelligent transfer service, extensible authentication protocol, IKE and AuthIp Ipsec keying modules, windows management instrumentation, system event notification services)

This will take up to 7-8 minutes and use around 80% of the CPU and most of the Physical memory. Is this a normal process and my underpowered laptop just not up to the task? It stops shortly and then all is well, no lags or high usage, but I thought I'd see if this process is indeed a "greedy" one naturally.


My System SpecsSystem Spec
.
12 Oct 2013   #2
poolmon

win 7
 
 

I have not run into this on WIN 7, but on both my WIN XP machines I had the same problem.
I fixed both by going to" Microsoft Update" (which I had enabled a long time ago) and disabled it, allowing to it revert back to "Windows Update" only (without looking for all Microsoft application updates only Windows OS). I then disabled Win Auto Updates.

Svchost dropped from 100% to 0%. I now just manually check for updates. Don't know if this will work for you but just thought I'd toss it out there.

Also if you have any HP Multifunction Print drivers on your machine, they have been known to cause the same issue with svchost at least on XP.
My System SpecsSystem Spec
16 Dec 2013   #3
Berkey

Microsoft Windows 7 Professional 64-bit SP1
 
 

So this problem seemed to go away a while ago, but last night my laptop was inoperable for 20 mins with 100% memory and upwards to 80% cpu. Any ideas or has anyone experienced this on 7?
My System SpecsSystem Spec
.

16 Dec 2013   #4
Ztruker

Windows 10 Pro X64
 
 

On XP this is caused by SVCHOST running for Windows Update. Disabling Automatic Updates resolves the problem. Probably not a good idea for Win 7 though.
My System SpecsSystem Spec
16 Dec 2013   #5
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Did you try to find out which .dll is running under the svchost.exe. Process Explorer is a good tool for that. Right click on the process and go to Properties.
My System SpecsSystem Spec
Reply

 svchost using high cpu often like clockwork




Thread Tools




Similar help and support threads
Thread Forum
High CPU Usage Due to svchost.exe
So this problem just happened out of the blue today. I was just browsing with my desktop and it just so happens that I noticed the jittery/laggy movement of my cursor occasionally. So I checked the Task Manager and noticed that svchost is putting my CPU usage at 50%~75% constantly. The high CPU...
Performance & Maintenance
svchost.exe High CPU usage 98% of at least one CPU.
I have had that message a couple of times whilst on the Forum. Haven't noticed it when I am doing anything else. Here's the info I get when I click on more details; Here's a screenshot of Process Explorer which I think indentifies the problem. I'm just not sure what to do to rectify this. ...
Performance & Maintenance
svchost.exe high memory
Whenever I start my computer,I'm getting high memory usage on svchost.exe ImageShack® - Online Photo and Video Hosting I'm not so sure which info I need to provide,to continue troubleshooting so here is some: Nod32 antivirus,Q9650 @ 3.00GHz,8 Gig of ram,around 10Gig of free space at the system...
Performance & Maintenance
SVChost high memory help
8 of the SVChost is using 396mb in total this is way to much how can i cut this down i thought this was for service coz i have a tweaked service i only set the services i need to automatic or manual but this process id taking up so much
Performance & Maintenance
svchost.exe high CPU - sigmatel problem or other?
Hello, as this is my first post, I'll try to explain my problem as good as possible. At the moment the official windows 7 build 7100 evaluation copy is running on my system (dell inspiron 6400, dual core 1,83 GHz, 2gb RAM, intel 945 chipset). It's installed since april 2009 and didn't give me...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:05.
Twitter Facebook Google+