Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't run chkdsk

06 Nov 2013   #1
shokan2

Windows 7 Pro 64bit
 
 
Can't run chkdsk

Right click an external USB hard drive (WD My Passport) > Properties > Tools > Error Checking > Check Now > Check Disk My Passport > Automatically fix... > click START.

The Check Disk My Passport box disappears as soon as I click START and nothing happens.

I started getting Delayed Write errors for.doc and .txt documents yesterday. The documents won't save my text additions. This is the reason I want to run chkdsk. Also, I open folders on the external drive that have files in them, but they show up empty. In the past when this has happened, a restart fixes this.

What is the problem here? Need advice. Thanks.

update: on Restart, Windows started installing device driver for a simple USB hub that the external drive uses. Why, I have no idea, because the hub has always been used The external WD My Passport was recently attached to it btw (about 2 days ago).

Now, the documents in question have all updated with my additions (that were previously not done, with the accompanying Delay Write notification as mentioned above) And the problem of folders appearing empty on the external drive has also been fixed after the restart and USB hub device driver install.

So, now my only question is, why did this all happen? Why would the computer need to install device driver for a generic USB hub, one that I've had attached for a long time?

The chkdsk runs fine now and the details are below. It said 'some errors found'. Are there clues to what happened in the details?




Attached Thumbnails
Can't run chkdsk-chkdsk-details-2013-11-06-wdmypassport.jpg  
My System SpecsSystem Spec
.
10 Nov 2013   #2
shokan2

Windows 7 Pro 64bit
 
 

I'm still having problems with the external WD My Passport hard drive. Just in the past few minutes, the whole drive comes up empty when I click on it. It was fine half an hour ago. When I try to safely remove it to try re-attaching it, Windows says it is being used by another process. LockHunter showed Explorer using it, so I unlocked that. Safely remove still says being used by another process. And the drive appears empty. Also, can't run chkdsk on it, same behavior as in my first post (START> nothing happens).

What could be happening here?
My System SpecsSystem Spec
Reply

 Can't run chkdsk




Thread Tools




Similar help and support threads
Thread Forum
CHKDSK will not clear dirty tag after chkdsk c: /r ?
I have a 2 TB WD BLACK SATA drive in my computer. For a couple of days while I was gone I ran chkdsk c: /r Hoping to clear the dirty tag I get when I run ( fsutil dirty query c: ) When I came back the boot screen was up and I logged in .. the dirty tag is still there. I've run the WD utility...
Hardware & Devices
How to get a log from chkdsk after running chkdsk from the RE?
Hi there, Is there any way to get a chkdsk log from an unbootable computer after you run chkdsk from the Recovery Environment (RE) so it can be posted on a forum? Thank you, Donna :)
Hardware & Devices
Can't get chkdsk to run...
I need to run chkdsk /F on my system (C) drive, and thus far I've been thwarted. I've tried two ways: In windows explorer, right click drive C and select properties > tools > Error checking. A window pops up and I keep the default (Automatically fix file system errors) checked. When I click Start...
Performance & Maintenance
Tools Chkdsk with no /f /r says errors, bootup chkdsk says none
AHCI disk. Running chkdsk from Properties Tools with no autofix says there are errors. Dismount the drive and reboot. Chkdsk reports no errors found. Properties Tools Chkdsk still syas there are errors. Auslogics Defrag also says there are errors.
Hardware & Devices
chkdsk can not run.....?
i tried to run chkdsk from Command Line, and restarted this netbook, and same message showed. how do u run this?
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App