Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Issues with hiberfil.sys / safemode / admin / et al

19 Jan 2014   #1

Windows 7 64 bit
Issues with hiberfil.sys / safemode / admin / et al

I just recently built this computer and was checking my harddrive last night and realized I was already at 87 gigs of 111 gigs available.

This made absolutely no sense since I only have Windows 7, Nero and a copy of Skyrim installed thusfar.

I started making inquiries and lo and behold I found that pagefile.sys and the aforementioned hiberfil.sys were hogging in excess of 54 gigs of my harddrive.

I started searching for methods in which to remedy this and was able to eradicate the pagefile.sys file and regain about 30 gigs of my drive.

The hiberfil.sys file has been another story. I have tried to disable hibernate and succeeded via GUI. But I cannot delete the file afterwards. I get this:

The action cannot be completed because the file is open in another program.

Thus I embarked on trying to enter: powercfg.exe -h off into the command prompt.

I get this:

You do not have permission enable or disable the Hibernate feature.

So, I figure it is because my user name, which actually does have admin privileges, is not an admin or something. I tried starting in safemode but for the life of me I can't get this computer to start in safemode. f8 = nothing except stuck key alarm.

I have followed this:

Hibernate - Enable or Disable

and associated links. I have searched here and on Tom's and found no one else facing the same issue.

If anyone can help me I would be eternally grateful.

Thank you in advance.

My System SpecsSystem Spec
19 Jan 2014   #2

Windows 7 64 bit

When I say no one with the same issue. I mean no one who has not reached a positive conclusion.
My System SpecsSystem Spec
19 Jan 2014   #3

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1


In my experience the hiberfil.sys file doesn't need to be manually deleted. A simple reboot after disabling hibernation should do the trick.

Also if you have more than one power plan - check that hibernate is disabled in the settings for each power plan.

Re: Pagefile.

The pagefiile should not grow to a huge size. Check your Virtual Memory settings and set the page file for your windows partition to system managed size. Ignore the settings in the screenshot as they are specific to my machine. Just highlight your windows partition and select "system managed" size.

Start > Run then type:


Press Enter.

On the "Advanced" tab choose "Settings" under "Performance" then on the "Advanced" tab select "Change" under "Virtual Memory"

Issues with hiberfil.sys / safemode / admin / et al-virtual-memory.jpg

My System SpecsSystem Spec

19 Jan 2014   #4
Microsoft MVP

Windows 7 Ultimate X64 SP1

This is the command to disable Hibernation, powercfg -h off, note the space between "g" and "-". Be sure you run it with Elevated Command Prompt
Callendar is correct, the command will delete the hiberfill.sys immediately.
My System SpecsSystem Spec
19 Jan 2014   #5

Windows 7 64 bit

HI Callender,

Thank you. As stated, the pagefile issue was dealt with and is no longer an issue.

My issue now is only with hiberfil.sys

I have rebooted and the file is still sitting there and still hogging 23.9 gigs of my hard drive. So yeah, I would like to delete it. But I cannot because the file is still open in another program.

Nothing I do suggested in any number of forum threads is doing anything because I don't have the permissions to make those changes supposedly.
My System SpecsSystem Spec
19 Jan 2014   #6

Windows 7 64 bit

Hi Britton30,

I just tried this elevated command prompt by typing %HOMEDRIVE%%HOMEPATH% into the properties box. I applied it and close it and now when I try to open the command prompt it opens it's file location on the C drive.

When I type the program into the search box and open it, it opens the user command prompt. I'm not sure how I am suppose to get the system32 command prompt to open. But typing the powercfg -h off after the only prompt I can get to opne doesn't do anything..
My System SpecsSystem Spec
19 Jan 2014   #7

Windows 7 64 bit

Hi Britton30,

That worked. The elevated command prompt did it.

79 gigs of 111 hd remain now, as opposed to 28 previously!

Thank you. Big props.
My System SpecsSystem Spec
19 Jan 2014   #8
Microsoft MVP

Windows 7 Ultimate X64 SP1

Good to hear, that's a good gain.
In the future just type cmd in the Start/Search field, in the results is CMD prompt, right click it and select Run as Administrator.
My System SpecsSystem Spec

 Issues with hiberfil.sys / safemode / admin / et al

Thread Tools

Similar help and support threads
Thread Forum
Issues with admin elevation from system drive
Hey Everyone, my first time on the forums here, and hopefully i am posting in the right section! This is going to be a bit of an in depth explanation here and i am sure i will leave stuff out that we have already tested, as i have done a fair bit of tested into what exactly is happening. ...
General Discussion
New restore/install, admin issues
Today I decided to wipe out my Gateway PC and do a restore/new install. The problem is, is that every time I install a program an admin window opens up and asks for a password. I never had this trouble before. I have the Admin account then my account that shows as admin when I logon, but looking...
General Discussion
Admin/Guest Issues
Hello, Hopefully someone can help me with this. I set up a Admin account on my computer. I was able to access it, so I was using guess and remembered it when going cmd the control userpassword2 i accidently deleted the admin account at the point and now only have access to guest. how...
System Security
Issues with Admin Rights
Ok, so here's my issue. I am the admin on my laptop although some things are disabled. I bought it as a refurb with W7 HP 32bit. If I go to manage accounts and create a new account with FULL power, it already shows me as the Admin. When I go to turn on Windows Updates, it says "Some settings...
System Security
Admin issues preventing bridging connections
I read over a few of the forum posts on how to bridge connections with Windows 7, and followed the instructions to the letter. Now the problem that is killing me is this: Windows keeps poping up with the error saying "You do not have sufficient privilages for configuring connection properties....
non-admin user, wireless issues
Hi, Ive just bought my daughter a new laptop which had Win7 home pre-installed. I left the default account as an administrator account, passworded and created a secondary account for her, non-passworded. Everytime we log into her account, the wireless light on the laptop seems to be...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App