Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RAID's write speed on large files suddenly tanking randomly

02 Feb 2014   #1

Windows 7 Home Premium x64
RAID's write speed on large files suddenly tanking randomly

tl;dr: When recording with fraps, dxtory or just generating a large file, my write speed fluctuates wildly, ranging from 140-70, but also dropping to as low as 2mbps, causing lag and maxing out disk activity %.

I've been recording gaming sessions off and on for a couple months now, but a few weeks ago, I started getting a problem with fraps. While recording, the frame rate will suddenly go into the toilet and my hard drive will start thrashing continuously, interfering with my game. Stopping the recording instantly fixes the issue. Nothing in the game seems to be causing it, it happens with recording plain desktop even. I tried using dxtory, another recording program, and it too seems to have this issue. It even has a disk write speed tester and it registered inconsistent write speeds, wildly swinging between 140mbps and dropping to single digits at times, sometimes nosediving down to 2mbps and staying there until I end the test.

I went back to fraps and watched the Resource Monitor when the issue kicked in. The recording speed went from 54mbps (give or take) down to 3-5 during those incidents while the highest active time pegged up to 100% and stayed there. 100% access time to get 2mbps write speed? Not good. No other programs appear to be interfering from what I can tell. I'm worried there's something bad wrong with my RAID 1 or the drives themselves.

On a possibly related issue, a few weeks ago (can't remember if it happened before or after this started) I had a power loss while gaming. I recovered and restored the RAID but later that night the computer locked up hard, completely. I had to manually shut the computer off. I thought it was just a bit of fizz in the ram after the power loss but it happened again last week during a periodic MBAM scan. It's got me worried.

Any help or insight would be appreciated.

My System SpecsSystem Spec
05 Feb 2014   #2

Windows 7 Home Premium x64

I can get the issue to happen pretty reliably. Just create a large file. dxtory's speed tests creates a dummy file and fraps creates large movie files. Both causes the issue to happen.

As I watch in Resource monitor with fraps recording, the disk activity goes at 31-36 MBps and 12-16% highest active time for a while, before instantly changing to 6-9 MPps and 100% highest active time, slowing everything down.

Included a screenshot of the occurrence. You can see from the graph the very clear marker between normal recording and when my HDD array wigs out.

I've tried disabling my antivirus entirely, no change. Ran CrystalDiskInfo, came up clean. I'm not sure what's going wrong.

Attached Thumbnails
RAID's write speed on large files suddenly tanking randomly-screenie.jpg  
My System SpecsSystem Spec
07 Feb 2014   #3

Windows 7 Home Premium x64

For the record, I've found what the problem was. After defragging (it went 10 passes) the recording is now smooth and doesn't drop to nothing anymore. Apparently writing and deleting large files over and over again is murder on the fragmentation.

My System SpecsSystem Spec


 RAID's write speed on large files suddenly tanking randomly

Thread Tools

Similar help and support threads
Thread Forum
USB write speed is suddenly extemely low!
Please help me! A lot of stuff has happened in the last two days, which I don't understand. The latest thing to happen, is that I can't write large files to USB-sticks. I usually transfer at about 1 GB per minute. Now, about the first couple of hundred MB (judging by the progress-bar) go at...
Hardware & Devices
Suddenly large pointer
After a recent reboot I have found that my pointer/hand selected icon/busy circle etc. are now all large size. I have checked Control Panel > Ease of Access > Make the mouse easier to use. Pointer size is set to NORMAL, but the QUICK ACCESS window has both check boxes enabled...not previously...
Can't download large files without corruption suddenly
2 Days ago I started having an issue with downloading large files. I never have any issues with downloading, but over the last 2 days virtually all of my large downloads have been corrupted. Most of the files are .rar or .zip files. Some are multi-part, and some are single .rar files. I have...
Network & Sharing
16 GB SanDisk Cruzer suddenly becomes write protected!
Got a 16 GB SanDisk Cruizer flash drive and it did well - until I swapped my hard drive for an SSD. Since the SSD conversion, the ReadyBoost file on it does not work - Windows won't use it because I have an SSD - that' fine. The real problem is the SanDisk became write protected - can't format,...
Hardware & Devices
loading windows 7 onto large RAID 0 disk
Hi I am new here, but I must already thank you for all the interesting info I have found here. I recently upgraded my computer and part of the plan was to use two 2Tb drives in a raid setup for my main windows drive. I see that it only recognises about half of the raid volume and the rest is...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:50.
Twitter Facebook Google+