Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System not shutting down when entering sleep

07 May 2014   #1

Windows 7 Ultimate
System not shutting down when entering sleep

Windows 7 Ultimate X64 SP1 system.
All has been fine until I installed Firefox 29.0 upgrade (with Mozilla Maintenance). Now, when I put the computer into sleep mode, the screen blanks (monitor goes into power save mode), but system keeps running. When I press power button to resume, Windows logon screen appears, and all is OK when I am logged in.

Now the details:
This problem only occurs after I have waited about 1min or more from boot (cold or warm). If i go into sleep before that time, the system shuts down normally.
This being the case, I opened Services and checked for anything that has delayed start. I found two items.
It turns out that the PnP-X IP Bus Enumerator service is the problem. When it is enabled (automatic - delayed start), the problem occurs. If I stop the service, then wait about 30 seconds for all of its processes to shut down, sleep mode works properly. If I start it again and wait 30 seconds for processes to start up again, sleep mode does not work properly.

I have temporarily disabled the PnP-X IP Bus Enumerator service. It does not appear that my system needs to run it. I have not found anything that doesn't work as a result.
That said, I would rather solve this issue properly. The PnP-X IP Bus Enumerator service was not causing any issues prior to upgrading Firefox. Perhaps there is another program causing the problem, but I do not recall installations other than the Firefox upgrade since the last time sleep was working properly. I have not yet tried uninstalling Firefox, but I think I should try that.

Any ideas?


My System SpecsSystem Spec
07 May 2014   #2

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

The default startup type for the PnP-X IP Bus Enumerator service is Manual, so something changed it on your system.
Maybe a Media Center device, XBOX, ... ?

I found this old thread where someone reported the same issue, but there is no reply/solution

My System SpecsSystem Spec

 System not shutting down when entering sleep

Thread Tools

Similar help and support threads
Thread Forum
System Crashes When Entering Sleep Mode
About ever 2nd or 3rd time I send my desktop into sleep mode, the display goes black, there appears to be disk activity for approx 10 mins until the system figures out there a problem and powers down. Everything works fine when I reboot. Windows states that it was unexpectedly shut down but irt...
BSOD Help and Support
Monitor only entering sleep mode, system continues working.
Hello everyone, My system suddenly stopped responding to the sleep command. The monitor goes blank but the system keeps on whirring away. I have gone through google and tried a few things and the best one so far was to run powercfg /energy, which has produced some results that I dont...
Performance & Maintenance
Bsod after/while entering sleep
After putting my computer into sleep mode, it crashes about (if not more than) half of the time. I've attached the mini dump file.
BSOD Help and Support
BSOD when entering sleep mode and with System Restore
I recently started to have problems with my system crashing and BSOD when it went into sleep mode. I updated all of the drivers and have attempted different fixes but I cannot resolve this issue. When I attempted to do a System Restore, it, too, was unsuccessful and also crashed with BSOD. There...
Backup and Restore
Problem when entering sleep
My laptop doesn't seem to be able to fully enter sleep mode, the screen will turn blank and then nothing happens for 10 mins. Then the system automatically restarts and when I log into Windows I get the error message stating : Windows has recovered from an error or whatever. I'm including the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:54.
Twitter Facebook Google+