Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to import <filename>.reg: Acces to the registry denied

20 Jun 2014   #1

Windows 7 Home Premium 64bit
Unable to import <filename>.reg: Acces to the registry denied


This is a pretty long story...:

So, I have program called CCleaner, it is a fine tool which can clean up your browser cookies, temporary files, etc. It can also scan for errors in the registry and remove them, however, this is not always safe, so I always make a backup whenever I mess with the registry.
A while ago (May 29th) I ran CCleaner again, after uninstalling a few programs, just to remove registry keys of these programs that may have been left behind. I did not pay attention to all the registry errors CCleaner had found and so I pressed "Remove all errors", and so it did.
However, after I did that, some things in Windows explorer were messed up: The bar at the top was gone and files were no longer shown as I requested (details/large icon size/etc)
I managed to manually fix that though, so I thought: Ok, it's all fixed, no worries.
I am still at high school, so after that, I had exams, until today. So today I booted up the PC again and decided to play some music files (.mp3 format)
However, that did not work. I always get an error message from Windows Media Player, saying that it could not open the file. I tried with my other 2 media players (VLC and Quicktime): They could open the file, but there was no sound.
Same thing for videos: just a black screen and no sound.
Windows sounds and YouTube are still working, so not all the sound is gone.
However, it does have a major impact. I have a few videogames and there is no sound in them either now. Probably because the games' sounds are coded in mp3/wav/ogg/etc.

So, I think that something has happend with the orginal microsoft/windows audio and video codecs, being corrupted...
After searching for an explanation for almost an hour, I came to the conclusion that it had something to do with the registry that I messed with on the 29th of May. I made a backup, but it simply does not want to merge back into the registry, no matter how I do it.

I always get the following error message:

Yes it is in Dutch, sorry for that. (Somewhat) litteraly translated: Unable to import <filename>.reg: An error occured while trying to acces the registry.

I have tried numerous things, like opening it as administrator, running regedit.exe and importing it from there, adding more permissions(which was useless, because this is the administrator account anyway)

I am starting to worry right now, thinking that this might have permanentyl corrupted microsoft software (which I cannot freely re-obtain from the internet anywhere)
I am not an adult yet (I still live with my parents) and so this computer is not fully my property, so if I mess it up, I am in trouble...
I tried numerous things to fix the codec issue, by finding other audio and video codecs. I tried K-Lite codecs, installed them, but they had not a single effect whatsoever. I also tried some other things which may have worsened it, but luckily I know how there is a System Restore option, so I gave it all up and used that to, unfortunately, get back to another day, which was the 9th of June, which is after May 29th, the day I used CCleaner)

Here is the .reg file that I backed up:

Windows Registry Editor Version 5.00










@="CisDebugInjector Class"





@="MAPIForm object"


@="MAPIForm object (V 1.0)"


@="Visual C# Project file"


@="Visual Studio Data Source File"


@="Visual Studio Code Snippet File"


@="Visual Basic Project file"


@="Visual Studio Project/Item Template File"


















[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\Wargaming\\World of Tanks Test\\WOTLauncher.exe"="RUNASADMIN"

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted]

Any useful help will be greatly appreciated.

My System SpecsSystem Spec
20 Jun 2014   #2

Windows 10 Pro X64

The easiest fix is to do a System Restore to before you ran CCLeaner.

Another way: Reset the entire registry permissions to defaults | Windows Reference

And one more: Windows Repair All-In-One
Complete the first 4 steps.
Once you get to Start Repair, click Unselect All then check Reset Registry Permissions at the top and click Start. Reboot when it finishes then try to merge the .reg file again.
My System SpecsSystem Spec

 Unable to import <filename>.reg: Acces to the registry denied

Thread Tools

Similar help and support threads
Thread Forum
is possible to set a password to a registry key?or block acces?
is possible to set a password to a registry key?or block acces only for that key?do not let that no one can edit or delete
General Discussion
Unable to acces files (grub4dos recovery)
running windows 7 ultimate 32 bit ok I recovered from grub4dos error windows start up but gives me black screen I press ctrl alt del en open task manager I create new task and type explorer.exe
General Discussion
No acces to registry
Hello everyone, I've got a problem with my user account. Whenever I log on I don't see my own background, but just a regular Windows 7 background. Also, a lot of my icons are gone and the menu is in English, though it used to be in Dutch. I found out that I sould go to registry...
General Discussion
Acces Denied - copy files external drive (xp)
Hi - In copying files from external drive (xp files) I received a lot of access denied errors on open. I right clicked on drive, and some subsequent folders, and took ownership, and set up full control permissions for admin group (as I am admin). STill got errors on some of the files. They...
System Security
Acces Denied for W7 Shared folder
i cannot access a shared folder on Windows 7 from an XP machine. buy W7 laptop. share folders on W7 laptop and access them on XP machine... no problem. router goes bad and have to replace. setup new router. connect to internet from W7 and Xp machine. connect to XP shared folders from W7...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:54.
Twitter Facebook Google+