Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error 1935 HRESULT: 0x80070003 when installing Microsoft Visual 2008

21 Jul 2014   #1

Windows 7 Professional x64
Error 1935 HRESULT: 0x80070003 when installing Microsoft Visual 2008


I was trying to install XNA 3.1 when I started receiving some VC90 errors. I uninstalled Microsoft Visual C++ 2008 32 and 64, but receive an error when reinstalling. Error 1935 HRESULT: 0x80070003.

I ran SFC /SCANNOW. CBS came back OK. I ran the readiness tool. CheckSUR says I'm fine. The install log seems to error out at:

MSI (s) (70:34) [23:22:13:604]: Executing op: ActionStart(Name=InstallFiles,Description=Copying new files,Template=File: [1], Directory: [9], Size: [6])
MSI (s) (70:34) [23:22:13:604]: Executing op: ProgressTotal(Total=65689,Type=0,ByteEquivalent=1)
MSI (s) (70:34) [23:22:13:604]: Executing op: SetTargetFolder(Folder=C:\Windows\winsxs\x86_microsoft.vc90.openmp_1fc8b3b9a1e18e3b_9.0.30729.4148_n one_80b7c8a91e9dd16a\)
MSI (s) (70:34) [23:22:13:604]: Executing op: SetSourceFolder(Folder=1\Windows\winsxs\-k7oasqv\|Windows\winsxs\ulOpenMPx86\)
MSI (s) (70:34) [23:22:13:604]: Executing op: ChangeMedia(,MediaPrompt=Please insert the disk: 1,MediaCabinet=1\,BytesPerTick=65536,CopierType=1,,,SignatureRequired=0,,,IsFirstPhysicalM edia=1)
MSI (s) (70:34) [23:22:13:604]: Executing op: AssemblyCopy(SourceName=cqodxjgu.mic|,SourceCabKey=ul_catalog.30729.4148.Microsoft_VC90_OpenMP_x86.QFE,DestName=x86_Micros,Attributes=0,FileSize=6501,PerTick=65536,,VerifyMedia=1,ElevateFlags=4,,,,ComponentI d={2021B2F9-AC6C-398F-A9DE-113A293ADEBD},,,,AssemblyMode=0,)
MSI (s) (70:34) [23:22:13:604]: Assembly Error:The system cannot find the path specified.

MSI (s) (70:34) [23:22:13:604]: Note: 1: 1935 2: {2021B2F9-AC6C-398F-A9DE-113A293ADEBD} 3: 0x80070003 4: IAssemblyCache 5: CreateAssemblyCacheItem 6: Microsoft.VC90.OpenMP,version="9.0.30729.4148",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitectu re="x86",type="win32"
MSI (s) (70:34) [23:22:13:604]: Assembly Error (sxs): Please look into Component Based Servicing Log located at -116132744ndir\logs\cbs\cbs.log to get more diagnostic information.
MSI (s) (70:34) [23:22:14:622]: Product: Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4148 -- Error 1935.An error occurred during the installation of assembly 'Microsoft.VC90.OpenMP,version="9.0.30729.4148",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitect ure="x86",type="win32"'. Please refer to Help and Support for more information. HRESULT: 0x80070003. assembly interface: IAssemblyCache, function: CreateAssemblyCacheItem, component: {2021B2F9-AC6C-398F-A9DE-113A293ADEBD}

I'm just unsure which path it's failing to find, and would like to avoid a repair install if possible. This is Windows Professional x64.

Attached Files
File Type: txt install.txt (510.6 KB, 0 views)
My System SpecsSystem Spec
25 Jul 2014   #2

Windows 7 Professional x64

Repair install doesn't look like a choice. It was a MAK and I can no longer get the key. I gave my account full rights to the registry and winsxs. I've narrowed it down a bit more.

Correct Install:
MSI (s) (4C:1C) [21:29:23:979]: Executing opSetTargetFolder(Folder=c:\Windows\winsxs\x86_microsoft.vc90.openmp_1fc8b3b9a1e18e3b_9.0.30729.4148_none_80b7c8a91e9dd16a\)
MSI (s) (4C:1C) [21:29:23:979]: Executing opSetSourceFolder(Folder=1\Windows\winsxs\-k7oasqv\|Windows\winsxs\ulOpenMPx86\)
MSI (s) (4C:1C) [21:29:23:979]: Executing opAssemblyCopy(SourceName=cqodxjgu.mic|,SourceCabKey=ul_catalog.30729.4148.Microsoft_VC90_OpenMP_x86.QFE,,Attributes=0,FileSize=6501,PerTick=32768,,VerifyMedia=1,ElevateFlags=4,,,,ComponentId={2021B2F9-AC6C-398F-A9DE-113A293ADEBD},,,,AssemblyMode=0,)
MSI (s) (4C:1C) [21:29:23:979]: Source for file 'ul_catalog.30729.4148.Microsoft_VC90_OpenMP_x86.QFE' is compressed 
My Install:
MSI (s) (50:24) [19:49:07:545]: Executing opSetTargetFolder(Folder=C:\Windows\winsxs\x86_microsoft.vc90.openmp_1fc8b3b9a1e18e3b_9.0.30729.4148_none_80b7c8a91e9dd16a\)
MSI (s) (50:24) [19:49:07:546]: Executing opSetSourceFolder(Folder=1\Windows\winsxs\-k7oasqv\|Windows\winsxs\ulOpenMPx86\)
MSI (s) (50:24) [19:49:07:546]: Executing opAssemblyCopy(SourceName=cqodxjgu.mic|,SourceCabKey=ul_catalog.30729.4148.Microsoft_VC90_OpenMP_x86.QFE,,Attributes=0,FileSize=6501,PerTick=65536,,VerifyMedia=1,ElevateFlags=4,,,,ComponentId={2021B2F9-AC6C-398F-A9DE-113A293ADEBD},,,,AssemblyMode=0,)
MSI (s) (50:24) [19:49:07:546]: Assembly Error:The system cannot find the path specified
Searching I can't find 2021B2F9-AC6C-398F-A9DE-113A293ADEBD in the registry or that cab file anywhere. I don't even have that ulOpenMPx86 folder.
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Error code 1935 and HRESULT: 0x80070003 and MS Support advice
Hi, I really hope someone can help. I have the errors when trying to install Corel Video Studio (]Video-editing software - VideoStudio Ultimate X8 It starts and fails generating the error codes. Product: Microsoft Visual C++ 2005 Redistributable -- Error 1935.An error occurred during the...
Performance & Maintenance
Error 1935, Microsoft Visual C++ 2008 Redistributable Package (x86)
I once had this before when I tried to download Age of Empires Online. I decided one game isn't worth the problem, and I'd avoid all "Games for Windows" games because of this issue. Now, I recently bought a Vita and now I can't download Content Manager Assistant because of this, so now it is...
Error 1935 installing ms visual c++ x64 2008 and others
Hi, I was working on this some time back when I was taken very ill and everything was put on hold. However I am back at it and would love some help form someone who understands the issues. This is a problem I have been struggling with for many months, on-line research shows itís quite common...
Error 1935: Microsoft Visual C++ 2008 Redistributable x86 Install
I was trying to install Visual Studio 2010 and started encountering errors with the C++ distributable package during install, so I decided to install it by itself. Whenever I try and install it, it stops on Feature: FT_VC_Redist_openMP_x86 and I receive the following error message before it...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:18.
Twitter Facebook