Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SFC can't repair mmdevapi.dll and %windir% folder perms are wrong

28 Aug 2014   #1

32bit Win7Pro
SFC can't repair mmdevapi.dll and %windir% folder perms are wrong

I'm trying to fix a Dell Inspiron 1545 running 32 bit Win7 Home Premium. Pentium T4300 cpu@2.1gHz. 3GB ram.
Background: They brought me the laptop saying it was running slow and not able to get on the Internet. Ha! I found a multitude of problems and have worked my way through most of them. Many toolbars and other adware related where removed by JRT and AdwCleaner. Mbam removed trojan Vundo and more pup's. I thought I was well on the way to fixed so I started Windows Update. 14 updates and they failed. I tried them one at a time and all installed except the .NET Framework ones.
I tried the tools to repair dotnet which didn't help so I ran the dotnetfx_cleanup tool. I was able then to install the .NET Framework 1 and its service pack but not anything higher. The installer simply aborts with error code 80070643. So I ran SFC and the cbs.log says; well I'll include the pertinent part. Thinking I had to replace mmdevapi.dll I took a closer look at it and discovered that the permissions were set so all groups had full permissions except trusted installer, which had only list. I knew that was wrong.
Sooo, dotnet won't update; file permissions are a mess (it looks like all of them are wrong) and sfc says a system file is corrupt and it cant find a replacement. BTW: the owner doesn't have an install disk. I copied a new mmdevapi.dll from my install disk but didn't do a file replacement because the file permission thing has got me spooked.
Is there any hope?

last part of cbs.log that applies:
{16}]"MMDevAPI.dll.mui" of Microsoft-Windows-MMDeviceAPI.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
2014-08-28 18:45:50, Info CSI 000001d1 [SR] Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:24{12}]"MMDevAPI.dll" from store
2014-08-28 18:45:50, Info CSI 000001d2 [SR] Cannot repair member file [l:32{16}]"MMDevAPI.dll.mui" of Microsoft-Windows-MMDeviceAPI.Resources, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing
2014-08-28 18:45:50, Info CSI 000001d3 [SR] This component was referenced by [l:262{131}]"Microsoft-Windows-WindowsFoundation-LanguagePack-Package~31bf3856ad364e35~x86~en-US~6.1.7601.17514.Windows Foundation Language Pack"
2014-08-28 18:45:50, Info CSI 000001d5 [SR] Repair complete
2014-08-28 18:45:50, Info CSI 000001d6 [SR] Committing transaction
2014-08-28 18:45:50, Info CSI 000001da [SR] Verify and Repair Transaction completed. All files and registry keys listed in this transaction have been successfully repaired

My System SpecsSystem Spec
29 Aug 2014   #2
Yard Dog

Win 7 Home Premium SP1 32 bit

Hello davidb231 You may want to peruse this tutorial and use which ever option that you have not done . Post result as applicable . Worst case scenario could be other options to include a repair install or a clean reinstall . We can advise you further if this tutorial does not solve the issue : SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
29 Aug 2014   #3

32bit Win7Pro

Thank you for your reply. I had already worked through most of the guide you suggested. However, I did repeat the sfc scan this morning (both preboot and normal mode) to provide you with fresh logs. I also took time to download a win7 home premium iso from and burned that to dvd. I haven't used it yet.
Will a repair install reset the permissions? Using windows explorer, when I check the security tab of properties of the system32 folder it appears the all groups have full access except trustedinstaller which can only list folder contents. I just don't know enough about permissions to know if this situation is even of concern. I only noticed it when I realized that I didn't need take ownership of mmdevapi.dll to move or rename it. I renamed it to mmdevapi.dll.old and it let me. edit: I did rename it back.
At this time I'm about ready to do a repair install; or even a clean reinstall if you can help me get the product key info from this machine. I'd prefer not to give the owners back broken machine if I can get it fixed.
Edit: @8/31/2014 17:57 At this time I am going to go ahead with the repair install. I'll let you know how it goes.
thanks again Yard Dog for your interest.

edit:@9/02/2014 09:40 I will mark this thread as closed. Repair install seems to have done the trick.
My System SpecsSystem Spec


 SFC can't repair mmdevapi.dll and %windir% folder perms are wrong

Thread Tools

Similar help and support threads
Thread Forum
customize %windir% folder during install
Hello. How I can customize c:\windows folder to something other during installation? I tried to google it before ask, but found only customization of install folder (Program Files/ProgramData) and profiles location.
Installation & Setup
Steam needs perms to write?
Well I moved all my folders to my program files x86 they were recently on my desktop and now steam refuses to run what should I do?
%WINDIR% not working
For the last two days something has got corrupted in my system (Windows 7 Pro 64 bit). All of the shortcuts to Notepad, Paint, Explorer etc. in my Quick Start bar have lost their icons. When I click these icons I get the message: Windows Can't open this item It might have been moved,...
General Discussion
when I try to reinstall and repair windows, wrong version error
Win 7 Home Premium will not finish booting. The splash screen just starts showing a little color, when it goes to choice of system repair or start windows normally. If normally is chosen the same choices repeat. If repair system, no solution is found. Next is an option of 7 choices to manually...
Installation & Setup
Windows cannot find %windir%
Hi! I'm distraught. I have a problem and I can't resolve it. ;( It's computer in a firm and I can't reinstall Windows. When I type in cmd: echo %path% -> the answer is: %path%. When I try check environmment variables (in Advanced System Settings) I have an error "Windows cannot find...
General Discussion
Startup Repair on multiple installs - what am I doing wrong?
Hey guys, I recently rebuilt my desktop PC, so it now has a brand new (well, maybe 3-4 months old) WD 1TB HDD. I installed Windows 7 Ultimate x64 and it worked beautifully for about a month, at which point I got into a Startup Repair loop and just decided to reinstall since I didn't have any...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App