Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WEI can't get past running test "Direct3D 10 Batch Assessment"

08 Oct 2014   #1

Windows 7 Ultimate x64
WEI can't get past running test "Direct3D 10 Batch Assessment"

Hello. Hope everybody is doing fine.
So, after installing another 4GB stick of RAM and my trusted SSD, it was time for a refresh on the WEI. But before I get to that, let me take you back a few days ago, when I got myself a new laptop (), a Lenovo Z710 (i3-4000M, GT 745M, 4GB DDR3L RAM@1600 mHZ, 1TB Seagate SSHD with a 8GB SSD for caching) and since I couldn't accept its performance, I got down to business (note to self: MUST also update my system specs ).
Step 1: I installed another 4GB of RAM DDR3 from my previous laptop (you can get it on my system specs as they are now) running at 1.5v, with no problems whatsoever. Before doing this, I had checked via the trusted HWiNFO64 that the pre-installed stick was a module of dual nominal voltage so I wouldn't fry the poor DDR3L. Ran WEI, got a 7,4 score on memory (in fact I was kinda disappointed but anyways), had no BSODs, no freezes, no nothing. But the SSHD was just low (the 8 GB of caching were literally nowhere) and that was the time I decided to go to
Step 2: and get myself a new clean install of Windows 7 Ultimate x64 on a Samsung 840 EVO SSD, with EVERYTHING in order (I had a few troubles finding the right driver for my wireless adapter though but I managed ) and decided to rerun the assessment.
To my great surprise, the test can't get past the "Direct3D 10 Batch Assessment", gets stuck there for about 5 minutes, maybe more and then I got the dialog box below. I am able to play MMO's and MMORPG games without any kind of problem whatsover and without a single hint of increased temperature.
I have already tried running sfc /scannow on an elevated command prompt (3 times) without any "integrity violations", I have already followed the instructions given here Windows Experience Index - Reset and I don't know what else to do.
Any kind of help or advice from the community would be much appreciated.
Thanks and my apologies for the tl;dr post of mine :)

Attached Images
WEI can't get past running test "Direct3D 10 Batch Assessment"-wei-error.jpg 
My System SpecsSystem Spec
09 Oct 2014   #2

Windows 7 Ultimate x64

Problem solved! It seems that the culprit for the "hung" of the aforementioned assessment was the latest drivers for the Intel HD 4600 and specifically, the CMAA (Conservative Morphological Anti-Aliasing) setting under the Intel HD Graphics Control Panel, which was set to "Override Application Settings" option. I don't know if it would work with the latest drivers which include this setting because I installed the previous one, just to be safe.
For anyone out there facing the same problem but determined to have the latest drivers installed, I recommend picking the "Turn Off" or "Enhance Application Settings" option (whichever permits the Direct3d Batch Assessment to run) and re-rate his/her computer.
Hope that will help.

P.S.: I mark this thread as solved as for me it is. If anyone has any insight on this matter, please feel free to share. I would be glad to hear it.
My System SpecsSystem Spec

 WEI can't get past running test "Direct3D 10 Batch Assessment"

Thread Tools

Similar help and support threads
Thread Forum
User Experience Rating crashes at Direct3D 10 Texture Load Assessment
Hello, I just finished building a new computer last week. It runs very well, and it scored a 7.8 out of 7.9 overall on the Windows User Experience Rating. The problem I am having is that I had to reinstall windows (I messed up the first installation) and now when I try to run the assessment...
Performance & Maintenance
Problem with "D3D" or "Direct3D"
Recently i bought a new monitor to my pc, his resolution was 1366 x 768, i installed the driver and everything was okay, even through i noticed the mouse was lagging a bit on the screen, the real problem started when i tried to play games, all games displayed the same error:...
Graphic Cards
BSOD running prime95 "Blend" torture test, error 0x00000124 (Win7 x64)
Hi everyone, I just finished my first computer build in 5 years last night (my previous one being an Intel Q6600 first-gen quad-core build), installed Windows 7 Ultimate x64, installed all of my core motherboard drivers via Gigabyte's website, updated my BIOS from version F3 to F7, and installed...
BSOD Help and Support
Direct3D 9 ALU assessment Shut Down/other
Hello, Recently I upgraded my nVidia drivers (or more, it automatically did), and ever since I've been having trouble with my PC rendering Anything 3D, whatsoever. The Direct3D ALU assessment is the most basic test of it.. it can't even begin before the system shuts down. It's progressed...
Graphic Cards
"Not compatible with Direct3D" help! =O
Hi, I just installed windows 7 (build 7000) on my older dell inspiron 700m. Everything has been running smoothly except for what i believe is a video driver problem. My screen max res. is 1280x800 but it's limiting me to 1024x768 right now. I also can't do things like screensavers, because when...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:06.
Twitter Facebook Google+