Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Page file apparently not working (but no error message/notification)

10 Oct 2014   #1

Windows 7 Home Premium x64
Page file apparently not working (but no error message/notification)

Hello everyone! I've had quite a disturbing problem with my page/swap file recently. First, the story: my computer just roasted after some hardware failure (I suspected something around the motherboard or power). I sent it back to the Asus support team, they quickly changed the mainboard and bam! Not even a week later I got the old nag back. They had already made a clean reinstall of Windows 7 and I just started downloading everything again (2 years worth of Windows updates, deleting McAfee, getting back that good old Kaspersky, Net Framework 4.5.2, Spybot, blablabla&bla).
Here came the little issue, after several reboots and updates installed I thought it was time to set up the page file (a tweak that worked like a charm before having to send the PC to support to enhance its reactivity). So Computer>Properties>Advanced System Settings>Advanced>Performance>Settings>Advanced>Virtual Memory>Change. Between C: and D:, I choose the former, click customize and set the recommended 9043 min/max. Apply, okay, and such. I reboot. I open the task manager aaaand well, I'll let you take a look at the screens I attached to this post.

First of all, which one is the liar? Cause if the page file is indeed working and I just can't see it in the task manager well no biggie, it's not worth bothering you. But otherwise well.. I'd be most obliged if someone had some idea to help me get it back. By advance, many thanks!

(As a side not, I tried putting the page file in D: too, even in both, and with different or same sizes, also managed automatically, bleh, nothing worked. To be honest I wasted my whole evening -and night- on it without finding any working solution my self or online.).

Attached Thumbnails
Page file apparently not working (but no error message/notification)-screenswapfile1.png   Page file apparently not working (but no error message/notification)-screenswapfile2.png  
My System SpecsSystem Spec
10 Oct 2014   #2

Windows 7 Pro 64 bit

Welcome to the forum.

No version of Windows has ever directly shown the size of the pagefile in Task manager. But we can easily calculate it's approximate size. The commit limit is the size of the pagefile plus RAM size minus a small overhead. The commit limit is 14 GB. Subtract the 6029 effective RAM size from that and we get a pagefile of about 8 GB. Which is pretty close to what you have set.

I see nothing unusual here.
My System SpecsSystem Spec
11 Oct 2014   #3

Windows 7 Home Premium x64

Ah? It's weird it showed before, I mean on my older computer too I can't have dreamed it all this time. I'll check once I can get back to my other PC and take a screen cause you got me curious! But yup anyway thanks for the clarification, there isn't any problem finally! Have a great day/evening \o
My System SpecsSystem Spec


 Page file apparently not working (but no error message/notification)

Thread Tools

Similar help and support threads
Thread Forum
Corrupt File Error Message...
Hi guys. This is the first time I have a problem like this, but when I was trying to install a game today I got a error message at an early time during the installation that a file was corrupt. Here's the message: The following error occurred on the file 'E:/' the file or directory is...
BSOD Help and Support
Unable to extract zip file, too big apparently
Hi, I'm trying to extract a zip file that I made about 6 months ago that is 15.5GB according to Windows Explorer when compressed. However when I try to extract the file it claims it is unable to continue as it needs another 5.99PB. Obviously I don't have that much storage, but when I try and...
Inet.cpl file is being used Error message
Hello All, I keep getting this error message every now and again and cannot think why it keeps occuring. I have uninstalled and reinstalled IE9 but it still appears, can anybody suggest a solution to this? Thanks, Tek9
General Discussion
Crashing with Page file error message
Hi all, trying to figure out what is causing all my crashes, attached is the dump files, thank you much :)
BSOD Help and Support
Error Message Follows File Loading
I've got several old astronomy programs that will only run under windows xp. I have new Toshiba laptop running Windows 7 Ultimate, 64 bit on a Pentium dual core cpu with 4gb of ram. Using Windows 7 I created a new partion, an F: drive. Following the dual boot setup procedure, I'm starting from...
Installation & Setup
This file does not have a prgram..... Error Message :(
Whenever I try to download/install any software now, I get this message (Windows 7 Ultimate-64 bit) >>>>This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App