Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SFC scannow cannot repair, need help on manual fix details

30 Nov 2014   #1

Windows 7 - Professional - 64 bit
SFC scannow cannot repair, need help on manual fix details

Short version:
Built my new rig 9 months ago, fresh equipment, new copy of Win7 (Pro). Recently my computer wouldn't start up, it kept going into a BSoD loop. It would flash the BiOS screen, pause with cursor jumps, then show the low res Windows load screen with the bar scrolling blue bars instead of filling. It would then flash a very fast BSoD (too fast to read) and start over.

I booted from my Win7 install disc, and tried to use the repair function, but it said that the disc was incorrect for my version of Windows (which is bizarre, no? As I installed it from this only months ago and have not altered it beyond standard updates). I cancelled it and restarted only to have the computer start up properly. I've used this to start my computer since, though it's awkward, and has started to occasionally have issues (where it lags booting from the disc, then when I restart it goes straight to the BiOS). It's not been terminal quite yet, thankfully.

I followed the steps in this guide:
SFC /SCANNOW Command - System File Checker

Got to the point where I needed to take option 3, and used this guide:
Extract Files from Windows 7 Installation DVD

I tried taking the cue from the details file and replaced the "l3codecp.acm" files in both the System32 and SysWOW64 folders from my Win7 install disk (as these are the files that were named by the output), but it didn't work, the problem persists.

I've rerun the scan and attached the new output file. I'd really love some help fixing it correctly so I can get my computer back to healthy operation.

Because I'm fascinated and confused, I'm also curious why the computer falters on a normal start-up, but when restarting from the install disc (with install disc removed) it starts up normally. I'm sure that should point to something, but it makes no logical sense to me.

Attached Files
File Type: txt sfcdetails.txt (43.3 KB, 4 views)
My System SpecsSystem Spec
02 Dec 2014   #2

Windows 7 - Professional - 64 bit

Hoping someone can shed some light on the original problem, but it seems to have just escalated. Tonight it will only boot to the BiOS, and at first the drive was still on the boot list. I tried loading into the Windows 7 install disc toying with the idea of creating a new OS install so I could get around the corrupted files until I could fix the original, but when I went into the drive list I noticed that the HD that has my OS partition and the partition for my programs (the WD Black drive) was not on the list of available locations.

Just to make sure, I went and unplugged and replugged all my drives to make sure that everything was plugged in properly, no loose connections. Now the Black drive doesn't show up in the BiOS either. =(

Have my issues just compounded?
My System SpecsSystem Spec
02 Dec 2014   #3


Hi, it might be that the drive has failed. do you have another data and power cable to switch them out with?
My System SpecsSystem Spec

02 Dec 2014   #4

Windows 7 - Professional - 64 bit

I decided to go nuclear, wipe the OS, thankfully I created a partition on this build so that the OS was isolated from the rest of the drive for reformatting.

I wiped the partition but got the 0x80300024 error when I tried to install windows. Did some digging and found the suggestion to remove other drives besides the one being installed to.

At first the drive failed to show up, I swapped the SATA cable and it recognized the drive and is letting me install Windows.

I'll update if it doesn't go well. =)
My System SpecsSystem Spec
05 Dec 2014   #5

Windows 7 - Professional - 64 bit

Ok. There's something funky in the works and I'm not sure what. Here's the update:

Wiped the OS partition, reinstalled Win7-Pro from the install disc, and installed all the drivers for my hardware from my disks (Mobo drivers and tools, video card driver and software, DVD/BR writer software).

There was a funky error where it was booting to the BiOS. I figured out that it wasn't identifying the HD that had the OS. I tried removing HD's one at a time to see if there was a conflict with another drive for some reason, only to figure out (eventually) that just switching all the plugs to a different drive, but all still plugged in, would let it boot fine and all drives are present and accounted for.

Computer has been starting up for a few days without issue and last night when the computer pushed an auto-restart to apply Windows updates (while I was not on it), I heard it start BSoD restart looping. It was late at that point so I shut it down and started up this morning.

Here's where I stand:
  • If I let it start up normally, it gives the "failed to start" screen with options. If I choose anything (safe mode or otherwise) or let it complete the countdown, it goes to the WinXP (o.O) startup splash, BSoD's after a moment, and restarts to that same loop.
  • If I boot to the Win7 CD, and hit Repair, it says the disc is the wrong version (o.O).
  • If I boot from the install disc, cancel the install, and eject the disc when it restarts, Win7 starts up just fine.
  • Running sfc /scannow returns no issues
  • The Windows Update believes it has completely and correctly installed its updates now.

Still, there is something hinky jamming up the startup process.

Can anyone help me track down the issue? It's gone from obscure and technical to truly mysterious. I am out of my depth by a long measure.
My System SpecsSystem Spec
06 Dec 2014   #6

Windows 7 - Professional - 64 bit

Mysteries continue. This morning I tried letting it boot normally to see what would happen and it went to the Win7 "Windows Starting" splash (EXCITEMENT!) only to blink a second later into a rapid BSoD.

This time, however, it restarted into the Startup Repair function. I ran it and got the following result:
Problem Event Name: StartupRepairOffline
Problem Signature 01: 6.1.7600.16385
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: unknown
Problem Signature 04: 393
Problem Signature 05: AutoFailover
Problem Signature 06: 1
Problem Signature 07: BadDriver
OS Version: 6.167600.
Startup repair found this root cause:
A recent driver installation or upgrade may be preventing the system from starting.

Repair action: System files integrity check and repair
Result: Failed. Error code = 0x2
Time taken = 414776 ms
And from the reading I've done, the cause of BSoD's is usually something hardware/driver related. Only, I haven't installed any new hardware.

I unplugged and reconnected all my hard drives, restarted and it started up fine (without having to do the install disc reset either).

I'm fairly stumped. The inconsistency is making the root cause hard to logic out, but I'm starting to wonder if there could be something with the SATA cables at the root of this? Something in the connections? Something that could shift overnight without the case being opened or touched to work fine one day and fault the next?

It's weird. If anyone can help..........
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
SFC Log calls for manual repair
recently while attempting to figure out why my 'volume shadow copy service' kept timing out during system restore point creation, I ran sfc to see if i maybe able to fix anything, there were some files that could not be repaired: and After restarting my computer I noticed that my...
Performance & Maintenance
Sfc /scannow failed at 99%. Log details included. Kindly help. Thanks!
Hi there Sfc code experts, - I ran sfc /scannow and it failed at the 99% mark. (unable to fix corrupt file as well) Not sure if this helps, previously i was able to run Windows experience index (WEI) but not anymore since the sfc /scannow fails. - The WEI gives an error and stops at -...
Performance & Maintenance
sfc /scannow cannot repair explorer.exe
Hi everyone, I am having problems using sfc /scannow in my elevated command prompt, as it reported that errors are found but cannot be fixed, in my CBS.log. I searched "cannot repair" in my CBS.log, and it reported error with my explorer.exe. I edited it before when using custom theme...
Performance & Maintenance
sfc scannow can't repair files
Hi guys. I was having problems with my wallpaper (couldn't change it) after fresh instalation of windows and I found a solution on somewhere on the interent. (I had to delate one file). But they also said I could do scannow using cmd.exe. So I did it. in CBS..log i found sth like this: ...
Performance & Maintenance
SFC /scannow cannot repair catsrvut.dll
Howdy, I have Win7x64Ulti -Dell OEM I auto installed Sp1 in a moment of weakness (gave in to the pain of Win7). I have problems with some programs around com+ and VSS, notably Casper, but others as well so I ran sfc /scannow. Only one file shows up as a problem and Win says "cannot...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:35.
Twitter Facebook