Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Back to Win 7; now all I see is UAC notifications, much too often

04 Jun 2015   #1

Windows 7 x86
Back to Win 7; now all I see is UAC notifications, much too often

Hi folks,
I've been using windows 7 for several years, then switched to windows 8, tried it a few months and hated it, so I'm back to windows 7 (sp1, 32 bit, fresh install). The problem is that I see the UAC much more often than I remember seeing it in Windows 7 before. My memory might play tricks on me, I must admit, and maybe I just got "un-used" to UAC because I've been using Windows 8 for a while.
But still, is it normal to see the UAC if running control panel applests? I don't rememeber this was the case in the past (but again, I might be wrong).
Also is it normal to see UAC for running regedit? Also UAC seems to be really slow (like waiting 5 seconds for it to appear).
I got back to win7 from win 8 because I was remembering it as being more responsive... but now it doesn't look so anymore...

L.E. 4. No I see there are lots of posts over internet regarding unknown publisher for MS programs, but I didn't know that was my problem when I started this thread.
I've checked and KB3004394 does not appear in the installed updates list and also can't be found with everything search program on my pc.

L.E.: An update to this. I've reduced a level the UAC settings (do not dim my desktop). Now the UAC notifiocation is not modal (it allows me to focus on other tasks) and doesn't dim my desktop but it still takes 5 seconds to appear. The problem is i never remember seeing this in my previous windows installation: I am trying to run "advanced system settings" from the "system" page in control panel.
So I am trying to run a valid windows control panel applet. And yet, I get:
[titlebar]:User Account Control
[message] Do you want to allow the following program from an unknown publisher to make changes to this computer?
Program name: systempropertiesadvanced.exe
Publisher: Unknown [in bold letters]
File origin: hard dirve on this computer
Program location "C:\windows\system32\systempropertiesadvanced.exe"

WTF? I need to confirm running the system properties control panel applet?
I've applied the regedit change described here:
with no effect. The KB2918614 does not appear in the installed updates list (but can be seen in my pc if searching with everything search, it's in \Windows\serviciing\packages)
I don't get the UAC prompt for cmd.exe in normal launch; I do get it if running it as administrator.
Also I DO get the UAC prompt for regedit.exe in normal launch.
How can cmd.exe and regedit have an unknown publisher?

The windows is a repackaged window 7 x86 installation with all updates up to november 2014. It includes the update mentioned in the KB above but I'm not sure that's the problem.

L.E. 2:
I've tried running calc.exe and notepad.exe. No UAC prompt for normal run.
If I try to run calc.exe as administrator I get a UAC promot similar with the one above, with publisher: unknown. WTF? UAC for calc.exe? Publisher unknown?

L.E. 3:
I am begiining to wonder if maybe the windows ISO I used might have a rootkit. I just wanted to skip updating windows from the base version (usually that means over 100 updates and also SP1).
I had comodo antivirus installed, i did not like it but I also noticed it wouldn't automatically start. So I've replaced it with Avira, which at first -after first reboot- it did start, but after subseqent system reboots I noticed it misses from system tray (and won't start manually either).
Now I noticed windows updates do not work too (after a few successful ones, there are 50 updates but they stall downloading at 0%). There are 171 updates already installed (most of them included in the iso, I believe).
I've scanned msiexec.exe with virustotal, 100% clean, but it's path is C:\Windows\winsxs\x86_microsoft-windows-installer-executable_31bf3856ad364e35_6.1.7601.17514_none_[random characters] - is this normal?
I've tried to run (from elevated cmd) SFC /scannow but it says: Another servicing or repair operation is currently running. Wait for this to finish and run sfc again.
Nothing is running (except windows update, that is).

ok a last update:
Windows Update gave errors 8000FFFF and 8E5E0408. Background intelligent transfer service was set on manual (by me). windows update service appears as "stopping" in services list. Still I don't think this might cause the "unkown publisher" problem.

My System SpecsSystem Spec
04 Jun 2015   #2

Windows 7 x86

well it seems I'm not the only one for who avira won't start:
I suppose that's a totally different prboblem though.

sorry for the double post.

As a last update to this - i've just installed the original fresh SP1 Iso i was supposed to install (instead of the one with slipstreamed updates) and non of the above problems exist.
Avira installs fine from the first try.
Regedit does prompt UAC but the publisher is correctly identified.
Control panel applets do not raise the UAC prompt.
So all these were caused -possibly- by an included update.
My System SpecsSystem Spec
10 Jun 2015   #3

Windows 7 x86

So... it seems that the guy who packed all those updates in the ISO included some buggy updates why actually are not recommended to install (and which Microsoft later dissactivated or made unavailable). No virus or rootking or alike but just bad windows updates.
now I have a clean install which is running smooth - exactly what I was expeting from win 7
I saved several restore points and the let windoes update all the offered updates
I have absolutelly no problem.

just a final update to all this stupid story
before solving it I remember I had other problems too, someting with the digital signing or certification of various legit programs (such as some instant messanger and irfanview IIRC) - I just could not install those problems because windows was pretending they are corrupt or something; also first try of installing avira also did not work (both the install kit form the official site and from softpedia), the setup file was rejected by windows as being corrupt. (In the end I did manage to install, a slightly earlier revision I suppose, but it did not work properly - that's other story).
I didn't make the logical connection with the missing publisher when trying to run various microsoft programs suchs as regedit.
So windows was just unable to read or identify the publisher and other data (such as the valididiy of the digital signing) of various programs including Microsoft's.
Also, very strange, I could not downloand ANYTHING from sourceforge (I got a crypting error message about mirrors but I suspect it wans't sourceforge's fault). I think all these were because of the infamous update (mentioned on various forrums) that f{}cks the didignal signing of the setup files or something like dat.
I was even wondering maybe I have a corrupt ethernet card, hard drive or memory. But exactly the same setup files now work just fine.
Also last but not least SFC /scannow was not working properly, not it works.

But now, updated in steps, I noticed the offered update -of cours- do not contain the buggy ones.
My System SpecsSystem Spec

11 Jun 2015   #4

Windows 7 Ultimate x64 SP1

Don't rely on System Restore alone. Make an image with Macrium free too. Imaging with free Macrium. Keep the one you make now, and make new images every week/month depending on computer usage. Delete the older ones when you need space for the new ones etc.
My System SpecsSystem Spec

 Back to Win 7; now all I see is UAC notifications, much too often

Thread Tools

Similar help and support threads
Thread Forum
Notifications only firewall
I'm looking for a Windows 7 compatible software firewall that has a notification only mode or something that could serve that purpose. We have windows firewall disabled for a number of reasons, but what I would like is to see notifications (without actually blocking) of incoming remote connections...
Network & Sharing
Notifications not displayed
Hey, I'm using Windows 7 for a week and I haven't get used to the menu yet. I have a very stupid problem but it's very annoying. When I turn on/off sound, Wi-Fi ets. there is no notification of the action on the desktop. I can't find a menu from where to correct this. :confused:
General Discussion
IE9 notifications?
How can i disable the notifications in the yellow boxes at the bottom of the page for IE9? I just want to surf without being interupted by those just about every other website i go to And for all those IE haters out there....i bounce around to FireFox and Chrome too. So dont just jump out...
Browsers & Mail
UAC Notifications
How do you tell W7 to recognize software so that you do not get a pop-up for the same software over and over? I did have it turned down lowest setting but you lose IE protected mode. ty
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:47.
Twitter Facebook Google+