Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Stops Loading at aswrvrt.sys...

25 Feb 2016   #1

win 7 Pro 64 bit
Stops Loading at aswrvrt.sys...

I have tried starting in Safe Mode with networking several times and it always stops loading after


is listed on the screen.

I can't control-alt-delete out of it (even though the keyboard seems active, because I can turn on and off num lock and caps lock).

So I just press the power button once and it shuts down itself.

My computer had been working fine up until about two nights ago. Then for some reason I was having internet connectivity issues (I couldn't get online. Sometimes my wi-fi network wouldn't show up, sometimes it would but it would say "no internet", sometimes it woud show up, it would say connected, and it would say "internet" when you hover over the white bars, but I still couldn't visit any websites or send any emails.

So I tried booting up in safe mode, and now it stops at aswrvrt.sys

HP Compaq elite 8300
Win 7 pro 64-bit
8 gigs ram

My System SpecsSystem Spec
25 Feb 2016   #2

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

That is an Avast driver,


Are you sure about the spelling on the second one, I get nothing searching for it.

Maybe you can boot into an install disc or live cd and uninstall Avast.
My System SpecsSystem Spec
25 Feb 2016   #3

win 7 Pro 64 bit

You are correct that it is aswrvrt.sys and I did misspell it previously (I have now corrected it)

I have a re-installation disk, but I am pretty sure that is NOT what I want.

I don't have a repair disk, I don't think.

I have live disks for various Linux distros, but I don't think you want me to boot up a live Linux session to remove avast.

May I ask what disk I would need exactly? I can download on my other Win 7 box, burn it, and try to remove avast I guess.

Thanks in advance.
My System SpecsSystem Spec

25 Feb 2016   #4

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

It was just a suggestion, it is getting stalled on an Avast driver, I would uninstall Avast myself.

Maybe someone else has something you do want.
My System SpecsSystem Spec
25 Feb 2016   #5

win 7 Pro 64 bit

Hi there, derekimo:

thank you for your suggestions.

I want to do what you suggested.

I just don't know HOW to do it, since I can't boot into my computer.

Can you please explain HOW to do what you suggested?
My System SpecsSystem Spec
26 Feb 2016   #6

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Honestly, I can't seem to find a straight answer to that question, there are a few threads on the Avast forum with the same type of issue.

What they seem to suggest is something beyond my capabilities, I was close suggesting the live CD but they seem to have a couple other steps involved with other tools.

I found one thread with the same file causing the same thing but there was no outcome.

I don't feel comfortable just pointing you to a thread that has specific instructions for a different file.

This is the same file mentioned here,


The guy never reported back but someone else did, I'm not sure if you want to try that method. He's just using a linux live cd in his instructions.
My System SpecsSystem Spec
26 Feb 2016   #7

win 7 Pro 64 bit

Thank you for the link, derekimo:

I appreciate your concern in not just making suggestion if you aren't 100% sure.

I think it MAY be an avast problem, because similar to the person thread you linked to, I have had the problem where my box would not connect to the internet.

Now I have uninstalled avast on that machine, but I still can't connect to the internet.

I will start a new thread with this problem (not connecting to the internet).

But to get my machine that was stuck at the aswrvrt.sys file, what I did was something I saw somewhere else. They basically said go into yoiur bios settings and set the bios settings back to the factory default bios settings.

So I tried that and it took me to the black screen with white righting that said Windows needed to do startup repair. So I clicke that and it went into the startup repair console.

After about 25 minutes, it rebooted into safe mode.

I went into system configure and changed it to normal boot, clicked apply ( I think you need to do that) and then hit ok.

Then it rebooted normally.

But I still have no internet access.
My System SpecsSystem Spec
26 Feb 2016   #8

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Yeah, if I haven't tried something or at least know someone who has then I try to err on the side of caution.

Thanks for posting back with what worked for you, that might help someone else in the future.

Glad to hear it is booting now, hopefully you can get the internet sorted too.
My System SpecsSystem Spec

 Stops Loading at aswrvrt.sys...

Thread Tools

Similar help and support threads
Thread Forum
IE10 32 bit stops loading at start up.
Machine is a upgraded(from Vista 64 Home) Windows 7 64 bit Home Premium version. IE64 bit will load without issue. IE32 bit will not load and crashes. Windows performs the looking for solutions process. Nothing is resolved. Machines is a quad core/8 gig of RAM/Nvidia Card.
Browsers & Mail
Multiple BSOD - Computer stops before loading Win 7. Mouse cursor only
What an adventure! My computer suddenly would not load Windows. It simply went to a black screen with the flashing mouse cursor. I finally gave up and did a System Restore. (Backed up all my files, now can't recover them but I'll check into that elsewhere on the forum!!). The problem went away...
BSOD Help and Support
Application Verifier Stops Windows From Loading???
I'm a developer, but it appears I've royally screwed my machine. I was debugging my code with WinDbg (novice user) trying to figure out an issue and I ran gflags.exe and enabled the checkbox for Application Verifier. I restarted WinDbg and Windows complained it couldn't start the application. ...
BSOD Help and Support
Windows 7 ultimate stops loading
I have a home build pc msi mother board p45 neo, 2gb corsair ram, nvida geforce 9800, wd 400 hd & WD 160. After i shut down and restarted PC it states windows is staring but never loads. I tried to go in safe mode trying all their options but nothing happens, I can not go into safe mode, I...
Windows Updates & Activation
Internet Randomly Stops Loading Whilst Browsing
Hi, I just used the downloadable update (Not CD) to upgrade my legit version of Windows Vista Home Premium x64 to the new Windows 7 x64. I've been using the Windows 7 RC for a while on another partition and have not had this problem. It has only occurred on the new version of Windows 7. ...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:18.
Twitter Facebook Google+