Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 locking up, cannot run disk defrag, no system restore points

05 Jun 2016   #1

Windows 7 Professional
Windows 7 locking up, cannot run disk defrag, no system restore points

Long post alert. This started with one issue and has snowballed into several. The performance of my system (Dell Latitude E6410, Windows 7 Professional) has gotten bad in the last few weeks. I'll be using a browser and maybe one other application, or have a folder open, and everything locks up. I can't move the mouse or open Task Manager and Ctrl+Alt+Delete does nothing. I have waited up to 5-10 minutes and eventually just do a hard reset.

After doing a second hard reset today, I received this message:
Checking file system on C:
The type of the file system is NTFS.
One of your disks needs to be checked for consistency. You may cancel the disk check, but it is strongly recommended that you continue.
Windows will now check the disk.

I let it run the check and it restarted normally, so I don't think it found any issues. It did recover a few orphaned files. After that finished, I had the same issue again, so I did another hard reset and started googling. One of the troubleshooting suggestions was to start with the disk defragmenter. When I try to open that, it says "Disk Defragmenter was scheduled using another program. Disk Defragmenter is currently using customized settings created by another program. Before you can modify the schedule, you must remove the customized settings." When I click Remove settings, that box closes, but nothing else happens. I try to run it again, same message.

So I google that problem. Another troubleshooting guide starts with run antivirus/anti-spyware program. I run my Microsoft Security Essentials full scan, and it comes back with no issues.

Next step is check that disk free space is more than 10% - I have about 45% free.

Next: check disk for errors, properties - tools - check now. I rebooted and it ran the check, again no errors.

Next: open system restore and restore to a point from before the issue started happening. I open SR and I only have one restore point from 3 days ago! I know I have created more than that. I try it, but it fails due to an Adobe Reader issue.

The next step says to find the dfrg.inf file and try reinstalling. I go to look for it, and it's not there. So I try another angle, looking at the task scheduler to see if maybe defrag is scheduled there. When I open it, I get 76 pop-ups in a row, each showing the name of a task and saying the task image is corrupt or has been tampered with.

Amazingly, my system hasn't locked up once since I started typing this, but now I feel the need to address all of these other issues!
1. Disk defrag not running and can't find file to reinstall
2. Restore points not being created and/or saved
3. All of my tasks (or task image?) being corrupt

Where to start?

My System SpecsSystem Spec
05 Jun 2016   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot

I would start by downloading MalwareBytes and doing a full scan with it:
My System SpecsSystem Spec
07 Jun 2016   #3
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Welcome to our forum hkingbomb.

Just some ideas off the top of my head.
Using Malwarebytes mentioned by Mellon Head is a great idea.

**What operating system came with this troubled computer from Dell?

A tutorial by Brink that could be helpful. Can't hurt.

SFC /SCANNOW Command - System File Checker

Completing this tutorial by Golden exactly as the tutorial states could show us some information that might be helpful.

Disk Management - Post a Screen Capture Image
My System SpecsSystem Spec

11 Jun 2016   #4

Windows 7 Professional

Hi Mellon, I ran MalwareBytes as you recommended and it returned 9 "Potentially Unwanted Programs". 2 Registry values, 2 Registry keys, 2 Registry data, 2 folders and 1 file. Those are all removed now.

Layback, my OS is Windows 7 Professional. I completed the tutorial and it did not find any integrity violations. That's good!

I also just checked to see if the restore point I created the other day is in System Restore, but it's gone, as is the one from 8 days ago that I mentioned in my original post. There is only one from 3 days ago now. Also still having the issue with disk defrag saying it is in use.

Thanks for your help so far!
My System SpecsSystem Spec
16 Jun 2016   #5

Windows 7 Professional

Any suggestions for other things to try? Still having the same issues. The system locked up for about 20 minutes yesterday until I gave up and did a hard reset.
My System SpecsSystem Spec
16 Jun 2016   #6
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I did not ask what Windows 7 you have installed.
I ask what Windows 7 did this troubled computer come with.

I also asked for a picture using this Tutorial by Golden.

Disk Management - Post a Screen Capture Image
My System SpecsSystem Spec
20 Jun 2016   #7

Windows 7 Professional

Somehow missed your second link about the screen shot, but it's attached now.

This troubled computer came with Windows 7 Professional. That's how I purchased it, I didn't install it, nor did I mention that I installed it. Sorry for any confusion.

Attached Thumbnails
Windows 7 locking up, cannot run disk defrag, no system restore points-capture.jpg  
My System SpecsSystem Spec
20 Jun 2016   #8
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I'm no security expert so I'm going to request your thread be moved to our security section.
I believe that you are still infected and/or the damage done by your previously found infection is still there.

You should get better help there with security problems.
It would be very helpful if you could post what infections were found using Malwarebytes. I will also see if I can get a security expert to take a look.

I know what I would do if it was my computer but it's not my computer so I will just watch how the expert handles your problem.
My System SpecsSystem Spec
21 Jun 2016   #9

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

1.1 GB System Reserved!! I never had it more than 100 MB, I knew some users got it 200 MB too.
Moreover, 33% of it is occupied!!

IMHO it is the right time to go for a clean install.
My System SpecsSystem Spec
21 Jun 2016   #10

Win-7-Pro64bit 7-H-Prem-64bit

Review Jacee’s instructions to run Adwcleaner here post #7,
Ignore the title of the thread,
Instant Savings App
On the BleepingComputer site use the button that looks like this,

Did you select scan for Rootkits in malwarebytes ?
Scan/ Custom scan/ Configure scan
Windows 7 locking up, cannot run disk defrag, no system restore points-mbam-scan-rootkits.jpg

My System SpecsSystem Spec

 Windows 7 locking up, cannot run disk defrag, no system restore points

Thread Tools

Similar help and support threads
Thread Forum
Deleting System Restore Points Selectively - disk usage
Hi, Thank you for WindowsSeven forums. I have just registered but during the last 6 months or so I have used the resources provided here - particularly the tutorials - to set up my Wndows Home Premium x64 system. Looking at one of the tutorials:...
Performance & Maintenance
Windows 7 System restore problem no restore points
I have seen numerous people are having this problem but I have not been able to find a solution that works for me. I figured I would post my own problem and maybe somebody could recommend a solution. I have been trying to use Windows System Restore on Windows 7 Home Premium. I have created...
Backup and Restore
Windows Update & System Restore Points BUG !?
hi ! 2 days ago on 100830 (Aug 30) i restored my system to a System Restore Point created a few days earlier, on 100826 (Aug 26). as i understand it, everything that has been installed AFTER the System Restore Point are then lost, including security-patches from Windows Update etc. ...
Backup and Restore
no system restore points on windows 7
hey there. i installed some dud fonts that stopped programs working,but went to system restore and there were no system restore points. now i have to reinstall windows. please help why did the restore points vanish?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:07.
Twitter Facebook Google+